Items tagged with classic classic Tagged Items Feed

sometimes when I download something from Maple apps centers, such as this package, http://www.maplesoft.com/applications/view.aspx?SID=33406  I find the example documents there are written in .mw and when I open them, there are in document mode style, the fancy word like style which I can't stand looking at.  It has all the math input in italic and maple commands look different from classic Maple text. It very confusing, since I see something as   (0<x<1) which is valid in this document mode, but in classical maple, this is not valid code.

 

It seems Maple has 2 different syntax. One that works in document mode and one that is classical text maple.

I like to use only input as Maple notation which these documents do not do.

Is there a way to convert such .mw file to become standard classic worksheet mode? I know I will lose the chapter/section heading and all that.  I also tried selecting all in the document, then did Tools->options->Display->Input display->Maple notation, but nothing happend to the open document. It remained document mode with 2D math input.

When I save it as .mws, and open it again, it remains on document mode.

How to convert such documents to classical Maple syntax?

 

 

Is there a way to open a classic worksheet in macintosh, even running windows through a virtual machine?

I am using "Maple 15" and "Windows 7" and I want to share the tip for using "Classic worksheet" and "GR Tensor". Windows 7 is 64-bit but you can use Classic worksheet and GR Tensor, which work basically in 32-bit, by simply downlording "32-bit Maple 15" !! I haven't tried other more current versions of Maple but Maple 15 works well: you can choose 32-bit Maple in the download options.

Enjoy the Classic worksheet and GR Tensor. Good luck !  

Greetings!

I only recently started to work with Maple17 and tried to test the Explore command. In Classic worksheet I tried a very simple function with a parameter, but after setting the inteval of the parameter in the Java pop-up window I have no result. In return I take: "Error, (in Explore) invalid input: rtable_dims uses a 1st argument, A (of type rtable), which is missing"

Has anyone encounter the same issue before?

Thanx

Maple people:

 

I just installed Maple 16 on my home PC.  I prefer using Classic Worksheet Maple, so that I can actually tell what I have typed, and what I type appears in red typewriter font.  I also would like matching parentheses to blink when I enter stuff so I enter the right number of parentheses.  Maple works this way on my office PC, but I can't get it to work this way at home.  I could simply use regular Maple 16 (not Classic Worksheet...

Hi,

 

Recently, I upgraded from Maple 13 to Maple 16.  I have been using Maple for 20 years --- Maple V Release 2 (1992) through Maple 16 (2012), and I participated in beta testing Maple V Release 4, which developed what we now call the Classic Interface.  The Classic Interface is amazing --- it was better than Mathematica in 1994 and it is still better than Maple's Standard Interface.  The Standard Interface is missing features that were...

I found some old Maple 6 worksheets that I wrote in 2003 and I want to see what's in them and probably transfer at least some of the content to new worksheets.  Most of them I can view just fine with Maple 16 standard interface but at least one of them comes out looking like all of the lines have been printed on top of each other --- completely illegible.  Now I can read the worksheet using Maple classic interface on my machine at home, but both of my machines at...

A user recently sent to me a Maplet that includes the display of an array of plots. This maplet works fine when run under the classic interface but not under the standard interface. As I tried to understand this problem I believe I have narrowed it down to a difference in the way the classic and standard interfaces handle an array of plots.

The attached worksheet is a very simplified example that shows the problem. What should happen is that pressing the "Plot single" button should show a single graph, pressing the "Plot array" button plots the empty axes, and pressing the "Plot displayed array" button displays a 2x2 array of plots. The second and third buttons illustrate the need for "plots:-display" in the action definition for this button.

Unfortunately, this works only in the classic interface. In the standard interface the "plot displayed array" button does not display anything. I should add that it appears to work correctly when exported as a .maplet file and run with the Maplet Viewer.

I have uploaded the worksheet: PlotArrayMapletDem.mw

Hi:

For many reasons, until recently, I have been always using Classic interface under Maple through Maple 16. When trying Maple 16 with Java interface I have noticed several quirks which were not present under the Classic interface of earlier versions through (at least) Maple 13. One of them is this:

The shortcut keys such as CTRL+Insert and SHIFT+Insert do not work and I am forced to use a mouse and copy/paste icons in Maple. This really slows down my keyboard...

I would appreciate a hint why Maple 16 Classic under Win XP 32 bit crashes due to the following sequence of commands

> dir1:="C:\\Maple16\\P16\\test1\\";
> path:=cat("dir ",dir1);
> ssystem(path);

with the lasst ssystem command doing the crashing while the same sequence of commands under Maple 13 Classic does not: Instead, system returns to Maple 13 worksheet the content of the directory "dir1" as expected.

Is there another way to issue that ssystem command?

That's the question... 'cause I've tried to open it using

./maple14/bin/maple -cw

like a thousand times and nothing happens...

I was solving one Math puzzle and found out a strange behaviour of the Optimization package commands in the Classic Worksheet.

Let us minimize the function 7*x+3*y under the constraint 6*x+2*y >= 49 for non-negative integers. When I type

Optimization:-Minimize(7*x+3*y, {6*x+2*y >= 49}, assume = nonnegint);

Maple 15, Windows7x64, Standard v. Classic

I have noticed that, on my system, the smoothness of some INLINE plots is better in Classic than in Standard. Is this some regression or some installation-specific quirck I wonder?

In Tools->Options, I have plot anti-aliasing enabled (whatever that is).

This looks alright in Classic

plots:-implicitplot(
  [ x^2 + y^2 = 1, x^2 + y^2 = 2 ]
  , x = -2 .. 2
  , y = -2 .. 2

Dear guys! It seems to me that we can not use "subs" after solving an ODE system by method=classical[rk4]. Am I right? If your answer is yes then how should Ido instead? 

The problem has been discussed in mapleprimes before, but I have not come across a neat solution. Perhaps there is one. What is the state of the art for exporting 3D graphics (plot3d, etc.) with Maple 15?

What I think I know is this: standard GUI has a completely new way of treating 2D graphics but has an outdated way of rendering 3D, while the classic GUI, though no longer developed, for some reason typically renders better 3D graphics.

I used to export graphics...

1 2 Page 1 of 2