MaplePrimes Questions

How do I plot a volume of revolution? I can plot other volumes using Student[Calculus1]]:-VolumeOfRevolution, but not this one. I get a blank plot. I do get the correct volume from output=value..

How do I plot this using plot3d?

a := 0; b := 1;
f := (x) -> x^2+2;
g := (x) -> 1/2*x+1;
V := int(f(x)^2 - g(x)^2,x=a..b)*Pi;

I was having this problem with Maple Flow 2021, and just purchased Maple Flow 2022 but am still having this problem.

I define a variable, using := and an equation (that itself uses other variables that have been assigned a numeric value) and end it with an = and it is clear that the variable has a numeric value successfully assigned to it.

Lower down in the document, I use this variable, but it isn't recognized as having any numeric value or having been previously definied at all and when evaluated it stays in symbolic form.

I have tried deleting variables, renaming them without subscripts, retyping equations, etc. and nothing seems to work. Oddly most of the variables work, but some won't even though there doesn't seem to be anything special about them.

Any thoughts or advice would be greatly appreciated.

I cannot plot the **erf** function, please see below, what's wrong ?


Suppose I have a matrix representing a magma such as

matrix(n,n, (i,j)->E[i].E[j])

First, if E is a set of integers then . is converged to * for some reason.

Second, is there any way to simplify the presentation of this matrix? I am using subs to simply but I have to essentially hand code every entry which sort of defeats the purpose. Is there any way to present a matrix and then have the resultant simplified as far as possible?

E.g., subs does not allow one to do something like ?.E[3] = E[2] where ? represents any value. E.g., if I have an identity it would be nice to simplify all elements quickly with one expression rather than having one for all possibilities(essentially 2n).

Also, magma's only let positive integers which seems kinda restrictive(why not create map internally to handle it?).

Also, is there any way to use special chars like -? I'm using d but I'd prefer using special chars so it is visually more congruent to what I'm doing. I realize - is also a minus but maybe there is someway around it(unicode?)?

Hello everybody! Happy new year!

Allright, well, the question states the following: "What is the maximum product of the fromula x*y*z which has the sum of 6 if you add x, y, and z together".

Now, i am seeing what they are doing, but somewhere down the line in the explaination they say "(after some calculations)". 

Isnt there a faster way to do it? And what did they do in the example to get to the result?

Thank you very much!


The Function    

solve(x+y+z = 6, z)









diff(-x^2*y-x*y^2+6*x*y, x)



convert(-2*x*y-y^2+6*y, 'horner', y)



solve(-2*x*y-y^2+6*y = 0, y)

0, -2*x+6


y := 0; solve(-2*y+6 = x, x)






diff(-x^2*y-x*y^2+6*x*y, y)



convert(-x^2-2*x*y+6*x, 'horner', x)



solve(-x^2-2*x*y+6*x, x)

0, -2*y+6


x := 0; solve(-2*x+6 = y, y)







I have just installed the Google Maps package but when I run the commands I only get empty results and some errors

Any thoughts of what can be wrong. Have latest Montery OSX 


I have a system of first order ODEs to solve using ODEplot. Now, need to plot one of the dependent variables by varying the initial condition. How do I go about this?

Dear Forum,

I get data from a mass-spectrometer and want to do some analysis on it . 

What I get looks like this : ( only a few lines, the files are very large )

t[s]; scanId; m/z; I[A]; pTot[mbar]
2.00;0;0; 0.000000e+000; 0.000000e+000
4.00;0;0; 0.000000e+000; 0.000000e+000
441.00;0;0; 0.000000e+000;1,29E+00
443.00;0;0; 0.000000e+000;1,29E+00
453.00;0;0; 0.000000e+000;1,26E+00
455.00;0;0; 0.000000e+000;1,24E+00
463.00;1; 0.390625;8,14E-05;1,23E+00
464.00;1; 0.40625;1,23E-04;1,43E+00
464.00;1; 0.421875;1,73E-04;1,43E+00
464.00;1; 0.4375;2,27E-04;1,43E+00
464.00;1; 0.453125;2,77E-04;1,43E+00

When I add some blanks, it looks like this :  

t[s];        scanId;   m/z;              I[A];               pTot[mbar]

464.00;  1;           0.421875;     1,73E-04;     1,43E+00

The columns are separated by semicolon

t[s]  and m/z are separated with a dot,  I[A]  and p come as exponentials with a comma.

When I try to import this  with

 BKK := Import("H:\\Maple\\Spielwiese\\BGSample.csv")

I get a DataFrame with two columns -correct-  because there are two commas. 

Is there a way to import such data without preprocessing into maple ?

I include the data file, had to change the suffix to .txt - the original is .csv

Thank you and kind regards, 


BKK := Import("H:\\Maple\\Spielwiese\\BGSample.csv")

module DataFrame () description "two-dimensional rich data container"; local columns, rows, data, binder; option object(BaseDataObject); end module


BKK[10, 1] = 27.NULL



I often want to export an expression from Maple to LaTeX. Often, the output will contain commands that my LaTeX compiler doesn't recongnize. This hinders my LaTeX document production efficiency greatly. I use MiKTeX and Texmaker to generate documents in LaTeX language. Naively I assumed that Maple sticks to core LaTeX packages when generating an output. I still don't know if that is the case. The main issue is that, I don't know which LaTeX packages some of the Maple outputs use, and so, I don't know which packages to load in my LaTeX document.

As a concrete example, I show how I convert an expression to LaTeX language and how that particular output contains commands: \iup and \idn which are not recongnized by my LaTeX compiler since I don't know which package these commands come from. I google search for commands \iup and \idn came up empty. How do I figure out what package these commands come from


I have been trying to figure this out for a long time and can't find anyone else having the same problem.

I use the built-in unit system for assigned values (short-cut is Ctrl+Shift+u) a lot when doing electronics calculations and electromagnetism, so I often use resistances and therefore need to use Ohm. This is very often an option in the "Choose Unit" drop-down menu on the right, but when too many units are brought into the same calculation the option dissappear. Usually I the go to the "Enter Unit" menu as to write the unit out myself I cannot figure out a way for it to accept greek letters. Does anyone know what to do?

I am a little not clear why Maple's odeadvisor gives [_2nd_order, _reducible, _mu_xy] as an ode type for a second order ode which is already exact as is.

When the ode is exact, then no integrating factor mu is needed (or rather mu=1). But Maple says the ode is "reducible" using an integrating factor mu(x,y)



THis ode is Kamke's 6.78, it is alslo mentioned in this paper in table 1 at page 18

I am just little confused, about the terminology. I thought reducible means the ode reguire an integrating factor of the form mu(x,y) or my(x,y') or mu(y,y') when it is not exact in order to make it to an exact ode so it can be now solved.

Why would odeavisor then says an ode which is already exact is also reducible using mu(x,y)?

 How to rectify the Error, (in MTM:-findsym) invalid input: a string/name list is expected for sort method `lexorder`   .Could you please help me to plot the curve.

Are Maple settings responsible for this error:

My worksheet carries out some preliminary checks and if these fail I want to prevent or cancel any further executuon of the worksheet.  Something like (pseodo-code)

llContinue = DoThePreliminaryChecks()
If Not llContinue

I couldn't find anything in the docs or with Google.  Any suggestions?  Thanks.

Mathematica's Dimensions returns a list of the allowed levels, which has been implemented in Maple as . But 

MmaTranslator:-Mma:-Dimensions(<<1 | 2>, <1 | 0>>);

returns [6], and 

MmaTranslator:-Mma:-Dimensions([[1, 2], [1, 0]]);

returns [2, 2, 4]. What happened here?

It should be [2, 2].


MmaTranslator:-Mma:-Dimensions(linalg[matrix]([[1, 2], [1, 0]]));



MmaTranslator:-Mma:-Dimensions(< 1 , 2 ; 1 , 0 >);



MmaTranslator:-Mma:-Dimensions(convert(`{{1, 2}, {1, 0}}`, FromMma));

[2, 2, 4]


MmaTranslator:-FromMma(`Dimensions[{{1, 2}, {1, 0}}]`, evaluate);

[2, 2]



Download Mma[Dimensions].mws

First 25 26 27 28 29 30 31 Last Page 27 of 2211