MaplePrimes Questions

Hi,

I am a newbie in Maple. I have the following code

with(LinearAlgebra):
w := (2*Pi)/14
v := Vector([1, sin(w*t), cos(w*t)])
simplify(sum(v . (Transpose(v)), t = k .. k + 13))

Even with some less advanced CAS I get that the result is a diagonal matrix with constant elements. However, I failed to properly tune the simplify command to get such a result. What I am doing wrong?

I have two questions:

1) How can I select only parts of an equation in a Maple Workbook? E.g. I have

4*x^2*(1 + x)^2*(x^2 + 6*x + 1)

and I want to select the text between the first "2" and the "6", but Maple always extends the selection to include the complete bracket. This is very annoying :)

2) How can I copy text from a maplesoft page into a workbook. E.g. I'm looking at

https://www.maplesoft.com/support/help/maple/view.aspx?path=updates/Maple2021/ODEsandPDEs

and I would like to select and copy some of the shown examples so that I can use them.

I believe I have found a bug or unintended behaviour:

The following second-order DE:

mplinput := ((x^4 + 4*x^3 + 10*x^2 + 4*x + 1)*diff(y(x), [x $ 0]))/(4*x^2*(1 + x)^2*(x^2 + 6*x + 1)) + 2*(x^2 + 5*x + 2)*diff(y(x), [x $ 1])/((1 + x)*(x^2 + 6*x + 1)) + diff(y(x), [x $ 2])=0:

can be solved by

with(DEtools):
hypergeometricsols(mplinput);

in terms of hypergeom functions. However,

dsolve(mplinput, [hypergeometricsols]);

does not find a solution, although it is supposed to use the same algorithm. One can trace this back to the sub-algorithm 'DEtools/2F1: --- find_2f1 ---' which is apparantly used by hypergeometricsols, but not by dsolve.

Another thing is that dsolve(mplinput, [hypergeometricsols]) in fact works in Maple2020, but does not in Maple2021 and Maple2022.
 

Hi, 

I installed syrup within Maple 2022 according to the procedure described in syrup's README file. The installation seems to run normally. After that I restarted Maple. When I now enter

with(Syrup);

it shows

[Draw, Library, Print, Solve, ToModelica, ToSpice, Version]

instead of 

[deindex, makecheckttable, printdeck, reindex, syrup]

as described in the application center: https://www.maplesoft.com/applications/Preview.aspx?id=4680

Also the example which is decribed there doesn't work:

syrup(divider, dc, 'curr');

delivers no result.

I'm working on Windows 10 64 bit.

Could it be that syrup is not yet prepared for Maple 2022, as it seems not to be updated for a long time? Or is the description in the application center not up to date?

Many thanks for your help!

Best regards,

Michael

 

Hi,all

I am new in Maple,when I execute the "InversePlot" command ,all functions were correct except for exp(x), error occurs as follows, can anyone tell me what mistake I took?

Tks in advance!

restart;
with(Student[Calculus1]);

InversePlot(exp(x), -1 .. 1);
Error, (in Student:-Calculus1:-InversePlot) module does not export `IsTrigProc`

 

Tks for all you guys. 

I have uninstall Maple and deleted the installed directory ,clear the register,reinstall Maple 2022, now all works well.

I think the problem is I installed Maple 2022 in the old directory of 2021for keeping my configuration,this caused much unexpected problem

I want to create a variable that is made up of a letter and an arrow on top. How to do that?

Also, how can I create a variable that is bold? I tried to type it as bold and then assign. But when I hit return it returns a normal symbol.

How to distinguish between a scalar variable and a vector variable in Maple?

Hi,

I want to solve a differential equation and plot the particle densities versus the distance.

How can I do this in Maple?

DE.mw

Sincerely

Suppose I want to calculate gcd(g(x),f(x))=a(x)f(x)+b(x)g(x) for two polynomial, i.e finding the RHS representation of the gcd, then how to implement this in maple?

I know of the command GCD(f(x),g(x)) but how to find the RHS representation?

Thanks!

Many formulas use a capital D to define parameters. A popular example is the second moment of area "I" of a tube. In Maple we get

Both I and D are protected symbols in Maple and are therefore printed in roman. With the "local" command, I and D can be used as unprotected symbols. However, only the unprotected "I" is printed in italic (like other symbols or names do). D is still printed in roman, which spoils Maple's excellent printout (a bit).

I hope this inconsistency can be improved one day. For the time being, I am looking for better alternatives than my workaround with a fat white space in the attachment. Are there better workarounds?

Italic_I_and_D.mw

primes_integrale_exp.mwThe integral in x of 

exp(-sqrt(x^2 + c))

was done by Maple 11 but return unevaluated in Maple 2021,

see attached worksheet 

I am trying to solve the equation in the attached Maple file, but Maple cannot return a result.

 

restart

Digits := 30

30

(1)

with(plots)

[animate, animate3d, animatecurve, arrow, changecoords, complexplot, complexplot3d, conformal, conformal3d, contourplot, contourplot3d, coordplot, coordplot3d, densityplot, display, dualaxisplot, fieldplot, fieldplot3d, gradplot, gradplot3d, implicitplot, implicitplot3d, inequal, interactive, interactiveparams, intersectplot, listcontplot, listcontplot3d, listdensityplot, listplot, listplot3d, loglogplot, logplot, matrixplot, multiple, odeplot, pareto, plotcompare, pointplot, pointplot3d, polarplot, polygonplot, polygonplot3d, polyhedra_supported, polyhedraplot, rootlocus, semilogplot, setcolors, setoptions, setoptions3d, shadebetween, spacecurve, sparsematrixplot, surfdata, textplot, textplot3d, tubeplot]

(2)

with(Statistics)

NULL

say the f(x) is a Beta with parameters alpha and beta

 

alpha := 10

10

(3)

beta := 100000

100000

(4)

"f(x):=PDF(BetaDistribution(alpha,beta),x)"

proc (x) options operator, arrow, function_assign; Statistics:-PDF(BetaDistribution(alpha, beta), x) end proc

(5)

f(x)

piecewise(x < 0, 0, x < 1, x^9*(1-x)^99999/Beta(10, 100000), 0)

(6)

NULL

semilogplot(PDF(BetaDistribution(alpha, beta), x), x = 0 .. 1)

 

 

fsolve(int(f(x), x = 0 .. y) = .1, y = 0 .. 1)

Download test_fsolve_integ.mw

On a shared cluster with 32 CPU cores, how do I limit Maple (called from the Linux command line) to use only 8 cores? (Certain built-in operations in Maple are parallelized by default.)

I try to sove the equation x^2-10*y^2=9 with tne procedure : 
genpellsolve := proc(D::posint, N::integer)
local t, u, L1, L2, sols, x, y;
if type(sqrt(D), integer) then error "D must be a nonsquare integer"; end
if; t, u := pellsolve(D); if 0 < N then L1 := 0;
L2 := floor(sqrt(1/2*N*(t - 1)/D)); elif N < 0 then L1 := ceil(sqrt(-N/D));
L2 := floor(sqrt(-1/2*N*(t + 1)/D)); else return {[0, 0]}; end if;
sols := {}; for y from L1 to L2 do x := sqrt(N + D*y^2);
if type(x, integer) then sols := sols union {[x, y]};
if (x^2 + D*y^2) mod N <> 0 or (2*x*y) mod N <> 0 then sols := sols union {[-x, y]};
end if;
end if;
end do;  return sols;
end proc:
This procedudure fails; I don't see why. Thank you for your help.

First 87 88 89 90 91 92 93 Last Page 89 of 2195