MaplePrimes Questions

I am trying to create a loop in the Physics package where I am interested in looking at the components of a tensor with one index up and one down. However, when I run the loop it returns the expression with both indices down in my attempts to solve the issue.

I have been fighting with it for an hour now and cant seem to find a fix. Any help will be appreciated, I have attached the file I am working with. 

Thanks in advance. 

LoopQuestion.mw

The following differential equation occurs during blending of two fluid in a continuous flow stirred tank

I want to replace the quantities in parenthesis on the RHS with the following variables (so-called deviation variables) where the overbar variables are constants and x1, x2 and x are variables.

When I use the subs command or algsubs command, it doesn't perform the substitution.

What is the best way to perform this operation?

Given a excel sheet with data for regression as input column Y will be a dependent variable 

 

Say a maximum of 120 independent variables are their 

 

A function that takes excel as input with headers as in the excel file

 

Do pick all possible subsets of maximum size 5 that is sizes 2,3,4,5 only 

Pick each and eleminate not to store them all together as otherwise storage will be a problem if more data

 

Copy only those subsets of independent variables to seperate seperate sheet

Only those subsets 

where the variables are independent pairwise between them

 

Step 2 function 

Then need to run a multiple linear regression on these subsets like training and test 

And choose the best models I each of cases of number of variable

That is best with 2 variables

Again with 3 variables

Similarly 4 and 5

 

Atleast if possible upto 2 to 3 variables it will be good kind help with your guidance and what is possible 

 

If you are not able give the program of train test regression with charts no issues 

 

Kind help with atleast storing the independent pairwise subsets of size 2 and 3 into seperate sheets in a Excel file atleast

I will do the regression at my end 

I'm trying to solve a system of differential equations and encountered this error: Error, (in fsolve) {f1[0], f1[1], f1[2], f1[3], f2[0], f2[1], f2[2], f2[3]} are in the equation, and are not solved for. How can this error be rectified?

For example when I run a worksheet, if there is an error, maple simply prints the error and moves on to the next step. Is there a way to do that with loops.
The try and catch statements are a bit cumbersome and sometimes you have to predict the kind of error statements you may face.

Dear all

I  have a PDE, I would like to substitute the funciton T by another funciton 

How transform the old PDE to a new PDE

transfirm_equation_using_change_variable.mw

thank you

I will have excel sheet with minium 500 coulmns and 1000 rows say

For sample to explain my question I attach a demo excel

All my columns have headers

I am looking to find all 2 way multiplication and add them as columns to my excel sheet and return it as a new excel sheet say

The column names for the new 2 way column should be like the

header name of column you are multiply * the name of the other columsn

Now in sample file if i multiple column with name A with column with name B I get a new column with header A*B the header name should be inserted and

Below that all the elements of that A column multiplied  with that of B should come

I am looking to form columns for all possible2  way multiplication for the excel I will give.

As you can see the demo file

Excel_to_explain.xlsx

Kind help please

Hello!

I have changed the the global character size from 12 to 14 but it is not stable. Suddenly size 12 is coming up when a try to copy a row to a another row in the same worksheet.

It is very annoying!!

Any tips????

Regards

Kjell

Here is an apparent instance: 

interface(version);

maximize((1+20230321)*x*y-(x^2+y^2)*(1/2))``

`Standard Worksheet Interface, Maple 2023.0, Windows 10, March 6 2023 Build ID 1689885`

 

0

(1)

NULL

Download incorrectAgain.mw

Why???
Quite evidently, its supremum cannot be 0. (There are, of course, other approaches to compute it symbolically, yet I just wonder about the cause of this bug.)

Dear all

I have an equation obtained from partial derivable of some functions, I would like to compute the limit when my variable named Pe goes to infinity. 

I hope to get a more appreciate presentation of my code to obtain the limit (  Pe -> + infty)

limit_infinity.mw

All derivative are well compute, but How can I add the limit as Pe goes to infinity

Thank you 

Hey everyone,

I've been experiencing some issues with Mapleprimes on my laptop. Whenever I try to access the website, it takes an unusually long time to load, and sometimes it doesn't even load at all. This is quite frustrating as I need to use Mapleprimes for my research work. I've tried accessing the website on other devices, and it works fine, so I'm confident that the issue is with my laptop. Has anyone else experienced this problem? Any suggestions on how to fix it?

Thanks in advance for your help!

Why doesn't Maple simplify sin(x) / cos (y) as tan

restart

with(plottools)

with(plots)

with(CurveFitting)

Digits := 10

with(GaussInt)

w := GInearest(0+I)

I

(1)

NULL

"f(t):=7.0*(e)^((-(t-13180)^(2))/(2000000))+4.7*(e)^((-(t-16000)^(2))/(3200000)):"

p1 := plot(f(t), t = 0 .. 20000, color = green); plots[display]({p1})

 

NULL

D1 := 15

epsilon := 200000

L := 6500

v := .7

.7

(2)

t := 10000

10000

(3)

i = sqrt(-1)

i = I

(4)

"k(n) := evalf((2 *Pi*n)/(L))"

proc (n) options operator, arrow, function_assign; evalf(2*Pi*n/L) end proc

(5)

f(n) = (int(f(t)*exp(-w*k(n)*x), x = 0 .. L))/L

NULL

"C(x, t) :=  (∑) exp(-v* t*k(n)- D1 *t*(k(n)^())^(2)- epsilon *t*(k(n))^(4)) *f(n)* exp(w*k(n)* x)"

proc (x, t) options operator, arrow, function_assign; sum(exp(-v*t*k(n)-D1*t*k(n)^2-varepsilon*t*k(n)^4)*f(n)*exp(w*k(n)*x), n = 1 .. 10) end proc

(6)

uu10000 := [seq(evalf(C(L-j, t)), j = 0 .. 6500, 100)]

[0.8582270020e-37+0.7071768085e-46*I, 0.8542115620e-37-0.8289193755e-38*I, 0.8422030662e-37-0.1650065052e-37*I, 0.8223146210e-37-0.2455737186e-37*I, 0.7947335229e-37-0.3238382907e-37*I, 0.7597194496e-37-0.3990668010e-37*I, 0.7176019535e-37-0.4705546418e-37*I, 0.6687772885e-37-0.5376326775e-37*I, 0.6137045955e-37-0.5996735584e-37*I, 0.5529014934e-37-0.6560976155e-37*I, 0.4869391210e-37-0.7063782859e-37*I, 0.4164366719e-37-0.7500470239e-37*I, 0.3420554942e-37-0.7866976371e-37*I, 0.2644927960e-37-0.8159900244e-37*I, 0.1844750367e-37-0.8376532722e-37*I, 0.1027510610e-37-0.8514880864e-37*I, 0.2008503850e-38-0.8573685436e-37*I, -0.6275071112e-38-0.8552431450e-37*I, -0.1449829443e-37-0.8451351706e-37*I, -0.2258447115e-37-0.8271423331e-37*I, -0.3045824843e-37-0.8014357420e-37*I, -0.3804631338e-37-0.7682581907e-37*I, -0.4527807059e-37-0.7279217843e-37*I, -0.5208629116e-37-0.6808049422e-37*I, -0.5840773014e-37-0.6273487939e-37*I, -0.6418370476e-37-0.5680530177e-37*I, -0.6936062957e-37-0.5034711554e-37*I, -0.7389050434e-37-0.4342054446e-37*I, -0.7773134955e-37-0.3609012248e-37*I, -0.8084758661e-37-0.2842409660e-37*I, -0.8321035975e-37-0.2049379645e-37*I, -0.8479779638e-37-0.1237297776e-37*I, -0.8559520434e-37-0.4137144557e-38*I, -0.8559520435e-37+0.4137144402e-38*I, -0.8479779639e-37+0.1237297769e-37*I, -0.8321035979e-37+0.2049379630e-37*I, -0.8084758664e-37+0.2842409653e-37*I, -0.7773134957e-37+0.3609012242e-37*I, -0.7389050442e-37+0.4342054433e-37*I, -0.6936062961e-37+0.5034711548e-37*I, -0.6418370481e-37+0.5680530171e-37*I, -0.5840773026e-37+0.6273487928e-37*I, -0.5208629121e-37+0.6808049418e-37*I, -0.4527807065e-37+0.7279217840e-37*I, -0.3804631352e-37+0.7682581900e-37*I, -0.3045824850e-37+0.8014357418e-37*I, -0.2258447130e-37+0.8271423327e-37*I, -0.1449829450e-37+0.8451351705e-37*I, -0.6275071183e-38+0.8552431450e-37*I, 0.2008503694e-38+0.8573685437e-37*I, 0.1027510603e-37+0.8514880865e-37*I, 0.1844750360e-37+0.8376532724e-37*I, 0.2644927944e-37+0.8159900249e-37*I, 0.3420554936e-37+0.7866976374e-37*I, 0.4164366713e-37+0.7500470242e-37*I, 0.4869391201e-37+0.7063782866e-37*I, 0.5529014927e-37+0.6560976160e-37*I, 0.6137045944e-37+0.5996735595e-37*I, 0.6687772877e-37+0.5376326784e-37*I, 0.7176019529e-37+0.4705546426e-37*I, 0.7597194490e-37+0.3990668022e-37*I, 0.7947335225e-37+0.3238382916e-37*I, 0.8223146207e-37+0.2455737195e-37*I, 0.8422030659e-37+0.1650065065e-37*I, 0.8542115619e-37+0.8289193856e-38*I, 0.8582270020e-37]

(7)
 

``

Download 0_one.mw

Could someone explain to me why the Maple online help pages (see here) are still apparently matching the Maple 2021 release for the past few years? Does this mean that all the information on the Maple online help pages is out of date, or just this one specific page is terribly out of date?

Hello,

I am trying to discretize high order derivatives (typicaly of order 3-4) and I would like to use maple to avoid errors. Using this thread of discussion I got the following minimum example that illustrates the problem I am facing:

NULL

# central discretisation u_xx, i=1,..,n-1
dxc:=add([1,-2,1] *~ [u[i+k,j] $k=-1..1])/(h^2);

(u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2

(1)

NULL

# we need to compute gradient(laplacian) on faces i+1/2,j and i-1/2,j.

#First diff(u_xx,x)|i+1/2,j
d1:=add([1,-1] *~ [dxc[i+p,j] $p=0..1])/(h);
#which should give
d1:=add([1,3,-3,1] *~ [u[i+k,j] $k=-1..2])/(h^3);

(((u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2)[i, j]-((u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2)[i+1, j])/h

 

(u[i-1, j]+3*u[i, j]-3*u[i+1, j]+u[i+2, j])/h^3

(3)

NULL

I would like maple to evaluate the first expression for d1 and give the second expression that I wrote manually.

Is there a way to do this ? (using simplify() does't produce anything)

Cheers,

Download high_order_derivatives.mw

First 88 89 90 91 92 93 94 Last Page 90 of 2297