MaplePrimes Questions


I'm attempting to scale the vertical axis of a histogram plot such that each bin reflects the percentage of the total bins (all bins sum to 1). Matlab has an option ('probability') for their histogram command which does this. I've attempted to solve this myself in the attached worksheet but I'm not satisfied with the results (just a hack to replace axis labels). Specifically, I would like for the underlying data in the plot to match the axis scaling. An example can be seen in the image below.

Thank you for your consideration,





I've worked as a programmer before, but now I dedicate a lot of time to learning math, and so I have been using Maple.

I was wondering if there is some standard way that people work when they have a relatively large codebase. For example, can we define procedures in one file (like a document) and then just import them in another document?

I am reading about the difference between document and worksheet mode on the Maple website.

There is a table called "Difference between Documents and Worksheets" and one row has the following information

My question is about the operation on the left side. The impression I get from reading that is that if I just enter the equation in 2D math mode and hit enter it will solve the equation without me having to type in the command "solve". But Maple simply echoes the equation back to me when I do this in Maple 2022. What am I missing?

Dear all

I have a coupled system of PDEs, 
I would like to return the exact solution of the system using error integral function or complementary error function is possible

thank you for your help 

How to display the coordinate set that was used to create the following plot:


de := plot3d(y*sin(x), x = 0 .. 2*Pi, y = -2 .. 2)



Does anyone have any idea why Maple can obtain a closed form of 

Int(f, t=1..3);

but doesn't for 

Int(g, t=1..3);


The Int forms are quite close and I don't understand what makes Maple's task that difficult in the second case (the issue seems to come from the conditions in the piecewise function).
Can we force Maple to perform the second integration ?




`Standard Worksheet Interface, Maple 2015.2, Mac OS X, December 21 2015 Build ID 1097895`


f := piecewise(z/t < 0, 0, z/t < 1, 630*z^8/t^8-2520*z^7/t^7+3780*z^6/t^6-2520*z^5/t^5+630*z^4/t^4, 0)/t:

Int(f, t=1..3);

value(%);  # returns a closed form of the integral

g := piecewise(z/t < 1, 0, z/t < 2, 10080-60480*z/t+156240*z^2/t^2-226800*z^3/t^3+202230*z^4/t^4-113400*z^5/t^5+39060*z^6/t^6-7560*z^7/t^7+630*z^8/t^8, 0)/t:

Int(g, t=1..3);

value(%): # unable to return a closed form of the integral


Fig := proc(t) 
local xD, yD, D, C, Ii, Points, tex,sol; 
global A, B, b, Omega1, EL1, EL2; 
xD := Omega1[1] + aa*cos(t); 
yD := bb*sin(t); 
D := [xD, yD]; 
C := [xD + b, yD]; 
Points := pointplot([A[], B[], C[], C[], D[], E[], Omega1[]], symbol = solidcircle, color = [red], symbolsize = 6); 
tex := textplot([[A[], "A"], [B[], "B"], [C[], "C"], [D[], "D"], [E[], "E"], [Omega1[], "&Omega;1"]], align = ["above", "right"]); 
display([polygonplot([A, B, C, D], color = blue, filled = true, transparency = 0.9), Points, tex, EL1, EL2,plot([D,Ii]),plot([Ii,C])], axes = normal, scaling = constrained); end proc:
display([seq(Fig((2*Pi*i)/40), i = 1 .. 80)], insequence = true);
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
Warning, data could not be converted to float Matrix
I am sorry; How to manage with such a message. Thank you very much.

Hi, someone help please. How I can fix the following problem (preferably avoiding for-loops as they are too slow):

From a family of subsets (say) S={{a,b},{a,b,c},{b,c},{c}} of the set X={a,b,c}
1). Extract all the subsets i.e. members of S, which have 'a' as their member?
2). For any (a,b) in X x X, check if 'a' is member of all those subsets which have 'b' also as their member or not?

I have few questions on this subject.

1) One can view internal maple procs using the command showstats. For example showstat(`dsolve`) prints the dsolve proc. And showstat(`dsolve/SERIES`)  prints the proc called  dsolve/SERIES(). And this i s what I do not understand. What is the signifcance of in the above?    Since dsolve itself is a proc, what does mean? does this means SERIES is an internal proc inside dsolve proc? That is not likely. I see things like convert/tan/simpler again, what does the mean here? it can't be that simpler is an inner proc inside tan proc which is inside convert proc? I never used /  myself in mycode in a proc name.

How are these procs organized physically? I mean inside Maplesoft computers. Is each proc in separate .mpl file? How does the /  comes into play?  I tried to make a proc myself with forward / but got syntax error. So this / must mean some other logical relation, but I do not know to emulate it myself.


2) Why one must add ` ` around the names when using showstats for system procs, but not for my own module? For example, I did the following

  export foo:=proc()
  end proc;
end module;

And that worked. But if I type showstat(`A:-foo`)  maple gives error Error, (in showstat) procedure name expected

but with system proc, must have the `` there. If I type showstat(convert/tan/simpler) it is an error.


3) Why showstat(`DEtools/odeadvisor`)  gives Error, (in showstat) procedure name expected? But help says odeadvisor is in DEtools module.


4) Why can't one display the source of the module itself, and it has to be a proc? For example showstat(`DEtools`) gives error, because `DEtools` is not a proc, but a whole module.

Are these things described more somewhere? I only know about with(LibraryTools); 

I am using GraphTheory:-AutomorphismGroup() command in order to obtain all the automorphisms of a graph. However, the command appears to return a set of generators. How can I get all the automorphisms listed?

Here is an example of my work.







anyone has smart tricks to verify this Maple solution to this first order ode? I think the solution is correct. But can't figure how to make odetest result simplify to zero.


I tried few simplification on the output of odetest to see if will become zero, but no success.  This is one of those solutions which is hard for odetest to show it is zero because of the signum there, so thought to ask, may be someone will find a smart trick.

Maple 2022.2 on windows 10.

if isolate fail, then it returns back the input equation. But if solve failed to solve for the variable in question, it returns either NULL or empty list, or empty set (depending on the input). So it is easy to check if it failed or not.

How does one check that isolate failed? Should I check the left side of what isolate returns is the variable I am solving for? For an example,

sol:=isolate(-2*y-cos(y)+x+sin(x)-_C1 = 0,y)

returns back -2*y-cos(y)+x+sin(x)-_C1 = 0

Is the following the correct way to check if isolate solved the equation or not:

sol:=isolate(-2*y-cos(y)+x+sin(x)-_C1 = 0,y);
if lhs(sol)=y then
   print("it solved it. Soltion is ",sol);
   print("Failed to solve it. Try solve command now ");

Just wanted to make sure as help for isolate does not mention anything about what happens if isolate can't solve the equation.

Maple 2022.1


So I have two issues currently. One is involved with units, and the other is involved in this preculiar issue I have with a solve.

The units issue is probably pretty simple. I tried converting the units to the more readable prefix unit (ex: nanofarads instead of farads). The conversion worked, as in the number changed, but the unit in the output didn't. How do I fix that?

The second issue is that I have a solve execution like above to solve for some resistor values. The problem is, for some reason, it's not actually giving me an output. I have no idea why, what am I doing wrong?

I want to calculate the Taylor expansion of an expression with Maple, but there is an error. How can I fix it?

I would like to place a legend between the axes and the image, but there is no such place in the positions given by the software. How to do it?

First 72 73 74 75 76 77 78 Last Page 74 of 2237