MaplePrimes Questions

Need help to use DrawGraph to align vertices and edges and length etc for very large large size graph which i want to analyze 

even if the graph even if it requires to writen to a file to make it more big and neatly visible.

kind kind help please it will be acknowledged

Program attached those cartesian product graphs are huge extra parameters and layouts and may others may be required to make such big big graphs visible. Kind help please.

Please help i am not that great on the stylesheet options please please help


Some kind of patterned way to set vertex positions for least crossings in grid form say I am trying but not able to achive kind help.

Any progression type loop based on size number of vertices et.


I am making good progress in getting Maple to do the simple tasks I need it to do, but there are a few things that I am unable to get looking the way I want. I have looked repeatedly for answers, but I have come up empty every time.

1. No Leading Zero: If I have a variable equal to 0.75, I want it to display as 0.75 not .75. This is not a problem when I do calculations, but when I, for example, display the value in a plot legend, I would like it to have a leading zero.

2. Scientific Notation Threshold: Is there a threshold defining when the display of a value changes from a regular decimal number to a number in scientific notation? For example, I have a number with a value of 0.0094, and I would like it to display (again, in a plot legend) as 0.0094, but it keeps coming out as .94e-2. Yes, it is the same value.

3. Scientific Notation Format: The number in #2 shows up as .94e-2, but it seems like it should be 9.4e-3. Am I missing something? It seems like I was always taught that the mantissa should be between 1 and 10, but Maple seems to want to give me a number between 0 and 1.



restart:local D:

a := 7;
b := a/2;

r := b/2;
c := 2*sqrt(10)*r;
A := [c/2, c/2];
B := [c/2, -1/2*c];
C := [-c/2, (-c)/2];
D := [-c/2, c/2];
f := (x, y) -> x^2/a^2 + y^2/b^2 = 1;
Ell1 := rotate(implicitplot(f(x, y), x = -9 .. 9, y = -6 .. 6, color = blue), Pi/4);

g := (x, y) -> x^2/b^2 + y^2/a^2 = 1;
Ell2 := rotate(implicitplot(g(x, y), x = -10 .. 10, y = -10 .. 10, color = blue), Pi/4);

quadri := plot([A, B, C, D, A], x = -6 .. 6, y = -6 .. 6, filled = true, color = red, transparency = 0.7);
Cir1 := disk([c/2 - r, -c/2 + r], r, color = blue);
Cir2 := disk([-c/2 + r, -c/2 + r], r, color = blue);
Cir3 := disk([-c/2 + r, c/2 - r], r, color = blue);
Cir4 := disk([c/2 - r, c/2 - r], r, color = blue);
display([quadri, Ell1, Ell2, Cir1, Cir2, Cir3, Cir4], scaling = constrained, axes = normal);
how to find the equations of ellipses in order to fit them to discs and whiten the interior of ellipses ? Thank you.

Is it possible to solve the mixed PDEs below using the method of lines or any other numerical scheme?


theta(0,t) = theta(d,t) = 0

v(0,t) = v(d,t) = 0

I.C: theta(z,0) = \thetab*sin(pi/2)*z,  v(z,0) =0 at t =0  for both the initial conditions, where thetab = 0.0001 

% parameters.

K3 = 7.5*10^(-12);

eta2 = 0.1361;

alpha2 = -0.1104;

gamma1 = 0.1093;

d = 0.0002;

xi = 0.1; 

Note: xi is the controlling parameter. For instance, we can plot theta and v for different values of xi.

I tried matlab but no standard scheme to solve the problem because of the partial^2 theta/partial d partial t term. It would have been possible to use pdepe in Matlab if not for the mixed derivative. Please any help.

Thank you

I have two plots that I want to overlay.  I can do that, but I want the units to be in english units ("lbf" instead of "N" for force).  Individually each plot will switch the units, but the "display" command throws an error!  Help, please.

I have a set of equations gathered in a vector. The number of equations varies each time. Here in this example it is 4. How you suggest so solve them with fsolve? I tried to use seq but faced error.


EQ := Matrix(4, 1, {(1, 1) = 32.1640740637930*Tau[1]-0.172224519601111e-4*Tau[2]-0.270626540730518e-3*Tau[3]+0.1570620334e-9*P[1]+0.3715450960e-14*sin(t), (2, 1) = -0.172224519601111e-4*Tau[1]+32.1667045885952*Tau[2]+0.587369829416537e-4*Tau[3]-0.1589565489e-8*P[1]+0.1004220091e-12*sin(t), (3, 1) = -0.270626540730518e-3*Tau[1]+0.587369829416537e-4*Tau[2]+32.1816411689934*Tau[3]-0.7419658527e-8*P[1]+0.5201228088e-12*sin(t), (4, 1) = 0.1570620334e-9*Tau[1]-0.1589565489e-8*Tau[2]-0.7419658527e-8*Tau[3]+601.876235436204*P[1]})

V := Matrix(1, 4, {(1, 1) = Tau[1], (1, 2) = Tau[2], (1, 3) = Tau[3], (1, 4) = P[1]})

q := 0

X := Matrix(4, 1, {(1, 1) = -0.1156532164e-15*sin(t), (2, 1) = -0.3121894613e-14*sin(t), (3, 1) = -0.1616209235e-13*sin(t), (4, 1) = -0.2074537757e-24*sin(t)})

t := 1

Xf := fsolve({seq(EQ[r], r = 1 .. 4)}, {seq(V[r] = q .. X[r], r = 1 .. 4)})

Error, Matrix index out of range``




Dear All,

I have a question about "fraddiff" command to compute the fractional derivative of a function.
I need to produce  a procedure to manually compute Caputo fractional derivative of a function, instead of using "fracdiff", as the following:

description "Frac_C(function,lower bound, variable (upper bound), order of differentiation)";
return 1/GAMMA(m-alpha)*int((x-tau)^(m-alpha-1)*diff(f(tau),tau$m),tau=a..x);
end proc;

when I call the above procedure, as Frac_C(x^(3.4),0,x,3/4), Maple is not able to calculate the integral defined in the Caputo fractional derivative. However, I saw the pre-defined Maple command, namely fracdiff, is able to do.
Where is the trouble?
can anyone help me?

It is worth mentioning that I can calculate the fractional derivative of a functional by procedure "Frac_C()" when I try to use it at the given x as the following which is not desirable for me.

Best wishes

t is removed from gamma(t)










subs(gamma(t) = gamma(t), (1+(cos(alpha(t))^2-1)*cos(gamma(t))^2)^(1/2))











If i matrix of order

m1 cross n1


other of order

m2 cross n2

and say n1 >n2 

The function change(A,B) and make the matrices of order m1 cross n1 and m2 cross n1 by appending zero columns to the other where n2 is the smaller one to make it n1=n2


The question is in the picture.

y(x) is the result of the last calculation. How do I apply diff to the last result?


Can pacemaker and corosync work with maple?

How to setup pacemaker and Corosync to maple work in Amazon EC2?

i had only one installed License in linux

how to make it work in clusters ?

what is the difference with supercomputing in Amazon ?

which consulting company in Hong Kong can help to use supercomputing in Amazon in my case ? I would like to run batch of batch total 100 script running maple in one instance , but total numbers need to run around 60 years. Any consultant to calculate and setup this supercomputing or pacemaker to make calculations into one day or a few days ? 


Suppose their are two matrices A and B say

A has dimension  n1   rows  and m columns

B has dimension n2 rows and m columns

I need to find if any two rows of A are same as that of B  or not

How many are same.

If they are same in some rows which row of A is same as which row of B 

Function     checkrowsuniquie(A,B)

I want the resulting shape of the 3D matrix M (ٍExcel file) to be placed in below grids codes.
The range of x and y is between 0 and 1 and the range of z is 1/1 e-4 to 1/1 e-10.




grids := proc (M, x_min, x_max, y_min, y_max) local z_min, z_max, plot_f, xz, yz, xy; z_min := 0.11e-6; z_max := 0.1e-2; plot_f := plot3d(M, x = x_min .. x_max, y = y_min .. y_max); xz := plot3d([x, y_min, z], x = x_min .. x_max, z = z_min .. z_max, style = line, color = blue, thickness = 0, grid = [6, 6]); yz := plot3d([x_min, y, z], y = y_min .. y_max, z = z_min .. z_max, style = line, color = blue, thickness = 0, grid = [6, 6]); xy := plot3d([x, y, z_min], x = x_min .. x_max, y = y_min .. y_max, style = line, color = blue, thickness = 0, grid = [6, 6]); return plots:-display(plot_f, xz, yz, xy, lightmodel = none, tickmarks = [6, 6, 6], labels = [x, y, "Error"], labeldirections = [horizontal, horizontal, vertical], axes = frame, orientation = [45, 70, 0], view = 0.11e-6 .. 0.1e-2) end proc

grids(M, 0, 1, 0, 1)

Warning, expecting only range variables [x, y] in expression M to be plotted but found name M







Dear all,

I would like to simplify the expression a*f(x)=0 with a>0.

It is expected to give f(x)=0, but maple still returns a*f(x)=0

I have tried this



It gives

a~ f(x)=0, not f(x)=0 


Dear Mapler

I want to find all real and complex solutions to the following equation. then calculate the omega based on these values and finally select the present the omega with the smallest imaginary part.




#params:= [p,    s, nu,   rho, h,    sigma, C1[1], C1[2], C2[1], C2[2], k1,  k2,  m1[1], m1[2], m2[1], m2[2] ]
 params:= [1e-7, 0, 1e-6, 1e3, 1e-2, 0,     5e-4,  5e-4,  5e-4,  5e-4,  1.4, 1.4, 1+I,   1+I,   1-I,   1-I   ]:

for i from 1 to n do
                  ( (x*h)*( (y*h)*sinh((x*h))*cosh((y*h))-(x*h)*cosh((x*h))*sinh((y*h)))*(1+s*(x*h)^2)
                 , [p=params[1], s=params[2], h=params[5] ]), y
            , AllSolutions=true)]:
    for j from 1 to nops(mm[i]) do
        omega[i][j]:=eval(-I*nu*((x*h)^2-mm[i][j]^2), [nu=params[3],h=params[5]]);
First 73 74 75 76 77 78 79 Last Page 75 of 2211