MaplePrimes Questions

Consider the following integral, shown below in this image.

>> Link to the Maple sheet: <<

Why does Maple provide erroneous results? Is there a bug in the software? I use Maple 2021.

I am curious to know steps of integration for e^(t^3)*(cos(t))^3 as Maple found the answer correctly. So I wanted to know how it got to that solution. I applied the commands shown in document but unable to get steps. I want to know the reason for this and is it possible to get it work.



int(exp(t^2)*cos(t)^3, t)




eval(-((1/16)*I)*Pi^(1/2)*exp(9/4)*erf(I*t+3/2)-((3/16)*I)*Pi^(1/2)*exp(1/4)*erf(I*t+1/2)-((3/16)*I)*Pi^(1/2)*exp(1/4)*erf(I*t-1/2)-((1/16)*I)*Pi^(1/2)*exp(9/4)*erf(I*t-3/2), [t = 1])









Understand(Int, constant, constantmultiple, sum, difference)

ShowSolution(Int(exp(t^2)*cos(t)^3, t), maxsteps = 1000)

Error, (in Student:-Calculus1:-ShowSolution) unable to compute solution steps






Derar All

I'm trying ot adapt some old Maple V code to a new Maple 2022 Module/Package and have an issue understanding if the "ModuleLoad" process does really run automatically with the "> with(TST); " command ?
the "> restart;" runs the ModuleUnload though, but for me the ModuleLoad does not seem to run when I expect it to !?



Any comment appreciated ?
the test code :


Tst := module()
  local ModuleLoad, ModuleUnload;
  export MyProc;
  global AAA;
  option package;
  ModuleLoad := proc()
      global AAA;
      AAA := 1;
      print("Hello Module");
  end proc;
  ModuleUnload := proc()
      print("Bye Module");
  end proc;
  MyProc := proc()
      print("Hello from Core");
  end proc;
end module ;

When was ?define, forall stripped from Maple?
Define used to accept all of these: Group, Linear, forall, antisymmetric, associative, binary, commutative, identity, inverse, symmetric, type, unary, zero. Was this function moved to another package?

How can I define an arbitrary signature of a space-time metric?

I want to define the signature of the form `++--`.

Multibody exports from MapleSim to Maple convert a symbolic expression to a rational quotient:

The parameters (parameter "a" above) disappear in the exported equations. How can I prevent this (conversion of sqrt3 and disapprence of "a")?





I asked solve to solve the above equation for A, expecting to get back (1/2+x+y)^(3), but it returns instead this

I looked at solve options, and tried number of them, but no change. I was looking for option to tell Maple not to simplify as it solves.

I also tried to see if the solution returned can be put back to the original form, and could not so far find a way, tried simplify and some options. But I did not try every possible method as there are do many.

Compare to Mathematica, which keeps the solution the same, as what one would expect. I see no reason to change it


The reason I am asking, is that it now makes parsing a little harder as I am looking for something in the form (expression)^power   as the solution.  i.e. the type to be `^`.    Now the type shows up as `*` because Maple for some reason changed it. 

It will easier if Maple did not do that, or if there is a way to change the expression back to the way it was. If all this fails, I have to just make the parsing handle this extra case form if needed.

Any suggestions?

Maple 2022.1


Found a way after lots of trials and errors



But it would have been better if Maple did not do the simplification in the first place. But I could not find an option to tell it to do that while solving.






It's common in mathematical physics to use cartesian unit vectors to describe the position of a point in space.


r_(t) = x(t)*_i+y(t)*_j

r_(t) = x(t)*_i+y(t)*_j


Sometimes it neccessary to convert a position vector like `#mover(mi("r"),mo("&rarr;"))`(t) to another cartensian coordinate system with different unit vectors, I call the primed system. In the primed system the position vector looks like:

"(r')(t)=x'(t) (i')+y'(t) (j')"

When using Physics[Vectors] and the unit vector hat notations to define vectors in cartesian space, can I define more than one cartesian space such as:

`#mover(mi("r"),mo("&rarr;"))`(t) = x(t)*`#mover(mi("i"),mo("&and;"))`+y(t)*`#mover(mi("j"),mo("&and;"))`



  "(r')(t)=x'(t) (i')+y'(t) (j')"?

Another way to ask the same thing: Can I define the position vector in different coordinates, each system having a distinct pair of orthogonal unit vectors?


The short answer I think is no. Given the current implementation it's not clear how one would go about defining the relationships between unit vectors from different coordinate systems. See below.


In 2D the transformation corresponds to a rotation of a vector the plane. The tranformation is characterized by the rotation angle α.




The unit vectors from different systems are related through scalar products.


"(i)*i' =(|i|)*|i'|*cos(alpha)=cos(alpha)"``NULL


"(j)*(j)' =(|j|)*|(j)'|*cos(alpha)=cos(alpha)"NULLNULL


"(j)*(i)' =(|j|)*|(i)'|*cos(3 alpha)=cos(3 alpha)"``NULL


Is there a way to implement scalar products of vectors from different coordinate systems using the Physics Tensors package? Here I create three different coordinate systems. I don't know whether the unit vectors systems X and Y have the same (i, j, k) unit vectors or does each system have its own triplet?


Setup(coordinates = cartesian, metric = Euclidean, dimension = 3, spacetimeindices = lowercaselatin, geometricdifferentiation = true)

[coordinatesystems = {X}, dimension = 3, geometricdifferentiation = true, metric = {(1, 1) = 1, (2, 2) = 1, (3, 3) = 1}, spacetimeindices = lowercaselatin]


Coordinates(Y, Z, Z = cylindrical)

{X, Y, Z}







hi everyone
i have a nonlinear double int which want to be solved and then plot against "z" variable.
tnx in advance

I think I'm going crazy! 

`Maple 2020.1, X86 64 WINDOWS, Jul 30 2020, Build ID 1482634`

solve((20 + 20*T + 2*T*(T + 1))*exp(-T) - 10*exp(-2*T) - 2*T - 10.0 = 0);
                 -10.00000000, -8.309536192, 0.

?????? Why???????

Has anyone gone crazy or what?

Maple 2022.1 on windows 10




Notice p2. The vertical line is gone. This happens when the range x=-6..10 and it shows back again when x=-6..11 or x=-6..9

Why does this happen? It is the same equation.


Expressions of the kind

A cos(phi) - B sin(phi)

are solved by Maple to phi=arctan(A/B)

In such cases: Is there a way to get a solution phi=arctan(A,B) other than in the attached?

If not: Can the attached solution be done more efficient? There are quite some commands involved.

(It may happen that Maple returns "minus arctan". Then the attached solution does not work and has to be preplaced by something more complicated. A solution that always work would be desireable)


I'm new to Maple Flow.  As an exercise I'm replicating a calculation I did in Mathcad, building a blade element model of a hovering helicopter.  The physics is well documented, but any specific design changes the results. 

The lift and drag values of the airfoil of choice and the blade physical geometry are used to solve for the forces generated at any radial segment, these are integrated along the blade radius to compute the rotor thrust and torque.  These integrals are taking an inordinate amount of time--one blade angle setting took fifteen minutes to compute rotor thrust and torque.  Since the next step is to compute these values over a range of blade angles this poses a significant problem.

I'd post the file if I could figure out how!!

I'm trying to move to Maple Flow after a long time using Mathcad.  (Long enough that I remember when Maple was the symbolic engine in Mathcad.)  So I'm looking for the user's forum (like the old collaboratory), and I thought that MaplePrimes might be that resource.  Under the heading of "Products" I find a list of many different programs--every version of Maple and MapleSim--but Maple Flow is not to be found.

I decided to ask why, only to discover that it magically appears when the question window asks me to "categorize your question" to get it answered faster.  So I guess my question really is, "How do I find information  and questions specific to Maple Flow?"


i have 3 Arrays and i want to plot them i 2D, 

for example : 

y  := [1,2,3,4,5,6]

x1:= [10,20,30,40,50,60] 

x2:= [0.1,0.2,0.3,0.4,0.5,0.6]

and i want to display at the graph for each y point the value of x1 and x2 by two axis (dualaxis)

any suggestions ? 


thank u in advance !

First 77 78 79 80 81 82 83 Last Page 79 of 2211