MaplePrimes Questions

From answer posted in https://www.mapleprimes.com/questions/225137-Internal-Symbol-Z1--Causes-Error-

I've learned to use

subsindets(expr, 'suffixed(_)', f->n);

To replace in a Maple generated solution which contains system suffix, such as _Z, _Z1, etc... returned by Solve and Maple calls, with a symbol that I find easier to read. The above works in some cases but not others. For example, it works on this result

restart;
expr:=signum(0, _Z, 1);
subsindets(expr, 'suffixed(_)', f->n);

                      signum(0, n, 1)

But not on this one

restart;
expr:=RootOf(signum(0, _Z, 1));
subsindets(expr, 'suffixed(_)', f->n);

             RootOf(signum(0, _Z, 1))

I do not want to use pattern matching, since the result is something I do not know what it will be. I just want to replace all those Maple symbols that start with _Z in the solution by another symbol. I can't use subs() either, since I do not know what the symbol will be.

What is the correct way to do this?

 

Should this generate an error?

restart;
r:=evalc(Im(1/ln(x)));
solve(r,{x});

 

This did not help. Same error as above.

restart;
r:=evalc(Im(1/ln(x))):
solve(r,{x}) assuming x::real;

This made Maple not give an error

restart;
r:=evalc(Im(1/ln(x))):
solve(r,{x}) assuming x::real, x>0;

       {x = x}

Also this worked, but NULL returned

restart;
r:=evalc(Im(1/ln(x))):
solve(r,{x}) assuming x::real, x<0;

Also this worked with NULL returned

restart;
r:=evalc(Im(1/ln(x))):
solve(r,{x}) assuming   x<0;

Is this how Maple generally works? i.e It generates an exception error when it is not able to solve something? Or does it normally echo back the input back if it can't solve something? Or at least return NULL if it can't solve it? I am havin hard time figuring which method to use to check if Maple is able to solve something or not, because each time it seems to do something different.

Should one then put a try/catch around each Maple call, and treat the try section as if Maple was not able to solve the equation whatever it was?

 

Essentially I have this trigonometric equation and I want to solve (get the roots of) it within the range -Pi..Pi:

v := a+b*cos(t)-c*(d*(1-(a+b*cos(t))^2-d^2*sin(t)^2)^(1/2)+e*sin(t)) = 0;
v1 := t > -Pi;
v2 := t < Pi;

Where t is the variable and a..e are constants.  At the moment I am trying the following:                  
solve({v, v1,v2}, t, allsolutions, explicit);


My problem is that Maple tries to solve this - I get Evaluating in the bottom left corner of the window - but never seems to return with a solution even after using 52,000s and 5GB of memory: I am using a late model macbook.

Can anyone see a way of re-framing this equation so that Maple can return an answer?

Is it possible to solve numerically a PDE, where the IBC is a function resulting from the numerical resolution of an ODE?

hi,

I want to setup quantum mechanical angular momentum operators and kets such that i can do something like:

Lz[2] . Ket(??, j, m) -> m hbar        (instead of getting m as eigenvalue)

L^2[1] . Ket(??, j, m) -> j (j+1) hbar^2           (instead of getting j)

where L and Lz are quantum operators. 

maybe if i knew how to do 

QuantumOp . Ket{QuantumOp, j) -> j (j+1)

i could do it with explicit tensor products of Kets - one for j, one for m?

can somebody give me an idea of how to do this, or point me at an example?

many thanks,

larry

The following product gives 0

restart;

product(1-1/k, k = 2 .. infinity);


                               0

However when I expand the product

1 - 1/2 - 1/3 - 1/4 - ... + 1/2*1/3 + 1/2*1/4 + ... + 1/3*1/4 + ... + triple products + quadruple products + and so forth...

Now the double, triple, quadruple, and so forth sums of products converge.

The 1/2 + 1/3 + 1/4 + ... nevertheless diverges, so why does maple give me 0?

Hello!
I am really desperate right now and I need help or advice.

I don't understand why dsolve doesn't work for my example. He doesn't get anything out....

restart; 
de := sin(1)*(diff(y(x), x$2))+(1+cos(1)*x^2)*y(x) = -1: 
cond := y(-1) = 0, y(1) = 0: 
dsolve({cond, de}, y(x))

Really hope for your help.

question.mw

Hello there,

I am trying to solve a pretty simple Cauchy Problem:

PDE := diff(u(t, x, y), t)+.5*(diff(u(t, x, y), x, x))+diff(u(t, x, y), x, y)+.5*(diff(u(t, x, y), y, y))+diff(u(t, x, y), x)+diff(u(t, x, y), y)+(1+(x+y)^2)*u(t, x, y) = 0

bc := u(0,x,y)=1;

with pdsolve and I get a result.

But surprisingly, Maple's pdetest applied to this result doesn't yield zero.

Hence, Maple solves my problem, but it also says that this solution is not right?

How is that possible?

 

Thanks a lot for your help. (btw: this is my first post here :))

Best regards,

utcyp

 

i have a prablem i work on it consiste of  aloop of 1000 iteration ,  and  apart of it evaluate the following sum  and integration  but maple either take very long time  about (12 hours) in evaluating it  (and it's very long )

 

or it get stuck . Is there any way to make maple evaluate this sum and integration  very quickely and didnt get stuck 


 

NULL

`&lambda;&lambda;`[1] := .1111111; `&lambda;&lambda;`[2] := 2222222; `&alpha;&alpha;` := 1.51222222

P := simplify(sum(sum((t+1)*`&alpha;&alpha;`^2*(1-`&alpha;&alpha;`)^(t+T)/(t+1+`&lambda;&lambda;`[1]*(T+1)/`&lambda;&lambda;`[2]), t = 0 .. infinity), T = 0 .. infinity))

Warning,  computation interrupted

 

r[1] := exp(-C*(int(lambda[1]*alpha^2*exp(lambda[1]*Z)/((exp(lambda[1]*Z)-1+alpha)^2*(exp(lambda[2]*Z)-1+alpha)), Z = 0 .. infinity, numeric)));

exp(-C*(int(lambda[1]*alpha^2*exp(lambda[1]*Z)/((exp(lambda[1]*Z)-1.+alpha)^2*(exp(lambda[2]*Z)-1.+alpha)), Z = 0. .. Float(infinity))))

(1)

``

R[1] := diff(r[1], lambda[1]):

 

lambda[1] := 1.117480:

``

C := -2:

r_r[1] := evalf(r[1]);

6.833764322

 

.5388679374

 

-1.033616758

 

4.934912438

 

-0.3143256678e-1

 

-4.822756149

 

4.934912438

 

-5.541440349

 

.2813149492

 

0.4011667571e-1

 

-0.3143256678e-1

 

.2813149492

 

-0.7207815680e-2

(2)

NULL


 

D

 

Maple 2018 memory usage increases as I try to display or manipulate the expression presented in  test_maple2018.mw. The same worksheet works perfectly in Maple 18

I've tried both in Maple 2018.1 and Command Line Maple 2018 obtaining the same result

Maple 2018.1, X86 64 WINDOWS, Jun 8 2018, Build ID 1321769

From command line maple 2018 when trying to evaluate

memory used=3.6MB, alloc=40.3MB, time=0.14
memory used=4.7MB, alloc=72.3MB, time=0.19
memory used=33.3MB, alloc=107.3MB, time=0.45
memory used=109.2MB, alloc=143.1MB, time=1.37
memory used=217.7MB, alloc=185.6MB, time=2.60
memory used=292.6MB, alloc=217.6MB, time=3.87
memory used=328.0MB, alloc=254.6MB, time=5.16
memory used=437.3MB, alloc=299.9MB, time=7.44
memory used=549.8MB, alloc=335.9MB, time=13.60
memory used=630.9MB, alloc=375.4MB, time=17.07
memory used=686.9MB, alloc=401.8MB, time=19.61
memory used=785.6MB, alloc=431.9MB, time=22.31
memory used=944.8MB, alloc=427.9MB, time=26.74
memory used=1150.1MB, alloc=427.9MB, time=32.37
Interrupted

I was wondering if my Maple 2018.1 installation is corrupted. Since I have no acces to other Maple licenses, can anyone try to execute it? test_maple2018.mw

This differential equation has an analytical solution.

However, I am looking for a numerical solution for it.

A single boundary condition with respect to t would be sufficient to solve the problem, but the command does not accept this.

In the end, I try to insert boundary conditions in relation to the variables x and t, but again this does not work.

Where am I going wrong?

Hello my friends

I have some problems with maple 18. I try to consider and extract some things about tensor such as contraction.

for instance, suppose we have metric=-exp(alpha(r))*(dt^2)+exp(beta(r))*(dr^2)+r^2*(dtheta^2)+r^2*(sin(theta)^2)*(dphi^2). how we can find all Riemann tensor and corresponding contraction, Ricci tensor and its contraction and even Weyl tensor and its contraction. unfortunately, I attempt to find them by using some other examples on the net but they don't help me to calculate them when time is the first element in coordinate, not last ( t,r,theta,phi) not (r,theta,phi)

thanks with the best regard

In Maple 2017, a simple one-liner can crash the current worksheet (in any mode with any text type it seems).

z[x]:=z

z[x]:=z(x)

Note that z and x can be any two letters, and that you can replace z[x] with the equivalent z+(ctrl shift _)+x (which displays as zx)

I was just wondering if someone could explain why kernelopts(maxdigits) = 38654705646, as in is this different for a differing computer, or is there a design aspect of maple that requires it to be this number, or is there a mathematical reason?

First 537 538 539 540 541 542 543 Last Page 539 of 2173