MaplePrimes Questions

How to write names on an drawing P1, P2, P3, Pn... I try
textplot({seq([(coordinates(point(P[i]))), cat("P", i)], i = 0 .. 5)}, 'align' = {'above', 'left'}):;
i got the message : wrong number of arguments that i don't how correct. Thank you.

Hi,

I would be really grateful if someone can help me in solving the below attached problem in maple.

Thanks in advance.

In Latex 897 correct Latex is generated for the following code. In 905, wrong Latex is generated. This is different from the other cases I posted about (links below) and new issue.

In 897, the Latex generated for this example compiles with no error

restart;
sol:=(Vector(2, [x__1(t),x__2(t)])) = (Vector(2, [2^(3/4)*3^(1/4)*(exp(2^(3/4)*3^(1/4)*t)*_C1-exp(-2^(3/4)*3^(1/4)*t)*_C2-sin(2^(3/4)*3^(1/4)*t)*_C3+cos(2^(3/4)*3^(1/4)*t)*_C4),2*6^(1/2)*(exp(2^(3/4)*3^(1/4)*t)*_C1+exp(-2^(3/4)*3^(1/4)*t)*_C2-sin(2^(3/4)*3^(1/4)*t)*_C4-cos(2^(3/4)*3^(1/4)*t)*_C3)]));
Latex(sol)

Now compiling the Latex gives

\documentclass[11pt]{article}
\usepackage{amsmath}
\usepackage{maplestd2e}  

\begin{document}
\[
\left[\begin{array}{c}x_{1} \! \left(t \right) \\x_{2} \! \left(t \right) \end{array}\right]
 = 
\left[\begin{array}{c}2^{\frac{3}{4}} 3^{\frac{1}{4}} \left({\mathrm e}^{2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \mathit{\_C1} -{\mathrm e}^{-2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \mathit{\_C2} -\sin \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \mathit{\_C3} +\cos \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \mathit{\_C4} \right) \\2 \sqrt{6}\, \left({\mathrm e}^{2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \mathit{\_C1} +{\mathrm e}^{-2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \mathit{\_C2} -\sin \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \mathit{\_C4} -\cos \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \mathit{\_C3} \right) \end{array}\right]
\]
\end{document}

In 905

The Latex(sol) gives

\documentclass[11pt]{article}
\usepackage{amsmath}
\usepackage{maplestd2e}  

\begin{document}
\[
\left[\begin{array}{c}x_{1} \! \left(t \right) 
\\
 x_{2} \! \left(t \right) \end{array}\right]
 = 
\left[\begin{array}{c}2^{\frac{3}{4}} 3^{\frac{1}{4}} 
\\
\left({\mathrm e}^{2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \textit{\_C1} -{\mathrm e}^{-2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \textit{\_C2} -
\\
\sin \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \textit{\_C3} +\cos \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \textit{\_C4} \right) 
\\
 2 \sqrt{6}\, 
\\
\left({\mathrm e}^{2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \textit{\_C1} +{\mathrm e}^{-2^{\frac{3}{4}} 3^{\frac{1}{4}} t} \textit{\_C2} -
\\
\sin \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \textit{\_C4} -\cos \! \left(2^{\frac{3}{4}} 3^{\frac{1}{4}} t \right) \textit{\_C3} \right) \end{array}\right]
\]
\end{document}

Which when compiled using texlive lualatex gives error. There is a missing \right. 

>lualatex foo5.tex
This is LuaHBTeX, Version 1.12.0 (TeX Live 2020)
 restricted system commands enabled.
(./foo5.tex
LaTeX2e <2020-10-01> patch level 2
.....
..Defaults to "dvips" Driver
(/usr/local/texlive/2020/texmf-dist/tex/latex/graphics/epsfig.sty (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics/graphicx.sty (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics/keyval.sty) (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics/graphics.sty (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics/trig.sty) (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics-cfg/graphics.cfg) (/usr/local/texlive/2020/texmf-dist/tex/latex/graphics-def/dvips.def))))
Defining Automatic Style Generation Macros
Defining Maple Spreadsheet Environments
Maple Spreadsheet and Table Support
) (/usr/local/texlive/2020/texmf-dist/tex/latex/l3backend/l3backend-luatex.def) (./foo5.aux) (/usr/local/texlive/2020/texmf-dist/tex/latex/base/ts1cmr.fd)
! Missing \right. inserted.
<inserted text>
\right .
l.14 \\

?


 

Maple 2020.2, Physics 905

Fyi, the issues I know about in Latex()  as of now are these 4

https://www.mapleprimes.com/questions/231398-Regression-In-Latex-Between-897-And?sq=231398

https://www.mapleprimes.com/questions/231397-Latex-Latex-Generates-Command-Not-In

https://www.mapleprimes.com/questions/231273-Why-Latex-Fail-To-Convert-Solution

https://www.mapleprimes.com/questions/231262-Latex-Generates-Wrong-Latex-For-This-Example

 

FYI,

I was testing Physics 905 to see if this bug reported in https://www.mapleprimes.com/questions/231262-Latex-Generates-Wrong-Latex-For-This-Example

But I found that now Maple generates a new command called \munderset  while in 897 it used to be  \Mapleunderset

So the problem was not fixed. In addition now it uses a command called \munderset which is not in any of Maple style files and not a standard Latex macro name. 

Replacing \munderset back to \Mapleunderset now the same error that was generated in the above linked to question, using the same exact code shown there.

So I think this new command should remain \Mapleunderset unless there is a new Maple syle file used which is not part of Maple 2020.2? 

To reproduce this, please run the same code posted in the above link. No need to duplicate it here again, and you will see this problem.

Maple 2020.2, Physics 905

 

 

In the following code,  

Although the lines in the figure include asterisk or points, the symbols don't appear in the legends.

 

restart:
f1:=x->x^2:
f2:=x->x^2-0.08:
N:=10: ptsize:=8: th:=1:
(a,b) := 0,2:
p1:=plot(f1(x),x=a..b,color=red,thickness=th,legend=f1(x),style=pointline,symbol=solidcircle,symbolsize=ptsize,adaptive=false,numpoints=N+1):
p2:=plot(f2(x),x=a..b,color=blue,thickness=th,legend=f2(x),style=pointline,symbol=asterisk,symbolsize=ptsize+4,adaptive=false,numpoints=N+1):

plots:-display(p1,p2);

 

 

For example; what is your method for showing asterisk, point etc. in the legends as in the following picture?

Hello!

I would appreciate any help on how to do computations on Maple of the following problem. 

Say we have 3 generators x,y,z and I define a map on polynomials in three variables over rational numbers L: Q[x,y,z] -> Q[x,y,z] on the generators, for example L(x)=xy, L(y)=1, L(z)=z^2. 

Then I need to compute L(xy+yz) and it needs to compute it using linearity and derivation (Leibniz rule):

L(x)y+xL(y)+L(y)z+yL(z)=xy^2+x+z+yz^2. 

 

I have in mind a recursive algorithm but I don't know enough syntacsys to implement it. 

P.S.: I need to compute Poisson brackets on a polynomial algebra for which there is no special way of doing it, right? So I though it must be easier for each basis element to come up with a linear map and extend it via derivations to know its action. 

Hi,

I was trying to differentiate an equation with two random variables with respect to my decision variable. But it took 4-5 hrs still MAPLE could not evaluate nor show an error.

 Later I want to find q* from the FOC and wish to substitute it back into the equation. I will be grateful if someone please help me in doing both.

doubt_1.mw

Thanks in Advance

I think Maple is wrong here. But may be someone could show me how it is correct?

Maple says this ode (below) is of type d'Alembert. But I am not able to show this. It is impossible for me to put this ode in _dAlembert. form. So I gave up.

https://www.maplesoft.com/support/help/Maple/view.aspx?path=odeadvisor/dAlembert

The challenge then is to put the following first order ODE in the above form to show it is dAlembert.

I could not do it. I worked on this by hand and not possible to get the ODE in the above form. Could someone show this?

restart;
ode:=3*x^2*y(x)^3+y(x)^4+(3*x^3*y(x)^2+4*x*y(x)^3+y(x)^4)*diff(y(x),x) = 0;
DEtools:-odeadvisor(ode);

The first thing I do when I want to show this, is to solve for y(x) from the ode. Since I can't use solve on an ode, I start by replacing all the diff(y(x),x) with say p. Then now solve for y(x). If it is dAlembert, then it should give expression that be put in the form    y(x)=x*f(p) + g(p). Notice that the functions f(p) and g(p) are functions of p only and not of x. This is important.  And f(p) is multiplied by linear term and not x^(3/2) or x^(1/2), etc... The term multiplying f(p) has to be linear in x.

ode:=subs(diff(y(x),x)=p,ode):
sol:=[PDEtools:-Solve(ode,y(x))];

Looking at second and third solutions. None of them is dAlembert.  This can be shown by either simplyfing it with assumptions, where not possible to obtain the needed form, or by simply replacing p back with diff(y(x),x) and asking advisor for the type of the resulting ode

DEtools:-odeadvisor( subs(p=diff(y(x),x),sol[2]));
DEtools:-odeadvisor(subs(p=diff(y(x),x),sol[3]));

So none is d'Alembert.

Question is: Could someone may be proof that this ode is d'Alembert? By putting it in the form   y(x)=x*f(p)+g(p)? Or is advisor is wrong here?

ps. I tried infolevel[DEtools:-odeadvisor]:=4 to try to trace it, but it does not work.

pps. I worked this out by hand, and I get 

                y(x)= x^(3/2)*f(p)  where f(p) = sqrt(-12 p^2)+sqrt(12*p)

And this is not d'Alembert.

 

clc;clear;
% Define i1(t) and i2(t) as symbolic variable
syms i1(t) i2(t)

% Given differential equation
ode1 = diff(i1) == 0.5*i1 + -3*i2 +5*exp(-2*t);
ode2 = diff(i2) == 2*i1 - 6*i2;
odes = [ode1; ode2];

% Define initial conditions
cond1 = i1(0) == 1;
cond2 = i2(0) == -1;
conds = [cond1; cond2];

% Solution of system of differential equation
[i1(t), i2(t)] = dsolve(odes,conds)

fplot(i1(t))
hold on
fplot(i2(t))
legend('i1(t)','i2(t)')

Output:

i1(t) =
exp((t*(73^(1/2) - 11))/4)*(73^(1/2)/8 + 13/8)*((57*73^(1/2))/292 - exp((3*t)/4 - (73^(1/2)*t)/4)*((15*73^(1/2))/292 + 5/4) + 3/4) - exp(-(t*(73^(1/2) + 11))/4)*(73^(1/2)/8 - 13/8)*(exp((3*t)/4 + (73^(1/2)*t)/4)*((15*73^(1/2))/292 - 5/4) + (3*73^(1/2)*(73^(1/2) - 19))/292)


i2(t) =
exp(-(t*(73^(1/2) + 11))/4)*(exp((3*t)/4 + (73^(1/2)*t)/4)*((15*73^(1/2))/292 - 5/4) + (3*73^(1/2)*(73^(1/2) - 19))/292) + exp((t*(73^(1/2) - 11))/4)*((57*73^(1/2))/292 - exp((3*t)/4 - (73^(1/2)*t)/4)*((15*73^(1/2))/292 + 5/4) + 3/4)

Hi everyone,

I'm new with maple and i want to evaluate this expresssion :

f := x -> exp((-1)*0.13/x)[0.4700036292*`&ndash;`(0.3364722366, 1.2)] + exp(-1/x)[0.2135277634 + 0.528*x] + (-1)*0.528*x + 0.5420043550 = 0 ..

i Have try fsolve (f, x) but with no result..

I don't know if someone have a solution for that kind of problems..

thank in advance 

I was just using odeadvisor to check type of some ode's, when I noticed it gives 

             Error, (in ODEtools/radnormal) numeric exception: division by zero

on ode's of form y(x)=x*diff(y(x),x)^n+x^2

for different n:

restart;
for n from -5 to 5 do
    if n<>0 then
       try
          ode:=y(x)=x*diff(y(x),x)^(n)+x^2;
          DEtools:-odeadvisor(ode);
          print("n=",n,"OK, no error");
       catch:
          print("n=",n,StringTools:-FormatMessage( lastexception[2..-1] ));
       end try;
    fi;
od;

Is this known issue and is expected?

Maple 2020.2 on windows 10


 

I am getting this error. Is this expected or known issue?  

restart;
sol:=-csgn(1, 1/(_C1*a - _C1*x - 1))*_C1*a^4/((k + 1)*(_C1*a - _C1*x - 1)^2) + 4*csgn(1, 1/(_C1*a - _C1*x - 1))*_C1*a^3*x/((k + 1)*(_C1*a - _C1*x - 1)^2) - 6*csgn(1, 1/(_C1*a - _C1*x - 1))*_C1*a^2*x^2/((k + 1)*(_C1*a - _C1*x - 1)^2) + 4*csgn(1, 1/(_C1*a - _C1*x - 1))*_C1*a*x^3/((k + 1)*(_C1*a - _C1*x - 1)^2) - csgn(1, 1/(_C1*a - _C1*x - 1))*_C1*x^4/((k + 1)*(_C1*a - _C1*x - 1)^2) + a^2/((k + 1)*(_C1*a - _C1*x - 1)^2) - 2*a*x/((k + 1)*(_C1*a - _C1*x - 1)^2) + x^2/((k + 1)*(_C1*a - _C1*x - 1)^2) + csgn(1, 1/(_C1*a - _C1*x - 1))*a^3/((k + 1)*(_C1*a - _C1*x - 1)^2) - 3*csgn(1, 1/(_C1*a - _C1*x - 1))*a^2*x/((k + 1)*(_C1*a - _C1*x - 1)^2) + 3*csgn(1, 1/(_C1*a - _C1*x - 1))*a*x^2/((k + 1)*(_C1*a - _C1*x - 1)^2) - csgn(1, 1/(_C1*a - _C1*x - 1))*x^3/((k + 1)*(_C1*a - _C1*x - 1)^2) - csgn(1/(_C1*a - _C1*x - 1))*a^2/((k + 1)*(_C1*a - _C1*x - 1)^2) + 2*csgn(1/(_C1*a - _C1*x - 1))*a*x/((k + 1)*(_C1*a - _C1*x - 1)^2) - csgn(1/(_C1*a - _C1*x - 1))*x^2/((k + 1)*(_C1*a - _C1*x - 1)^2);

solve( simplify(sol)=0,x,allsolutions = true) assuming real; #also x::real, same error

Maple 2020.2 on winsows 10. Physics 897

 

 

The following command returned 1026 instead of 1000 samples. Any ideas why?

R1 := Sample(Normal(0, 1), 1000);
length(R1);
 

Thanks

restart; with(plots):unprotect(gamma):
_EnvHorizontalName := 'x';_EnvVerticalName := 'y';
line := proc (x1, y1, x2, y2) options operator, arrow; (x-x1)*(y2-y1)-(y-y1)*(x2-x1) end proc:
R := 3:
ang := [0, (1/3)*Pi, 3*Pi*(1/4)+.2, 7*Pi*(1/6)+.4, 8*Pi*(1/5), 13*Pi*(1/7)]:
for i to 6 do P || i := [R*cos(ang[i]), R*sin(ang[i])] end do:
pts := [seq(P || i, i = 1 .. 6)]:
for i to 6 do tang || i := x*P || i[1]+y*P || i[2] = R^2 end do:
sol:=solve({tang1,tang3},{x,y}):Q13:=[subs(sol,x),subs(sol,y)]:
sol := solve({tang1, tang2}, {x, y}): Q1 := [subs(sol, x), subs(sol, y)]:
sol := solve({tang2, tang3}, {x, y}): Q2 := [subs(sol, x), subs(sol, y)]:
sol := solve({tang3, tang4}, {x, y}): Q3 := [subs(sol, x), subs(sol, y)]:
sol := solve({tang4, tang5}, {x, y}): Q4 := [subs(sol, x), subs(sol, y)]:
sol := solve({tang5, tang6}, {x, y}): Q5 := [subs(sol, x), subs(sol, y)]:
sol := solve({tang1, tang6}, {x, y}): Q6 := [subs(sol, x), subs(sol, y)]:
ptQ := [seq(Q || i, i = 1 .. 6)]:
line14 := line(Q1[1], Q1[2], Q4[1], Q4[2]): L14 := implicitplot(line14, x = -10 .. 10, y = -10 .. 10, color = red):
line25 := line(Q2[1], Q2[2], Q5[1], Q5[2]): L25 := implicitplot(line25, x = -10 .. 10, y = -10 .. 10, color = red):
line36 := line(Q3[1], Q3[2], Q6[1], Q6[2]): L36 := implicitplot(line36, x = -10 .. 10, y = -10 .. 10, color = red):
sol := solve({line14, line25}, {x, y}): I1 := [subs(sol, x), subs(sol, y)]:

lineP23 := line(P2[1], P2[2], P3[1], P3[2]): lineP56 := line(P5[1], P5[2], P6[1], P6[2]):
sol := solve({lineP23, lineP56}, {x, y}): gamma := [subs(sol, x), subs(sol, y)]:
lineP12 := line(P1[1], P1[2], P2[1], P2[2]): lineP45 := line(P4[1], P4[2], P5[1], P5[2]):
sol := solve({lineP12, lineP45}, {x, y}): beta := [subs(sol, x), subs(sol, y)]:
lineP34 := line(P3[1], P3[2], P4[1], P4[2]): lineP16 := line(P1[1], P1[2], P6[1], P6[2]):
sol := solve({lineP16, lineP34}, {x, y}): alpha := [subs(sol, x), subs(sol, y)]:
pl:= line(alpha[1], alpha[2], gamma[1], gamma[2]):
hexa := seq(implicitplot(tang||i, x = -20 .. 20, y = -20 .. 20, linestyle=3,color = blue),i=1..6):
#hexa:=plot([seq([P||i,P||(i mod 6)+1],i=1..6),color=green): 
#hexa:=plot([seq([P||i,P||(i+1)],i=1..6)],thickness=4,color=green): 
hex:=plot([[Q1,Q2],[Q2,Q3],[Q3,Q4],[Q4,Q5],[Q5,Q6],[Q6,Q1]],thickness=4,color=green):
tp := textplot({seq([op(pts[i]), cat("P", i)], i = 1 .. 6)}, 'align' = {'above', 'left'}):
tpq := textplot({seq([op(ptQ[i]), cat("Q", i)], i = 1 .. 6)}, 'align' = {'above', 'left'}):
TP:=textplot([[I1[],"I"],[alpha[],"alpha"],[beta[],"beta"],[gamma[],"gamma"]],'align' = {'above', 'left'}):
slopes:=[seq(((dx,dy)->dy/dx)((pts[i]-pts[(i mod 6)+1])[]),i=1..6)]:
lines:=zip((pt,slope)->y=slope*(x-pt[1])+pt[2],pts,slopes):
plotpts:=plot(pts,style=point,colour=red,symbol=solidcircle,symbolsize=5):
plotptQ:=plot(ptQ,style=point,colour=black,symbol=solidcircle,symbolsize=5):
plotlines:=plot(rhs~(lines),style=line,linestyle=3,colour=magenta):
cir:=implicitplot(x^2+y^2=R^2,x=-R..R,y=-R..R,color=black):
PL:=implicitplot(pl,x=-1..15,y=-15..6,color=blue,thickness=3):
display(plotpts,plotptQ,plotlines,hex,cir,L14,L25,L36,PL,tp,tpq,TP,axis = [gridlines = [4, color = blue]],
view=[-6..10,-15..6],scaling=constrained,axes=none,size=[800,800]):
How to simplify this program ? Thank you.

First 165 166 167 168 169 170 171 Last Page 167 of 2141
´╗┐