MaplePrimes Questions

I am attempting to use maplev mode for emacs. Ubuntu 20.04.3, Emacs 26.3, maplev-mode from git, release-2.36-59-g142c03. maple 2021.

I copied mload from an older computer and added a line to define maple, after the original maple definition line.

MAPLE=${MAPLE:-maple} # Maple script
MAPLE=/usr/local/Maple2021/bin/maple  <=== added

I compiled and installed maplev-mode. I had to touch doc/version.texi because the file did not exist. But, otherwise, I saw no errors.

I added lines to my emacs init.el as per the README.md.

maplev-mode seems to load when I edit a .mpl file.

However, mint is not defined.  Where should I change to define the location of mint?

/usr/local/Maple2021/bin/mint

Tom Dean

It has been a decade or more since I have seen an option for lifetime enrollment for anything. Does maple calculator even have such an option available? If not, why not?

Hi all,

I want to verify the sum of associated Laguerre polynomials as shown in the picture below. I have tried numerical, but I am struggling with the syntax.

Anyone know how to do that?

For compact technical documentation it would be desirable to create output in the form of a=b=c, which is a style that is commonly used in textbooks (probably for the same reason).

It is possible to create such an output with non executable math and probably also with document blocks. This is error prone and time consuming. I am looking for a solution where I can use Maple commands to refer to expressions to assemble an a=b=c output.

The advantage: Using commands would change the output when the expression change (at least after re-execution of the document).

How can this be done?

I'm attempting to use the GoogleMaps command however it doesn't appear to work

FindLonLat("Waterloo") just returns the command.  What now?

Colored axes and showing 5 colored branches (Riemann surfaces) and ln(z)  as a spiral

There is a plotcompare(log(z), expression_plot, 3); branches(ln);

FunctionAdvisor(branch_cuts, log(z));
                         [ln(z), z < 0]

The principal branch is the red colored one : Pi..-Pi (difficult to see here )


                                       pic 1

Compare this pic 1  with the Imaginaire plot log(z) in plotcompare command.

Hi,

Happy new year.

I have a problem, if it is possible please guide me.

I want to add "arrows=small/curve/...." (i.e. vector fields) to the following maple's example, but unfortanutley it does not work (see the green code and run it ....).

It is not important to me that I use phaseportrait or DEplot or dfieldplot, I just want to show arrows in any "scene" that I choose.

restart;

with(plots);
with(DEtools);
with(VectorCalculus);
BasisFormat(false);

DEplot({D(w)(t) = x(t) - w(t)*z(t), D(x)(t) = y(t) + z(t), D(y)(t) = -x(t) - y(t) + w(t), D(z)(t) = x(t) + y(t) - z(t)}, [x(t), y(t), z(t), w(t)], t = 0 .. 10, [[x(0) = 0, z(0) = 0.25, y(0) = 0.5, w(0) = 0.165]], scene = [z(t), w(t)], numsteps = 101, axes = BOXED, linestyle = dashdot, method = rkf45, startinit = true, maxfun = 5000, xtickmarks = 10, arrows = medium);

Indeed I want to get something like this:

DEplot([diff(x(t), t) = -0.5*x(t)*y(t), diff(y(t), t) = 0.5*x(t)*y(t) - 0.15*y(t)], [x(t), y(t)], t = 0 .. 40, x = 0 .. 1, y = 0 .. 0.6, [[x(0) = 0.99, y(0) = 0.01]], arrows = medium);

In this plot, we can observe arrows (vector fields), but in the first example, I cannot to handle it.

Thanks in advance.

When the new Beta application center becomes active and the old one is obsoleted (sigh) many links to the applications centers from here (mapleprimes) will be broken.  Or will the links be directed to the proper location?

Hi,

I tried a simple expressioin using imaginary numbers in MapleFlow,

a:=1 + 2*i

but got the following error:

¨'mn' is not numeric"

does anyone know what is happening?

thanks very much.

In this example, i have a top module A. Inside it, I have module named my_RECORD (which happened to be option object) that I want to return back to caller when they call a proc.

Maple allows me to declare the proc to return my_RECORD. No problem., But when making a local variable inside the proc and using o::my_RECORD it complains  that my_RECORD does not exist. 

The solution is to change o::my_RECORD to o::A:-my_RECORD

My question why it did not complain the same way on the return value on the proc?   for me, they are both semantically the same. One says the proc returns this type, and the other says the local variable is this type. So why had to do A:-my_RECORD on one but not the other? 

Here is an example. Maple 2021.2 on windows 10.

restart;

interface(warnlevel=4);
kernelopts('assertlevel'=2):

3

A:=module()
 #this is the RECORD to return
  local module my_RECORD()
   option object;
   export data::string:="";
  end module;
   
  export do_analysis:=proc()::my_RECORD;   
    local o::my_RECORD; #error here. But this is the same above line above?    
    o:=Object(my_RECORD);
    o:-data:="test";
    return o;        
  end proc;
end module;

_m2642451182336

A:-do_analysis()

Error, (in do_analysis) type `my_RECORD` does not exist

#FIXED BELOW
restart;

A:=module()
    #this is the RECORD to return
    local module my_RECORD()
        option object;
        export data::string:="";
    end module;
   
    export do_analysis:=proc()::my_RECORD;
          local o::A:-my_RECORD;    
          o:=Object(my_RECORD);
          o:-data:="test";
          return o;        
    end proc;
end module;

_m2642339719872

A:-do_analysis()

module my_RECORD () export data::string; option object; end module

 

Download A_no_lib.mw

hi,

I looked at the file mapleflowrc and saw that it lists several palettes that are not visible in the workshheet dock.

Does anyone know if these palettes are available in mapleflow? And if so, how to make them visible in the worksheet dock?

thanks very much in advance.

As maple 1d input:

expr:=(1/2)*a*(b/c)/d;     

As 2 d input : 

This rightside of the equation i like to get in Maple , but how?

answer

I have a very simple task:

convert([a,b],`*`)

the result is of course a*b.  However if I load the Physics package beforehand, that is,

with(Physics)
convert([a,b],`*`)

the followinkg error shows up:

Error, unrecognized conversion: Physics:-`*`

I have read that the Physcs package redefines the mutiplication. This must be the source of the problem.
But how can I proceed. I need to do this task with the Physics package loaded. 
Any help will be appreciated! 

Hello everyone, I'm trying to interpolate a function using the roots of a Chebyshev polynomial as interpolation points, and then compute the absolute error. I want to compute that error via numerical integration, however, Maple is returning the expression of the integration itself. Why is that?

This is the code I'm using:

with(CurveFitting):

u := x -> exp(1/2*x^2 - 1/2):

r := evalf(allvalues(RootOf(ChebyshevT(5, x), x))):
points := Vector(5, i -> r[i]):
u_points := Vector(5, i -> u(points[i])):

P__2 := PolynomialInterpolation(points, u_points, x):

evalf(int(abs(u(x) - P__2), x = -1 .. 1))

This is the result:

I often create diagrams in Maple and export them so I can embed them in a Word Doc.  Lately, when I right-click on the picture so I can select "export," the entire program closes.   It seems to happen more when the picture is in 3D.   Am I doing something wrong?     Thanks.

           David

First 76 77 78 79 80 81 82 Last Page 78 of 2155