MaplePrimes Questions

He intentado utilizar el comando "SolveSteps" y no he podido lograr que se muestre los pasos de la solución, incluso copié el siguiente comando que aparece en la ayuda: SolveSteps([12*x + y = 18, 7*x - 8*y = 32]), donde aparecen una serie de pasos antes de llegar a la respuesta final, pero al escribirlo en la "hoja de trabajo", no me aparece el desarrollo del ejercicio, sino que el mismo comando y la ecuación que escribí. Acaso debo de instalar los comandos, será que no vienen predeterminados, o será porque tengo una versión temporal de 15 días, que no permite utilizar dichos comandos?

Gracias por su ayuda.

Hello MaplePrimes, 

So, I have used the discont=true option in the past and it has worked fine for me but for some reason with these functions I am using now the plots are still containing the veritcal asymptotes. Anyone spot something I am forgetting or doing incorrectly?

I have attached my maple file for easy viewing. 

Thanks. 

DiscontQuestion.mw

 

Hello,

How i use maple to get the formal solution of this non autonomous system :

dsys := {diff(x(t), t) = (a*p*S/h + (-o - u))*x(t) + f(t)*p*S*y(t)/h, diff(y(t), t) = a*(1 - p)*S*x(t)/h + (f(t)*(1 - p)*S/h - b)*y(t)}

I tried dsolve(dsys) but maple consider the set of solution with x(t) y(t) and f(t), but f(t) is a parameter of the system. I search a solution for x(t) and y(t).

Thank you

I easily found the roots of the following equations,

s:=solve(x^3+x^2-2*x-1,x)

I accidentally discovered that  2*cos((2*Pi)/7) is also the root of this equation. 

simplify(eval(x^3+x^2-2*x-1,x=2*cos((2*Pi)/7)))

0

It’s easy to know that 2*cos((2*Pi)/7) is equivalent to the third root found above

s1:=fsolve(x^3+x^2-2*x-1,x);
2*cos((2*Pi)/7.)

         s := -1.801937736, -0.4450418679, 1.246979604

                          1.246979604

 

Maybe I don’t like the use of imaginary units, and I prefer  2*cos((2*Pi)/7) .

In the case that I don’t know that  2*cos((2*Pi)/7) is the solution of the equation, can I make a certain transformation without using the imaginary unit to represent the real number. For example, trigonometric functions, exponential functions, etc.

I tried to use the following functions, all failed.

s:=solve(x^3+x^2-2*x-1,x);
convert(s[3],cos);
identify(s[3])

 

What is interesting is the following phenomenon. Even if Zeta function does not look great:

s1:=fsolve(x^3+x^2-2*x-1,x):
identify(s1[3])

 

 

For this example, can all roots be transformed into trigonometric expressions by maple.

 

 

Can someone please tell me why is my output not ''-cos(x) '' but this:

And how can I set up the worksheet to give me the outputs I want?

Few months ago, someone was kind enough to send me an email letting me know that in Maple 2021 the following new change will be in Object

I am attending a workshop on OOP.  In Maple 2021, one will be able 
to invoke a method of an instance of an object with the  syntax:  object_name:-method_name

However, I am not able to get the above to work in Maple 2021. And I looked at the help pages and see no such example. This is what I tried

restart;
module person()
    option object;
    local name := "me";   

    export get_name::static := proc( self::person, $ )
        self:-name;
    end;

    export set_name::static := proc( self::person, name, $ )
        self:-name:=name;
    end;

end:

p:=Object( person ); #create object

p:-get_name();

Error, invalid input: person:-get_name uses a 1st argument, self (of type person), which is missing

What changes are needed in the above code to be able to use  obj:-method()  syntax?

Or is it possible that this change did not go into Maple 2021?


 

Hey

 

I can't find the toolbar for drawing i Maple 2021. 

Can anyone help me? I'm using Macbook.

 

I try to clik on at picture but I can't see it.

I try to insert a drawnig but I can't see it.

 

Hope someone can help me.

I would like to use the command "TensorArray"  to create the contravariant tensor.  As seen in the following simple routine, the command output seems to assign values to the contravariant tensor, but, on the last line, the contravariant value is still unassigned. 




 

 

 

Hello,

I have solved a differential equation from which I get a solution that contains special functions

BesselK(a1,b1) but also BesselK(a2,b2) and many time the same function but with different parameters

Now I would like to study asymptotics of the solution for small argument of the BesselK functions.

So I would like to replace each BesselK(x,y) (for any x and y) function by the corresponding small argument asymptotics 1/Gamma(x)*(y/2)^(-x)

Is that possbile or do I have to replace each of them manually?

Thanks in advance

 

 

Hi,

I am using Maple 13, 16 and 17 on 64 bit ubuntu 14.04LTS without 

any problems.

 

I tried to start the above Maple versions after upgrading to ubuntu 18.04LTS. Unfortunately, Maple does not start and transmits an incorrect hostid error message. The error message for Maple 16 is pasted below.

 

The command ifconfig -a produces an ethernet address 00:21:70:a6:a4:4b that is identical to the hostid given in the license.dat file.

 

I believe that the license manager flexnet is 32 bit. I used the synaptic 

manager to install lsb-base and ia32-libs (synaptic package manager refused to install lsb-core and transmitted some error messages). However, this did not help and I obtained the same hostid error message.

 

I do not know what is causing the hostid error message. Maybe some script file/s in the Maple installation can be modified such that Maple starts correctly?

 

Any assistance in getting Maple 13, 16, 17 to start on ubuntu 18.04LTS 

would be much appreciated.

 

Thank you very much for your support.
CF

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
 

> ...:~/maple> maple16
> Maple initialization error, Invalid host.
> The hostid of this system does not match the hostid
> specified in the license file.
> Feature: Maple16
> Hostid: 002170a6a44b
> License path:
> /home/apps/maple16/toolbox/MapleSim/license/MapleSim.dat:/home/apps/maple16/license/license.dat:
> FLEXnet Licensing error:-9,57
> For further information, refer to the FLEXnet Licensing documentation,
> available at
> "https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.acresso.com&c=E,1,5ci9cywR8uvrXaVJ4IkoXH0TFBBbJwSK_TulrfrUDs5AyVQ4TXsHOVm5KWKAIhp4OZb9C4OAnmgylY1JC6fpbdZK9SjQLVrW012Uzxq18iDYC56NG2eDyHS8RPA,&typo=1".
.......
>

> root@<mailto:root@>...:~# ifconfig -a
> enp0s25: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
> ether 00:21:70:a6:a4:4b txqueuelen 1000 (Ethernet)
> RX packets 0 bytes 0 (0.0 B)
> RX errors 0 dropped 0 overruns 0 frame 0
> TX packets 0 bytes 0 (0.0 B)
> TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
> device interrupt 22 memory 0xf6ae0000-f6b00000
>
> lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
> inet 127.0.0.1 netmask 255.0.0.0
> inet6 ::1 prefixlen 128 scopeid 0x10<host>
> loop txqueuelen 1000 (Local Loopback)
> RX packets 454 bytes 35138 (35.1 KB)
> RX errors 0 dropped 0 overruns 0 frame 0
> TX packets 454 bytes 35138 (35.1 KB)
> TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

 

 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
 

EDIT 
x*f'(x^2)  + g'(x) = cos(x)  - 3x^3 and f(x^2) + g(x) = sin(x) -x^4. 

How to find the function f like this:
x*f'(x)  + g'(x) = cos(x)  - 3x^3 and f(x^2) + g(x) = sin(x) -x^4. 
I know that, f(x) = -1/2*x^2 + C. But, I tried. This answer incorrec. 
restart;
f := x -> -1/2*x^2 + C;
g := x -> sin(x) - 1/2*x^4 - C;
diff(f(x^2), x);
f(x^2) + g(x);
x*diff(f(x^2), x) + diff(g(x), x);

The uploaded worksheet describes a chain driven at constant speed by gears.

What math will describe its shape?

GearDrivenChain.mw

Greetings!

I am unable to evaluate an improper integral involving rational, exponential and Bessel functions. Can Maple do it? if not is there a way around.

test.mw

Would be nice if someone could add Maple 2021 to Software Change Requests list.

Right now Maple 2021 is unusable for us due to a big problem related to saving workbooks.

First 192 193 194 195 196 197 198 Last Page 194 of 2195