MaplePrimes Questions

Hi everybody:

i want to obtain the binary(basis of two) of a number with procedure and without use the convert command, can everyone help me? tnx.

Hi,

I am trying to find k1,m1,k2,m2 from these four equations defined in sys but Maple does not give any solution. Any suggestions?

sys := {(k1*m1+k1*m2+k2*m1+sqrt(k1^2*m1^2+2*k1^2*m1*m2+k1^2*m2^2+2*k1*k2*m1^2-2*k1*k2*m1*m2+k2^2*m1^2))/(2*m1*m2) = (2*Pi*8.78)^2, .8347192842*k1/m1 = (2*Pi*4.8515)^2, -(-30.85287127*k1-k2)/m2 = (2*Pi*8.78)^2, -(-k1*m1-k1*m2-k2*m1+sqrt(k1^2*m1^2+2*k1^2*m1*m2+k1^2*m2^2+2*k1*k2*m1^2-2*k1*k2*m1*m2+k2^2*m1^2))/(2*m1*m2) = (2*Pi*4.8515)^2};

solve(sys, {m1,k1,m2,k2});

Thanks,

Bahar

 

I have 6 parameters, say p1 - p6, which enter my Monte Carlo Code and computes a 1-D Array of floats of size 1000 . I have an experimental array of floats of the same size. My code outputs an array which is the difference of these two arrays. The objective function is the sum of the sqares of the elements in this output array. I have initial guess for the parameters: p1i - p6i. I need to find the values of the 6 parameters which minimize the objective function.

Obviously I do not have an explicit mathematical form for the objective function and nor its Jacobian.

Could some one please help me in this task.  Thanks in advance. 

Greetings, I am trying to make augmented matrix in the form of A, B and F where A is the tridiagonal matrix, B is the vector and F is the non-linear part of the system. I already tried (A,B,F):=augment(X,output='A','B','F'); but it is an error. Can someone help me? Thank you in advance!

 

 

The matrix X is as follows:

 

X:=[[[-lambda/(h^2),-u/(2 h)+lambda/(h^2),0,0],

       [u/(2 h)+lambda/(h^2),-lambda/(h^2),-u/(2 h)+lambda/(h^2),0],

       [0,u/(2 h)+lambda/(h^2),-lambda/(h^2),-u/(2 h)+lambda/(h^2)],

       [0,0,u/(2 h)+lambda/(h^2),-lambda/(h^2)]]];

I have a matrix with complex entries! and I want to multyply that by it's conjugate. But I can have a simplify form for example  I have matrix A and B as below thier multiplication is a real matrix but it does not give me in simplifyied form!

I have made a plots[multiple] with 3 different functions, but I wish to connect the ends with vertical lines. Does anybody have a solution to this? I have uploaded screenshot Thank you in advance. BR Jens

Hello people in mapleprimes,

I am writing this sentences, hoping to be given any answer from you, to the 
question I have, about conversion of Array to List.

restart;
a:=plot3d(theta*z,theta=0..2,z=0..1,coords=cylindrical,grid=[3,2]);
A:=op([1,1],a);

brings a response of Array as, which I call BB,

Array(1 .. 3, 1 .. 2, 1 .. 3, {(1, 2, 3) = HFloat(1.), (2, 2, 1) = HFloat(.540302305868139765), (2, 2, 2) = HFloat(.841470984807896505), (2, 2, 3) = HFloat(1.), (3, 2, 1) = HFloat(-.832293673094284814), (3, 2, 2) = HFloat(1.81859485365136342), (3, 2, 3) = HFloat(1.)}, datatype = float[8])

And, I converted it to List, with 

convert(A,list,nested);

The response of this is, which I call CC,

[[[0., 0., 0.], [0., 0., 1.]], [[0., 0., 0.], [.540302305868140, .841470984807897, 1.]], [[-0., 0., 0.], [-.832293673094285, 1.81859485365136, 1.]]]

, which is composed of three lists:
[[0., 0., 0.], [0., 0., 1.]]

[[0., 0., 0.], [.540302305868140, .841470984807897, 1.]]

[[-0., 0., 0.], [-.832293673094285, 1.81859485365136, 1.]]

Then, my question is following:

Seeing CC, I can see three segments are shown.
The first one is  the segment between [0., 0., 0.] and [0., 0., 1.].
But, I can't find any elements of Array BB corresponding to [0,0,0] above in CC.
And as for 0, 0 in [0, 0, 1] in CC above, the first 0 should be (1,2,1) and the second one should be (1,2,2).
But, there are no such (1,2,1) and (1,2,2) in BB. 
Despite of these, BB is converted to CC, from any reason I want to know and ask this question for.

As for [[0., 0., 0.], [.540302305868140, .841470984807897, 1.]] in BB, the circumstances are the same.
I don't know from where [0,0,0] appeared. Surely, as MESH requires three points, you might say that
such things might occur. But, it is only after I converted Array BB to List CC, with plot3d or MESH then having no relation 
to the present circumstances. So, I think that it is not possible to say that Maple added [0,0,0] or such things to Array BB

 as it is about plot 3D or about MESH.

So, my question is how the conversion of BB to CC could have occurred.

Thanks in advance.

May_16_2018_question.mw

How can I this problem using maple when you are meant to use a linear transformation and find an equation for eq* using a matrix.

 

 

The matrix

 

The eqution.

eq := 2*x-3*y+z = 4

eq*

This is how the problem is specifed. 

A: eq --> eq*

 

I am getting this error for pretty much everything now, i am using maple 16, and there literally is no way i will be able to buy a newer version considering

restart

latex(alpha, beta)

Error, (in latex) permission denied: no write access (C:\Users\the_r\Desktop\MAPLE_DOCS\NUMBER_THEORY\IDENTITY_INVESTIGATION_ARCHIVE_SYSTEM\beta)

 

``


 

Download mapleHELP.mw

Hi, I wrote the following code 

p := 4*N/(Pi*d^2)
y := (1/2)*b

x := (1/2)*B

And I am trying to expand the following double integral 

M := 4*u*p*(int(sqrt(x^2+y^2), [y, x]))

 

But I keep getting the error:

Error, (in int) integration range or variable must be specified in the second argument .

 

When I define B and b just as B and b, the error is gone and it works, but as soon as I add 1/2 to the values, the error occurs. Please help me out here :(

Hi i wanted to see how this function is generated so i entered:

numtheory:-ithrational := proc(i::nonnegint)
   1   if i = 0 then
   2     return 0
       end if;
   3   return numtheory:-ithratB(i-1)/numtheory:-ithratB(i)
end proc

showstat(ithratb)  returns the error that this function is not in the number theory package, which is the complete opposite of what is implied by the above.

I have the following equation:

eqn := m*`ℓ`^2*(diff(q[1](t), t, t))+k[t]*`ℓ`^2*q[1]+5*k[r]*q[1]-4*k[r]*q[2]+k[r]*q[3]-5*P*`ℓ`*q[1]+2*`ℓ`*P*q[2]+2*`ℓ`*T*q[1]-`ℓ`*T*q[2] = 0;

And I want to execute the following substitutions:

k[r]/(k[t]*`ℓ`^2) = alpha;
P/(k[t]*`ℓ`) = sigma
T/(k[t]*`ℓ`) = theta

For that, I have tried:

expand(eqn/(k[t]*`ℓ`^2));
eqn1:= algsubs({k[r]/(k[t]*`ℓ`^2) = alpha, P/(k[t]*`ℓ`) = sigma, T/(k[t]*`ℓ`) = theta}, %);

And:

eqn1:= algsubs(k[r]/(k[t]*`ℓ`^2) = alpha, %);
eqn2:= algsubs(P/(k[t]*`ℓ`) = sigma, %);
eqn3:= algsubs(T/(k[t]*`ℓ`) = theta, %);

But none of these have worked. Does anyone know how to solve this?

Thanks in advance.

Can we use this euler lagrange command for the system of pde's?

If we have a system without lagrangian then euler opertor is applied corresponding to three dependent variables.

so we have three equations but in this euler lagrange command no dependent variable is mentioned.   

Hello people in mapleprimes,

I am writing this question, hoping you to teach me about the meanig of the Array in a plot3d object.

c:=plot3d(x*y,x=0..2,y=0..1,coords=cylindrical,grid=[3,2]);
lprint(c);

makes 

PLOT3D(MESH(Array(1 .. 3, 1 .. 2, 1 .. 3, {(1, 2, 3) = HFloat(2.), (2, 2, 1) = HFloat(1.08060461173627953), (2, 2, 2) = HFloat(1.68294196961579301), (2, 2, 3) = HFloat(2.), (3, 2, 1) = HFloat(-1.66458734618856963), (3, 2, 2) = HFloat(3.63718970730272684), (3, 2, 3) = HFloat(2.)}, datatype = float[8])))

I thought I had known the cylindrical coords.
And, I think that (1, 2, 3) in  (1, 2, 3) = HFloat(2.) means the value of x*y when x, the angle, =0, y, the hight, =1, z, distance from the origin, =3. And, it should become 0, as the value of x, times 1, the value of y, equals 0. But, it takes HFloat(2.) as
shown in (1, 2, 3) = HFloat(2.).

And, as for (3, 2, 1) = HFloat(-1.66458734618856963), which means x=2 and y=1, I think the value of x*y=2. But, 
it is wrong as seen in  (3, 2, 1) = HFloat(-1.66458734618856963). 

I hope you will teach me how to consider about sample points in the cylindrical plot.

Thank you advance.

 

 

 

 

First 568 569 570 571 572 573 574 Last Page 570 of 2173