MaplePrimes Questions

Dear Comrades, I'm trying to solve a system of coupled integral equations. Does anybody know how to use IntSolve? And what's the shared library? Do I have to download IntSolve from somewhere? And is this the best way to spolve integral equations if I did? Regards, Andrew
Hello, I know it is possible to catch errors using traperror and lasterror... But is it possible to also catch warnings in any way? It seems they are only messages that are printed on the screen. So, using OpenMaple/C, they can be extracted from the textCallBack stream (using id 5)... but is this also possible in the Maple environment itself, and if so, how? -- Regards, Franky.
New info on the "label=" question. I open a new work sheet and enter solve({x^2-y^2=y,2*x*y*=x}). The answer returned includes RootOf(_Z^2-3, label=_L2). Then I copy and paste that solve command after the next prompt and solve the same exact problem again. This time I get the same exact answers EXCEPT that the label is now _L5 and if I solve the same exact problem a third time I get a third label. I can only conclude that the label has nothing to do with the solutions to the problem. This makes me wonder what then is the purpose of a label? Why is it returned? What significance should one attach to it? I don't want to get bogged down about what the spec says or whether this is a bug.
I would like to import a big dataset in Maple and this is giving me some difficulties. Although Maple does have an Importdata-command, I can't figure out exactly how it works. The dataset I want to import is an excel file consisting of 2000 observations with 7 variables. Can this be done and made usefull in Maple, or do I really have to sit down and learn SAS..?
View on MapleNet or Download
View file details I'm going through the introductory programming guide for maple 11, and I recently worked on some exercises. Instead of just computing, I tried to create a procedure for the first exercise of exercise set 1.6 on page 21.
I have a system of equations where unkowns are functions of variables > eqns:= {a(s,y,z,t)+2*b(s,y,z,t)=0,3*a(s,y,z,t)-5*b(s,y,z,t)=0}; I would like to get the matrix associated to the system. I tested genmatrix but maple returns `equations are not linear ` Anyone have an idea of how to do this?
I have a large set and I would like to do the following efficiently: 1) use selectremove to split off a part of the set, based on a function f 2) map a function g onto the selected set 3) (optional) map a function h onto the removed set I don't actually need 3) however I think it would be useful. My problem is that the function g is easily computed while computing f, so something like the following is 2x too slow:
S, R := selectremove(f, big_set);
S := map(g, S);
On the other hand, g outputs a result of a different type, so I can code g to return the identity unless the condition in f is satisfied:
I get RootOf(_Z^2-3, label = _L2) in an answer. My understanding is that RootOf _Z^2-3 would be a root of Z^2-3=0 or plus or minus the square root of 3, but after reading the RootOf help sheet I still cannot figure out what label = _L2 means. My gut feeling is that it means one of the two roots, either -sqrt(3) or +sqrt(3) but that bothers me because I think that both are ligitimate solutions to the problem. Could someone please explain what label = _L2 means? The help sheet says something about label=e where e can be anything which wasn't at all helpful. Thanks. P.S. The problem that provided this issue is solve({x^2-y^2=y,2*x*y=x}) and in the second equation the x on each side should not be cancelled because x=0 is one solution.
I would to get some ideas on how to write a maplet code that will animate step by step how to draw a rectangle ABCD: Draw side AB, and after this is done without removing side AB, draw side BC, and after this done without removing sides AB and BC, draw CD, and after this done without removing AB, BC and CD, draw DA. Although this is not really my problem, it is similar to the animation I am trying to create. Rectangle ABCD is constructed without user intervention. Thank you for any assistance you may come up with.
Using _EnvAllSolutions:=true; with solve(sin(x)=1,x)the answer returned is 1/2Pi+2Pi_Z1~. The Maple User Manual on page 82 says that Maple uses variables of the form _ZN~ to represent arbitrary integers thus my understanding is that the answer returned can be interpreted as 1/2Pi+2nPi where n is any integer. Correct? Now for the more difficult situation where I an not sure my understanding is correct. Using _EnvAllSolutions:=true; with solve(sin^2(x)/x,x)the answer returned is Pi(2_Z1~+_B1~). In this case, the -Z1~ is again any arbitrary integer but _B1~ is quite different. Using about(_B1~) the return tells me that _B1~ is assumed to be : OrProp(0,1).
I am having this common problem when solving trig equations. I read "?solve" but missed something somewhere because I still don't know how to solve this problem. Taking a simple example of solve(sin(x)=1,x) the answer returned is Pi/2 and while Pi/2 is a correct answer, because of the periodic nature of the sin function there are others. So maple for some reason (which doesn't make sense to me at all)is limiting the range/domain and therefore not providing the complete answer which is Pi/2 +2nPi where n is any integer. I tried to force Maple to consider a larger range by using assume(0<>
I installed Maple 11 into my Ubuntu 7.04 machine, and I'm having a problem to make the arrow keys work when I running maple classic worksheet. All the other keys on my keyboard works fine, but Maple won't response when I hit the arrow keys(up, down, left, right). It's a problem that only shows up in "Maple classic" (xmaple -classic). Any suggestions?
When I enter solve((sin(x))^2/x=0,x) in Maple 11, nothing is returned. When I enter the same thing in my voyage200 calculator, the correct answer of x=@n1*Pi where @n1 is any integer constant is returned. Why can't I get maple to produce the correct answer? Is this a bug?
What does the term Tool Box mean as used with Maple?
Hi! I have an external library with this function: double test(double x) { return sin(x); } In Maple I am doing this: test := define_external('test', x::(float[8]), RETURN::(float[8]), LIB = "Test.dylib"); f := x->test(x); Now when I call f(2) for example, I get 0.909297426825681710 back. But if I try this: plot(f(y), y = 0 .. 2); I get this error message: Error, (in f) invalid input: test expects its 1st argument, x, to be of type numeric, but received y I think I need to somehow convert the (possible) symbolic input of f into a float[8] before it is passed to the procedure test, but I can't figure it out.
First 2235 2236 2237 2238 2239 2240 2241 Last Page 2237 of 2338