MaplePrimes Questions

Hi, I'm having trouble getting the collect function to do what I want. Namely, I would expect collect( a*x^b + x^b, x) to return (a+1)*x^b. Here, a and b are variables. Collect only seems to work if either a or b has a defined value (e.g. a=2, b is undetermined). What am I doing wrong here?
I have the following: arrays arrC of type double in a C code and a fct in Maple allowing arrM of type Array(datatype = float[8]) as argument. I want to evaluate the fct using arrC as input. For that one can either use 'MapleAssignIndexed' (looping through the elements if there are not very much of them), or 'RTableCreate' (details omitted). Both seem to need some overhead which costs time. Is there a way to use something like the C function memcpy to copy the array to Maple (assuming the correct space can be supplied) to speed it up? Does one have to work with byte arrays instead for that - or is it
Hi! The Maple 10 installation worked fine. No problems at all. I've installed the 2 updates 01 and 02. The command line maple works. BUT xmaple denies to start. I see no error message. May a java related problem which I am not able to fix myself. Help is very apreciated! Regards, Arno
Hi! Can sombody tell me when a native version for Intel based Macs will be available. I tried the G5 binary installer which didn't start. Thanks, Arno
Hello, I was wondering whether there is any way to protect a table. I have the following situation: > f := table([ a = table([ a1 = 1, a2 = 2 ]), b = table([ b1 = 3, b2 = 4 ]) ]); That is, f[a] returns another indexed table. Now, when I do protect(f), protect(f[a]) or even protect(f[a][a1]), I cannot change its value any more: > protect(f); > f[a][a1] := test; Error, attempting to assign to array/table `f` which is protected But if I assign f[a] to a new variable g, then I can do it: > g := f[a]; > g[a1] := test; > eval(f); table([a = table([a1 = test, a2 = c]), d = table([d1 = i, d2 = j])])
I encountered the pair command in order to zip a pair of variabels. This is usefull for 2d plot. Is there's a way to do it for 3d plot, meaning zipping three parameters?
I noticed that this function is used only for a discontinous function. What can I do if I have a discontinous data?
I'm trying to generate a list of solutions by changing two parameters as follows (T,x[1,a]): A:=0.2:Q:=273.15: > J:=10: > K:=283.15: > U:=0.4: > V:=0.1: > W:=0.8: > N:=(K-Q)/J+1: > M:=(W-U)/V+1: > data:=[]: > List:=[]: > forget(fsolve); > for T from Q by J to K do > eq[1]:=x[1,a]*alpha[1,a]=x[1,b]*alpha[1,b]: > eq[2]:=x[2,a]*alpha[2,a]=x[2,b]*alpha[2,b]:
Hey all I would like to know if after solving a Matrix Differntial Equation (general form, no initial conditions) there is a way to convert the solution matrix to equation form (i.e. y(t)= C_1e^(3t)+C_2e^(-t)+... etc). see yas david
Hello all, I'm having trouble with working out an animation problem in maple 10 which I was hoping someone might be able to give me an idea on. I have a series of x,y coordinates to draw a line on a graph, where the coordinates are combined as a 2D list like this: list1 = [x1,x2,x3,...] list2 = [y1,y2,y3,...] ... pairxy:=(x,y)->[x,y]: comblist := array(zip(pairxy,list1,list2)): Ive a number of these combined lists, and I'm trying to create an animation which displays each list in turn, making the line appear like it is moving. I thought since I can create a single plot of one list using the plots tools then I could create an animation by calling each list iteratively over a loop, but Ive been trying to create the animated graph, and it doesnt seem to want to work for me, I dont seem to be able to pass my coordinates to the animation function parameters.
I am first install Maple 9.5 under SUSE 9.2 in the directory of
/usr/local/maple. When I use ./xmaple to start it, it reported 'Connection to Kernel lost'. How to repair this one?
so check this out... i have to create this map to represent the different elevations and then create the various trails shown on the third figure in red. And you have to create the entire grid using a piecewise function. how exactly do you do this? i have no clue how to even get started with maple let alone create a whole new map and all. is there anyone who is really skilled at this type of work who can help me? i'm sure for you guys this is like a piece of cake, but for me...i'm totally clueless. help please!
Hi, I'm using Maple 10 on a linux (Ubuntu) platform. With Maple 9.5, there was a script in the installation folder to uninstall it, but I can't find anything of the likes in the Maple 10 folder! When I installed v10, I just pointed it to ~/.maple10, so would it be safe to assume everything's in there and i can just rm the directory? In case you're wondering, it's only for reinstalling, I'm not abandoning Maple! ;) Thanks, James
I often find maple returning fractions of the following form: - (1/ (x-1)) This would look a whole lot nicer if maple could simplify it to the equivalent: 1/(1-x) I've tried various forms of simplify, breaking up the numerator and denominator then recombining them, etc., but I can't find a general way to do this. Is it possible to customize "simplify"'s notion of complexity?
for engineering purposes the ability to input a multi-variable equation in one form and then apply the known variables and solve for the numeric unknown is very handy. such as an equation of horesepower,torque and rpm. is there an easy way to do this in maple 10?
First 2283 2284 2285 2286 2287 2288 2289 Last Page 2285 of 2315