MaplePrimes Questions

Hello,

I'm encountering an issue with the "roots of complex number" message while running my Maple code. Maple seems unable to solve this problem for me.

I would greatly appreciate any ideas or suggestions that could help me resolve this error.

Vib-code.mw

I still see these Maple internal errors in Maple 2024.

Now calling odetest.

The problem is that it is not possible to catch them.

Any suggestion what to do and what causes it?

11196

interface(version);

`Standard Worksheet Interface, Maple 2024.0, Windows 10, March 01 2024 Build ID 1794891`

Physics:-Version();

`The "Physics Updates" version in the MapleCloud is 1727 and is the same as the version installed in this computer, created 2024, April 17, 19:33 hours Pacific Time.`

sol:=y(x) = (exp(RootOf(-sin(x)*tanh(1/2*_Z+1/2*c__1)^2+sin(x)+exp(_Z)))+sin(x))/sin(x);
ode:=diff(y(x),x)-cot(x)*(y(x)^(1/2)-y(x)) = 0;

y(x) = (exp(RootOf(-sin(x)*tanh((1/2)*_Z+(1/2)*c__1)^2+sin(x)+exp(_Z)))+sin(x))/sin(x)

diff(y(x), x)-cot(x)*(y(x)^(1/2)-y(x)) = 0

try
   odetest(sol,ode,y(x));
catch:
   print("cought error ");
end try;

Error, (in anonymous procedure called from depends) too many levels of recursion

 

 

Download too_many_levels_of_recursion_calling_odetest_maple_2024.mw

Hello:

I have created a simple plot and labelled a line as follows

Lbl:=plots[textplot]([600,-Pi*floor(R)*ln(R)-0.01,typeset(-pi*floor(r)*ln(r)),font=[Helvitica,bold,10]],labels=[T," "]):

where R is a number, so the label appears near where I want it to be:

But part of the formula is floor(r) and I can't make that appear as the 2D mathematical symbol for floor(r) in the typeset;

If I make the typeset part of an axis label or a legend, I can cut and paste the math2 expression for floor(r) just before I export the plot and that works, but how do I do that for a textplot that is sitting in the middle of a plot?

Thank you.

Dear All,

I want to define a linear transformation called T, an operator on the variable x. This transformation is such that, for example, the transformation T(alpha__1*x^2*y+alpha__2*x^4*t+alpha__3*t*y) returns alpha__1*y*T(x^2)+alpha__2*t*T(x^4)+alpha__3*t*y*T(1).

Can anyone help me in this matter? At this stage of the work, I don't have a precise definition of this linear transformation.

T(alpha__1*x^2*y+alpha__2*x^4*t+alpha__3*t*y)=alpha__1*y*T(x^2)+alpha__2*t*T(x^4)+alpha__3*t*y*T(1);

Best wishes

Hopefully, this is a question relating to Mathematica, which I find virtually unreadable, and the Statistics package, which I am minimally familiar with, that someone can answer quickly.

Hence, could someone translate the following Mathematica code into Maple code? (The MmaTranslator failed at the 2nd line.)

func[x_] := 1/(1 + Sinh[2*x]*(Log[x])^2);

Distrib[x_, average_, var_] :=   PDF[NormalDistribution[average, var], 1.1*x - 0.1];
n = 10;
RV = RandomVariate[TruncatedDistribution[{0.8, 3}, NormalDistribution[1, 0.399]], n];
Int = 1/n Total[func[RV]/Distrib[RV, 1, 0.399]]*Integrate[Distrib[x, 1, 0.399], {x, 0.8, 3}]

hi , there is a simple expression ,

1D-input code: 

3*G*(`Δγ`*H - `σy`(`Δγ`) + q)/(-q + `σy`(`Δγ`))^2;

 

and I want to simplify it like below ,but failed  ,

 

hope for the result:

3*G*`Δγ`*H/(q - `σy`(`Δγ`))^2 - 3*G/(q - `σy`(`Δγ`));

then  I'd like to use algsubs , but again  a error occurs.

1D-input :

algsubs(3*G*`Δγ`/(q - `σy`(`Δγ`)) = y, 3*G*`Δγ`*H/(q - `σy`(`Δγ`))^2 - 3*G/(q - `σy`(`Δγ`)));

 

hope for some suggestions . thanks!

I think I found another clitch in odetest.

dsolve gives correct solution to this first order ode with IC. But odetest does not verify that the solution is satisfied for the IC part, but only for the ode itself. 

Below worksheet confirms the solution is also valid for the IC.   So why odetest does not give 0 for the IC part?

``

restart;

19644

interface(version);

`Standard Worksheet Interface, Maple 2024.0, Windows 10, March 01 2024 Build ID 1794891`

Physics:-Version();

`The "Physics Updates" version in the MapleCloud is 1727. The version installed in this computer is 1725 created 2024, April 15, 17:29 hours Pacific Time, found in the directory C:\Users\Owner\maple\toolbox\2024\Physics Updates\lib\`

libname;

"C:\Users\Owner\maple\toolbox\2024\Physics Updates\lib", "C:\Program Files\Maple 2024\lib"

ode:=x^2*diff(y(x),x)*cos(y(x))+1=0;
ic:=y(infinity)=Pi/3; #16/3*Pi;
sol:=dsolve([ode,ic]);
odetest(sol,[ode,ic])

x^2*(diff(y(x), x))*cos(y(x))+1 = 0

y(infinity) = (1/3)*Pi

y(x) = arcsin((1/2)*(3^(1/2)*x+2)/x)

[0, (1/3)*Pi]

#we see that odetest think the solution does not verify the IC. But it does

IC_eq:=Pi/3=limit(rhs(sol),x=infinity)

(1/3)*Pi = (1/3)*Pi

Download odetest_does_not_verfiy_correct_solution_maple_2024_april_18_2024.mw

I think what odetest did is not use limit when plugging in the values. That is why.

If we do not use limit, this is what happens:

IC_eq:=Pi/3=eval(rhs(sol),x=infinity)

And this explains the odetest output. It should have used limit.

ps. just in case also reported to Maplesoft support.

Hi, I am trying to illustrate the concept of solid areas, and I'm wondering if there's a way to easily develop them (representing each of their faces in two dimensions on the same plane) using Maple? Thank you for your help

SolidesDév.mw

Every last query I make in the AI Formula Assistant returns this message...

This happens even when I use a basic canned query shown in use-case examples (e.g., surface area, sphere).

I have accepted the Terms of Use.  Is there some other setting I need to enable? Thanks.

For the following program using dsolve to solved a differential equation with a sum of exponential inputs, the time required has a huge dependence on subtle difference in paramters.

For example, if Cl := 0.32, calculation time is 1.4 sec.    If Cl := 0.33,  calculation time is 39 sec.

Also, calculation time seems to have huge dependence  on whether or not I truncate M

Can someone please explain what is going on?

restart;
st := time();
N := 4;

T := 5.0/60;
M := 6905;
dose := t -> M*sum(Heaviside(t - 24*k/N)*exp((-t + 24*k/N)/T), k = 0 .. 2*N - 1);
Cl := 0.32;
deq := diff(C(t), t) = dose(t) - Cl*C(t);
sol := t -> rhs(dsolve({deq, C(0) = 0}));
p := plot(sol(t), t = 0 .. 48);
time() - st;
                             1.360
 

I tried to solve a Blasius problem (available in maple), but I have an error. How to solve this issue.

Download Shoot_Blasius_solution.mw

What might be the reason for the GUI loosing icons during a session? It looks like this

Mouse over let the icons reappear.

This problem is not new to me and only happens from time to tim

I have not found out under what conditions this happens.
The only thing I can say is that I didn't see it after restarting Maple.
And: Only the icons on the left-most disappear.

Everything under Windows 10

Has anyone seen the same thing?

Any idea how to fix this?

I'm trying derive the equation for a matching resistor pad.  In order for me to get a solution (eg for R2), I had to "manually" solve the one equation and then substitute the resulting value in the other.  Why doesn't solve do the same thing?  

restart

NULLeq1 := (R2+Rhi)*R1/(R1+R2+Rhi) = Rlo

(R2+Rhi)*R1/(R1+R2+Rhi) = Rlo

(1)

NULL

eq2 := R1*Rlo/(R1+Rlo)+R2 = Rhi

R1*Rlo/(R1+Rlo)+R2 = Rhi

(2)

``

R1sol := solve(eq2, R1)

-Rlo*(R2-Rhi)/(R2-Rhi+Rlo)

(3)

R2sol := solve(subs(R1 = R1sol, eq1), R2)

(Rhi^2-Rhi*Rlo)^(1/2), -(Rhi^2-Rhi*Rlo)^(1/2)

(4)

restart

NULLeq1 := (R2+Rhi)*R1/(R1+R2+Rhi) = RloNULL

(R2+Rhi)*R1/(R1+R2+Rhi) = Rlo

(5)

 

NULLeq2 := R1*Rlo/(R1+Rlo)+R2 = RhiNULL

R1*Rlo/(R1+Rlo)+R2 = Rhi

(6)

s := `assuming`([solve({eq1, eq2}, {R1, R2})], [`and`(Rhi > 0, Rlo > 0)])

{R1 = RootOf((Rhi-Rlo)*_Z^2-Rhi)*Rlo, R2 = -(RootOf((Rhi-Rlo)*_Z^2-Rhi)*Rhi-RootOf((Rhi-Rlo)*_Z^2-Rhi)*Rlo-Rhi)/(RootOf((Rhi-Rlo)*_Z^2-Rhi)-1)}

(7)
 

``

Download for_help.mw

ras5_v1.mw 

How can I  change eq13 to eq14 without using op command manually?

Thank you for your help in advance,

I want to solve a big system of equations. There are 32 equations and 32 variables. Furthermaore there are a few restrictions to 8 of those variables, for example 0<t, t<1. I put the restrictions into the set of equations I want to solve. Normaly its works quite well, but today, one of the solutions was t=-2.0000000000. But this does not fit to the inequalitys I gave into the programm. Why is that? Is there a diffrence if I mark a set of inequalitys as restrictions and put them as a further property into the solve command comparded to use those inequalitys as additional equations?  

First 9 10 11 12 13 14 15 Last Page 11 of 2324