Question: why still not able to install Physics package from cloud in Maple 2019?

I've always had problems installing Physics package from inside Maple.

I thought by buying Maple 2019 this problem will go away, but I am still not able to install this package.

I get this error

Fetching package "Physics Updates" from MapleCloud...
ID: 5137472255164416
Version: 326

File size is 10764288 bytes(10 MB). 

Installing package...
PackageTools:-Install("C:/Users/me/AppData/Local/Temp/cloudDownload3648614516733692025/Physics+Updates.maple",overwrite=true,pkgname="Physics Updates");

ERROR: The package could not be installed.
error PackageTools:-Install, "this package is intended to work 
with Maple %1; it can not be installed in the version you 
are using -- %2", "2018", "2019"

Here is screen shot


I am on windows 10 professional. Maple 2019 installed with no problems.


any suggestion to try (other what was suggeted in link at top, which is to manually download the physics package each time and update maple.ini to point to the new version)?

Is Physics package updated to work/install in Maple 2019 or does one need to wait few more days untill this happens?

Please Wait...