Question: Phyysics updates installation

My OS is Windows 7 64-bit

I can't install the Physics Updates package in Maple 2020.1 and I'm looking for suggestions from anyone who has managed to do this, particularly on the above OS

Detailed timeline Nad what I have tried so far

  1. A couple of days ago I upgraded to Maple 2020.1
  2. I immediately started getting random warnings in Maple worksheets, which essentially stated that the installed Physics package (version 707) was designed for MAple 2020.0 and needed to be updated. However when I checked for \Physics updates none were available.
  3. So far, not a big problem, I figured the a Physics Update appropriate for Maple 2020.1would become available over the next few days
  4. Today I noticed that Physics Updates version 708 was available, and I made the rash(?) assumption that this would be the version I need for use with Maple 2020.1, so I tried to install it
  5. Using the icon in the top right of the the Maple worksheet in the usual way, I tried to install this update. The relevant pop-up finishes the download process, statrts the installlation process, gets about halfway through then stops along with another pop-up saying that mserver.exe has stopped working. Since the installation process was getting nowhere, I shut down Maple.
  6. Restarting Maple, and executing Physics:-Version(), I get the output `The "Physics Updates" version "708" is installed but is not active. The active version of Physics is within the library C:\\Program Files\\Maple 2020\\lib\\maple.mla, created 2020, March 5, 1:36 hours`. So maybe it did install? No, the "default location" for this package (which on my system is C:\Users\TomLeslie\maple\toolbox) contains a 'Physics Updates' folder, but the only thing in it is a 'version.txt file, which (amongst other things) contains the line cloud-version: 708.
  7. Normallly this 'Physics Updates' folder should contain a 'lib' subfolder, which in turn contains the file 'Physics Updates.maple' - but none of these exist, so I'm not convinced by the statement in (6) above that `The "Physics Updates" version "708" is installed
  8. At this stage I go into debug mode, and amognst other things, I have tried
    1. Repeat the process in (5)-(7) above - same result (including the mserver.exe crash)
    2. Delete the default installation folder C:\Users\TomLeslie\maple\toolbox\Physics Updates, and repeat the process in (5)-(7) above - same result (including the mserver.exe crash)
    3. Try 8.1 and 8.2 above running as administrator - same result
    4. Figure that maybe I have totally screwed my Maple 2020 installation, so reinstalled it, reactivated it, and updated it to 2020.1
    5. Repeated steps 8.1 to 8.3 above with exactly the same result
  9. Decide I am getting nowhere, so delete the folder C:\Users\TomLeslie\maple\toolbox\Physics Updates. The command Physics:-Version(); now returns `The "Physics Updates" package is not installed` so I assume I'm running on the Physics version which actually ships with the Maple 2020 release
  10. All suggestion for getting Physics updates running with Maple 2020.1 on 64-bit Windows 7 will be gratefully received
Please Wait...