Question: Kernel connection lost under Ubuntu 20.04.

I run Maple 2021 under Ubuntu 20.04 on a new Lenovo laptop with 32Gb of Ram. Every time I start Maple, it runs for a few minutes and then loses the "kernel connection". I have to save the worksheet and re-start Maple. In dmesg, I find:

[ 1436.724570] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/user@1000.service,task=mserver,pid=8037,uid=1000
[ 1436.724589] Out of memory: Killed process 8037 (mserver) total-vm:31723552kB, anon-rss:31289772kB, file-rss:60kB, shmem-rss:0kB, UID:1000 pgtables:61656kB oom_score_adj:0
[ 1437.151441] oom_reaper: reaped process 8037 (mserver), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB

indicating that Maple's virtual memory exceeded 30 Gb! This happens even if the only command I execute is, for instance, "resrart" or "A:=1" and nothing else. It also happens when no other applications are running and the "top" command indicates that around 30Gb of RAM is available.

In this state, Maple is utterly useless to me. This was a new install of Maple and a fresh install of Ubuntu on a new laptop, surely I am not the only one seeing this?

I have tried setting a 30Gb limit in "kerneloptions" for "stacklimit" but that di not make a difference.

If you have seen any behaviour like this, please respond. Is there some bug in Maple that leads to oncontrolled and unprovoked memory grabbing?

Please Wait...