MaplePrimes Questions

I am a Mathematica user actually. And I can know x^(1/(x + 1/x)) + y^(1/(y + 1/y)) == E is closed by the code:

ContourPlot[x^(1/(x + 1/x)) + y^(1/(y + 1/y)) == E, {x, 0, 7}, {y, 0, 7}]

But Mathematica cannot calculate this integral Integrate[1,Element[{x,y},ImplicitRegion[x^(1/(x+1/x))+y^(1/(y+1/y))>=E,{{x,0,7},{y,0,7}}]]]. It just can give a numerical solution by NIntegrate, This makes me depressed. So I try to calculate it by Maple. After I read some documentation of maple, I don't know how to use a implicit function to expression a region to do integral in MultiInt. So I ask here to help. Anybody can tell me how to write this code in Maple?

Hello, I'm using Maple 2021.2 to approximate the solution to a differential equation using a pseudospectral expansion in the basis of Hermite polynomials. After setting up some equations, I get a non-linear system of equations that I try to solve using the Maple's function solve, but Maple suddenly crashes during the execution of this function.

My code is the following:

HN := (n, y) -> exp(-1/2*y^2)*simplify(HermiteH(n, y))/sqrt(sqrt(Pi)*2^n*n!):

u7 := a0*HN(0, y) + a1*HN(1, y) + a2*HN(2, y) + a3*HN(3, y) + a4*HN(4, y) + a5*HN(5, y) + a6*HN(6, y):

resid := diff(u7, y $ 2) + 4*y*diff(u7, y)*u7 + 2*u7^2:

r := evalf(allvalues(RootOf(HermiteH(7, x), x)));
equations := {evalf(eval(u7, y = 0) - 1)};
for root_r in r do
    if root_r != 0 then
        equations := {op(equations), evalf(eval(resid, y = root_r))};
    end if:
end do:

solutions := solve(equations, {a0, a1, a2, a3, a4, a5, a6}):

Does anyone have any idea about what is happening? Is there any better way of solving a non-linear system of equations?

A user wonders if they can customize Maple output to show, for example x^2 instead of x2 in 2D output. 

We suggest they either set 

interface(prettyprint=0);

globally, or use

lprint(x^2)

for individual outputs. 

Hi,

I have a MapleFlow program that perform some symbolic calculations. To test the program, I assign a numerical value to a variable, say a:=1.6, in the middle of the program. I would like to clear the variable and continuing the program development using symbolic calculations. I've tried unassigning and restart but nome worked.

Any ideas?

This was asked before: https://www.mapleprimes.com/questions/233343-Drawing-Of-Complex-Numbers-On-A-Complex-grid-#comment283684

It really showed me what was going on. But now there is something else, that really does not look the like, i tried. But there is nothing that really looks like an answer for the b. question. "Draw the following collection in the complex plane".

There really is no explanation on how to handle the numbers in the |z| part and (z) part of the argument of question a. Also, adding imaginary numbers to the argument en the |z| part is really odd. Do i multiply those numbers with the x and y components in there?  

a.

plots:-inequal([1 <= 2*sqrt(x^2+y^2), 2*sqrt(x^2+y^2) < 2, (1/4)*Pi <= arctan(2*y, 2*x), arctan(2*y, 2*x) < 3*Pi*(1/4)], x = -3 .. 3, y = -3 .. 3, optionsopen = [linestyle = dash, color = red, thickness = 2])

 

b.

plots:-inequal([1 < (4*I)*sqrt(x^2+y^2), (4*I)*sqrt(x^2+y^2) <= 1, (1/2)*Pi <= arctan((2*I)*(y, x)), arctan((2*I)*(y, x)) <= Pi], x = -3 .. 3, y = -3 .. 3, optionsopen = [linestyle = dash, color = red, thickness = 2])

 

``

This really helps out a lot if someone could explain this to me. 

Thank you!

Greetings,

The Function

Download Mapleprimes_Book_2_Question_3.1.mw

hello 
i have a long proc i am defining in a loop inside the proc for some reason it calculates the value of a1[j+1] and a2[j+1] and assigns it(in the case of the picture j=1 and in j=2 it doesnt sub) but when it is called again in the next iteration  it doesnt sub the value it just calcluated ! 
i would be so thankful for any help ive been stuck on this for a while now 

First of all I would like to wish everyone a happy, prosperous and especially healthy 2022!

I do not understand why my second formula in the attached sheet gives the wrong answers. I have added the correct answers in the vector "Correct". I still find it a bit cumbersome to work elementwise in Maple but that is most likely because still being relatively new to the program. Any help is more than appreciated 

Elementwise.mw 

What/Whare are the maple initialization files.

I have a problem with libname.

According to maple help, I should create/modify ~/.mapleinit.

> cat ~/.mapleinit

libname := "/usr/local/Maple2021/lib","/home/tomdean/maple/toolbox/maplev/lib","/home/tomdean/maple/toolbox/Syrup/lib";

But, when I start maple (in emacs), libname is only the first part, "/usr/local/Maple2021/lib",

hello 
i am trying to define a proc that has a local arrays and lists in it
how do i define it in the local row ? saying a is a local array in the proc, do i just write a ? 

thank you 

I installed the cloud version of Syrup with xmaple, by clicking the cloud icon, etc. It is loaded with xmaple and cmaple. But, not in maple running in emacs.

with(Syrup);
(**) Error, invalid input: with expects its 1st argument, pname, to be of type
{module, package}, but received Syrup
(**) 

Tom Dean

Best wishes for all for the New Year 2022!

Is it possible to search for my questions who answered this on Maple Primes ?

Hello everybody! Happy new year! 

Im back this year. I bought a flatbedscanner to scan some books. Already scanned 3 whole books in 2 days, its a blast!

Ive got a question about some complex numbers that i have to draw on a grid. 

The translated question is: "draw in the complex grid the following collections:"

Here is what ive got. But the book does not give any solutions for me to check on. So its not great at all to have to learn like that. 

Download Mapleprimes_Book_2_Question_3.mw

a.

-2+I = 2

sqrt((x-2)^2+(y+1)^2) = sqrt(2)

((x-2)^2+(y+1)^2)^(1/2) = 2^(1/2)

(1)

smartplot(sqrt((x-2)^2+(y+1)^2) = sqrt(2), sqrt((x-2)^2+(y+1)^2) = 1)

 

b.

-1+I*2

-1+2*I

(2)

(1/2)*sqrt((x-4)^2+(y+2)^2) = 0

(1/2)*((x-4)^2+(y+2)^2)^(1/2) = 0

(3)

smartplot(sqrt((x-1)^2+(y+2)^2) = sqrt(3))

 

c.

Error, `;` unexpected

 

NULL

``

``

``

#d.

sqrt(x^2+y^2) = 1

(x^2+y^2)^(1/2) = 1

(4)

sqrt(x^2+y^2) = 3

(x^2+y^2)^(1/2) = 3

(5)

smartplot(sqrt(x^2+y^2) = 1, sqrt(x^2+y^2) = 3, x = -(1/4)*Pi, x = 3*Pi*(1/4))

 

-(1/4)*Pi

-(1/4)*Pi

(6)

evalf(%)

-.7853981635

(7)

3*Pi*(1/4)

(3/4)*Pi

(8)

evalf(%)

2.356194490

(9)

e.

everything under y=0 and everything to the right of x=0

plot(x = 0 .. 10, y = -10 .. 0)

 

f.

sqrt(x^2+y^2) = 0

(x^2+y^2)^(1/2) = 0

(10)

sqrt(x^2+y^2) = 2

(x^2+y^2)^(1/2) = 2

(11)

smartplot(sqrt(x^2+y^2) = 0, sqrt(x^2+y^2) = 2, x = -(1/4)*Pi, x = (1/3)*Pi)

 

``

``

``

``

``

``

``

The book gave an example, the translations says:"Draw in the complex grid the collection:
Solution

This we can read as: draw all complex numbers for which the distance to i is similar to 2. This collection is a circle in the complex grid with the center (0,1) and a radius of 2. See the figure on the left.

Draw in the complex grid the collection:

Solution

We can wright     This we can read as: Draw all complex numbers for which the distance to -3+2i is simular to 1. This collection is a circle in the complex grid, see the figure on the right. Another method is z=x+iy, we can substitute this into. This substitution delivers a relation between x and y, after which we can draw each z=x+iy that complies with |z+3-2i|=1. The substitution gives us:  frown which leads,   so that  . This is again a formula of a circle in the complex grid with the middlepoint (-3,2) and a radius of 1." 

Some more examples:

I also added a PDF of the chapter, so you can see what a flatbed scanner can do (a canon lide 400) and adobe DC (to combine the scans and perform "OCR" on the text so the computer can read the text so you can copy and paste it and search the text with CTRL+F. A must have if you are serious in doing studies in my opinion, its way way faster to look up things like that than to go to a register or glossary at the back of the book that may not even have the topic listed what you are looking for.). It is very impotant that you get good scans of the PDF program will not read your numbers and letters in the scanned file well. The solutions (after having scanned half a book already, so i had to do that part again) was to lay the book on the right side of the scanner, with half the book on top of the scanner. Press on the back of the book, and lay 2 hands on top to press the page (lightly) against the glass. When you are dont with that page, you invert the book and keep half the book on the right side again. The PDF program (adobe DC) will flip the scans for you with the OCR recognition function. 



I thought id share this with you, while this costed me 2 books to find this out, and costed me a lot of time. Time a valuable, that is why i started the scanning in the first place. It better be good on the first run.  

Looking at the google translate results the "grid" probably is a "plane" just as in a 3d drawing program. 

Any way, i hope i was specific enough. Im having a bit of trouble with this planing of complex numbers. 

Greetings,

The Function. 

Maple_question_3.pdf

Download Mapleprimes_Book_2_Question_3.mw

Hi Guys,

I am not sure where I'm going wrong, but last year (I am sure!) the integral of this equation (eq2) was given by Maple in terms of the Hypergeom function.

eq2:=x^(-2)/((z)-x^(a));
Int(f,x)=int(eq2,x=1..x1);

However, this year, I get no further than the following.  What am I doing wrong here, I'm now using Maple 2021.2.

In previous version of maple, the above commands would report a solution in terms of hypergeometric 2F1 or LerchPhi.  Something like this, -(-LerchPhi(x1^a/z,1,-1/a)+LerchPhi(1/z,1,-1/a)*x1)/z/a/x1

How do I get Maple 2021.2 to provide the solution to the integral?

Thanks very much,

Rhod

I am attempting to use maplev mode for emacs. Ubuntu 20.04.3, Emacs 26.3, maplev-mode from git, release-2.36-59-g142c03. maple 2021.

I copied mload from an older computer and added a line to define maple, after the original maple definition line.

MAPLE=${MAPLE:-maple} # Maple script
MAPLE=/usr/local/Maple2021/bin/maple  <=== added

I compiled and installed maplev-mode. I had to touch doc/version.texi because the file did not exist. But, otherwise, I saw no errors.

I added lines to my emacs init.el as per the README.md.

maplev-mode seems to load when I edit a .mpl file.

However, mint is not defined.  Where should I change to define the location of mint?

/usr/local/Maple2021/bin/mint

Tom Dean

It has been a decade or more since I have seen an option for lifetime enrollment for anything. Does maple calculator even have such an option available? If not, why not?

First 61 62 63 64 65 66 67 Last Page 63 of 2141