DJKeenan

432 Reputation

9 Badges

15 years, 116 days

MaplePrimes Activity


These are replies submitted by DJKeenan

I had a very quick look at the curveexpert.webhop.biz site. It says “XY data can be modeled using a toolbox of linear regression models, nonlinear regression models, interpolation, or splines”. Maple can do all that, and perhaps better.
I had a very quick look at the curveexpert.webhop.biz site. It says “XY data can be modeled using a toolbox of linear regression models, nonlinear regression models, interpolation, or splines”. Maple can do all that, and perhaps better.
The plot command is generally using hardware floats, i.e. roughly evalf[14]. Getting the same answer with higher values of Digits does not mean that the answer is accurate. From the above experiments, the constants need to be specified to more than 10 digits, to ensure accuracy. With only 10-digit constants, the final result might well be in error in the second digit, or worse (even using, say, evalf[100]). My suggestion is to do two things. First, replace all the floating-point constants with exact values, where reasonable—there seem to be many instances. Second, assuming some inexact constants remain, use one of evalr, Tolerances, ScientificErrorAnalysis; if the inexact constants came from experiments, then the third is likely to be most appropriate. The issues that you are encountering are inherent in floating-point arithmetic. Maple, though, does have some nice facilities to address them.
The plot command is generally using hardware floats, i.e. roughly evalf[14]. Getting the same answer with higher values of Digits does not mean that the answer is accurate. From the above experiments, the constants need to be specified to more than 10 digits, to ensure accuracy. With only 10-digit constants, the final result might well be in error in the second digit, or worse (even using, say, evalf[100]). My suggestion is to do two things. First, replace all the floating-point constants with exact values, where reasonable—there seem to be many instances. Second, assuming some inexact constants remain, use one of evalr, Tolerances, ScientificErrorAnalysis; if the inexact constants came from experiments, then the third is likely to be most appropriate. The issues that you are encountering are inherent in floating-point arithmetic. Maple, though, does have some nice facilities to address them.
You are completely wrong. Your comments are almost always helpful and informative, and I am far from alone in being glad to read them! I.e. you do not post too much, okay?
In Maple, you can sometimes compute a result both symbolically and numerically, and check the answer that way. For example, f:= k-> sum(1/(n^4+1), n= -k..k): seq(evalf(f(i)), i= [100, 200, 400]); 2.156954503, 2.156955077, 2.156955149 For comparison, a similar check is not always viable in Mathematica. In Mathematica, “numeric” integration (and perhaps other routines) is sometimes done partially symbolically, and then the floating-point answer in computed. There was an example a few months ago, posted to Google Groups, where Mathematica gave the same incorrect answer to a definite integral using symbolic and numeric methods, and the poster concluded that this was what was happening.
One point is that if Maple were to have a defined order, then it would require maintaining that ordering in the future (for compatibility). Not having an order leaves things free for the future. Also, maintaining an order requires time. If someone does not need an ordering, the time would be wasted. If some does need this, then they can use sort.
I got 0 the first time that I tried it, in a fresh Maple session. And the third time. I did not find a pattern as to when and when not I got 0.
I am also using 11.02/WinXP. Sometimes I get 0, and sometimes I do not.
Just to clarify, do you need to use 128 decimal digits or 128 binary digits? Also, how did you determine the number 128?
A warning to anyone who uses plotsetup: this is not reset by the restart command. The behavior here is in contradiction to ?interface.
Scott, thanks! You are right, I'd missed that.
In principle, p12 and p0 could be combined using the ImageTools package. It turns out though, that this approach leads to several problems—including due to bugs. I think that manually combining the plots (via Gimp/Photoshop/whatever) is preferable. I have posted a Product Suggestion for addressing one of the problems.
In principle, p12 and p0 could be combined using the ImageTools package. It turns out though, that this approach leads to several problems—including due to bugs. I think that manually combining the plots (via Gimp/Photoshop/whatever) is preferable. I have posted a Product Suggestion for addressing one of the problems.
In similar situations, what I have done is export the plots (here p12 and p0) and then combine them using an image manipulation program (I use The Gimp; Photoshop, etc., would also work). I often export&manipulate anyway, e.g. to position the caption or legend within the plot, to include a small version of one plot within another, etc.
1 2 3 4 5 6 7 Last Page 2 of 13