Question: The exact same input (i would think), but totally different outcomes.

Hello everybody,

Something totaly unexpected came by, and i was wondering: how could this be? Im putting what would be the same input in, and yet, its not giving me the results i was expecting for the input i had itterated. 

While one solution would be really cumbersome and slow, it tried to do it faster. It worked before, but now i hit a wall. No clue why, but it seems to be so. 

Here is the example:



stelsel := {-x1+7*x2+3*x-x5 = -7, 2*x1+3*x2+4*x3-x5 = 10, 5*x1-3*x2+2*x3-x4-2*x5 = 8}

{-x1+7*x2+3*x-x5 = -7, 2*x1+3*x2+4*x3-x5 = 10, 5*x1-3*x2+2*x3-x4-2*x5 = 8}


solve(stelsel*{x1, x2, x3, x4, x5})

Error, (in testeq) invalid arguments



stelsel := {-x[1]+7*x[2]+x[3]-x[5] = -7, 2*x[1]+3*x[2]+4*x[3]-x[5] = 10, 5*x[1]-3*x[2]+2*x[3]-x[4]-2*x[5] = 8}

{-x[1]+7*x[2]+x[3]-x[5] = -7, 2*x[1]+3*x[2]+4*x[3]-x[5] = 10, 5*x[1]-3*x[2]+2*x[3]-x[4]-2*x[5] = 8}


solve(stelsel, {x[1], x[2], x[3], x[4], x[5]})

{x[1] = 17/3+(4/3)*x[2]-x[3], x[2] = x[2], x[3] = x[3], x[4] = 53/3-(23/3)*x[2]-7*x[3], x[5] = 4/3+(17/3)*x[2]+2*x[3]}



Thank you!


The Function


Please Wait...