Question: Why add on package not working?


I'm recently searching for  a way to do QFT on Maple 12(Windows) or 13(Linux).I found a relevant Q and ans/comments  almost 3 years old(nov 04,2007)-thanks to doris sanchez,John Fredsted & other contributors.There, Mr. Fredsted gave 3 links to download  3 add-on Maple packages.I found those helpful & downloaded those 3 packages(thanks to their authors & Maplesoft).

Now,I'm getting to the point:

Prob-1)Releated to the "FeynmanGraphs" package.I did what the instruction manual told me to do(copying 3 FG files i.e. with 3 different extensions,to the appropriate directory).Then I opend a standard worksheet,loaded the package.Now the manual shows that - my worksheet  should show extra 3 lines before showing the contents of the package-but it shows only the loaded contents,like the result of loading any regular package.Then I copy-pasted the 1st command to generate a diagram and it failed.Instead I can see something like a lot of other codes filling up my screen,but no diagram.I also tried after restarting my computer without any luck.

So what went wrong?Is it probably because of that the package was written in/for Maple 9,or something else?

The package is here:

NB:The 2nd package for evaluating trace of gamma matrices works fine,though it was written in/for Maple 7.

Prob-2)Can I  use those same exact  FG files to use it in Maple installed on Linux,provided that I copy them to the right Maple-directory in Linux?I've already tried the Feynman package,but it won't work.

NB:I use Ubuntu 10.04 LTS 32 bit.

By the way why are those packages are not built-in the next Maple versions(as a whole different package or as a sub-package of "Physics")?If there are copy-right & other classified issues,then it is probably none of my business.Otherwise I'm curious.

Thanks a lot.

Please Wait...