MaplePrimes Commons General Technical Discussions

The primary forum for technical discussions.

Create new document (or worksheet) with content below and execute it step by step: > restart; > Eval(diff(v(z),z),z=H)==eval(diff(v(z),z),z=H); Eval(diff(v(z),z),z=H)=diff(v(H),H) > v:=z->z*H; v:=z->z*H > value((1)); H=2H As you can see, result of eval, which in this case is equivalent to subs(z=H,diff(v(z),z)), at the right side of first equation leads to wrong final result :( This...

Where can I find Maple worksheets for viewing/download with regards to the following fields of application?:- 1) soft independent modelling of class analogy (SIMCA), regularized discriminant analysis (RDA) and discriminant analysis with shrunken covariances (DASCO) for multivariate classification, 2) principal component scores-based multivariate statistical process control (MSPC), 3) modelling of multiplicative terms in analysis of variance (ANOVA), 4) generalized rank annihilation method (GRAM) and iterative target transformation factor analysis (ITTFA) for curve resolution and optional second-order bilinear calibration, and
This is regarding an earlier thread about Maple's misleading output of exponentials. Here is a link with a screenshot of what I am talking about: Maple output It seems like no one else is experiencing this problem. Maybe it has something to do with the version of java or OS X I am running, which is OS 10.4.3, Java 1.5, and Maple 10.01.
Try typing the following input in Maple 10.01 in 2D mode (on Mac OS X) input: (e) output: e when in fact what maple means is this: e The intended answer appears when you call simplify on the first result, but this seems dangerously easy to confuse, especially for inexperienced maple users, or if this was returned as the answer to a problem (like taking residues, where I discovered it) it could be easily overlooked -Matt
I'm running Maple 10.01 under Mac OS X ( 10.4.2), and when set my Java Preferences so that the J2SE 5.0 being used in the runtime environment, Maple will not open and gives the following error: Uncaught exception in main method: java.lang.NoClassDefFoundError: org/apache/crimson/parser/XMLReaderImpl Maple works fine for me when the runtime environment is set to use J2SE 1.4.2. -Matt
I teach some mathematics subjects to students studying a computer science course. Most of these students dislike maths (I'm Australian, hence "maths" instead of "math"), and are doing it only because it's a core subject in their first year. I should also point out that many of my students have a very weak maths background, and so find the maths that I teach (which over a year covers logic and boolean algebra, some combinatorics, and linear algebra and calculus) very difficult and demanding, and often simply dull. I've been using Maple for about four or five years now; each week the students work through a sheet of Maple exercises (which are all marked) designed to enhance their learning. But here's the thing - the students actually don't like Maple! They would much rather spend that hour having a standard tutorial, working through pencil-and-paper problems, than in a computer lab with Maple. So I need to change my approach; to somehow make Maple more central, more enjoyable, and more "enhancing" than I've been doing up to now.
I came across this cool site created by Justin Mullins of the New Scientist. The site contains artwork created by mathematical expressions. The creator describes it as Mathematical Photography, "In the same way that an ordinary photograph is a snapshot of an area of outstanding natural beauty, a mathematical photograph is a snapshot of mathematical beauty."
There are many examples to be seen on the site. And they will be shown at the UK gallery exhibition in London next February. Link (via Boing Boing)
Today I try to solve a simple ODE: dot{x(t)}=sin(x(t)). Maple gives me the below answer: x(t) = arctan(2*exp(t)*_C1/(1+exp(2*t)*_C1^2), (-exp(2*t)*_C1^2+1)/(1+exp(2*t)*_C1^2)) How comes the arctan function takes two arguments? I solved the equation by myself, and a simple manipulation result in the follwoing result: x(t)=2arctan(C*exp(t)) How can maple end by a 2-argument arctan function?? Help...
Hi, All,

Please see below:

> restart:
> with(DEtools):
> deq := diff(y(x),x,x) = A*exp(y(x)/vt);
> deq2 := diff(y(x),x,x) = A2*exp(y(x));

> #y := unapply(rhs(dsolve(deq,y(x))),x);
> y2 := unapply(rhs(dsolve(deq2,y(x))),x);

If I let two dsolve go, it gives error message for the second. However, commenting one and letting one go will always works perfectly. What's the problem, any bugs inside Maple. I tried in Classic Maple and Maple 10. same problem happend.


I have a classic-worksheet version of Maple 9.5 that runs as an X11 application on my Macintosh. Is there a classic-worksheet version of Maple 10 that does the same? If so, where can I get it?
dear all, I want to write a greek letter (tau) in the legend of a figure. how can I do that? thanks!
dear all, how can i move legends from bottom (default) of a figure to the side? thanks!
Hi, I have a problem printing a worksheet under OS X 10.3 (I've tried it with various minor versions of 10.3 and they all behave the same). The worksheet contains a few plots, and when I try to print, the printout stops at the first plot. The plot is not printed, nor is any of the subsequent material. The printer does generate blank pages, though (and it generates the "correct" number of blank pages). So, text up to the first graphic prints, but nothing after that point shows up. If I use Maple's "File / Print Preview" command, it displays a preview with all the worksheet displayed the way it should be.
We have Maple 10 ryunning on a large Univerity network of Windows XP machines. Unfortunately Maple can't save changes in options such as to use "Maple input" rather than "2-D input". The reason for this (according to our tech people) is that Maple tries to write to user profiles directly rather than using the API (as it should), and so it is missing our redirection of the profiles. 1) Are other people having this problem? 2) Is the above correct? If so, why are Maple using these hacks and not implimenting things "properly". 3) Is there a fix? I'd be grateful for any info.
Hello All: I am working on generating some correlated sequences using Matrix Exponential techniques. there seems to be some problem with the way maple manages memory (or am i doing something wrong?). specifically, in the code below, i am calling a few functions inside a for loop but none recursively. so as the for loop progresses my stack (memory; seen as PF Usage in win XP) size should not really blow up. right? but in Maple 9.0 and 10.0 this below program would give a "Execution stopped: stack limit reached." exception after about 30000 executions(I am running on a WinXP machine , about 2.8GHz, with 512 MB RAM, also checked on a machine with 1 GB Ram; and another 1GB in page file size). But the same program seems to work alright on the same machines with Maple8 running (i uninstalled maple-9 and installed maple-8 in one case). I could go up to 300,000 iterations without any problem. And the memory would go from about 250MB (PF Usage) to about 800MB. So even in Maple 8 there is some stuff that is being dumped on the stack; i tried to run Garbage collector (gc()) function once every 500 iterations; it did not make any difference either. Can anyone please look into it?
First 74 75 76 77 78 Page 76 of 78