MaplePrimes Commons General Technical Discussions

The primary forum for technical discussions.
The control(menus, buttons, ..etc) font of maple is ugly on linux jdk 1.4.x. So I tried to run maple on jdk 5.0 with swing.aatext=true option. I have installed crimson xml parser at {maple installation dir}/java directory. And I tried to start maple. But maple didn't start with next exception. Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: No such child: 0 at java.awt.Container.getComponent( at com.maplesoft.mathdoc.components.dockingtools.WmiBorderSplitPane$DockContainer.(Unknown Source) at com.maplesoft.mathdoc.components.dockingtools.WmiBorderSplitPane.addAtLocation(Unknown Source)
Hi everybody, I'm new to this site, I did a search and looked through the topics but did not find anything regarding a problem I'm having with Maple 10.02 : EDIT BELOW: Problem now solved! While running a "for" loop containing some very very large equations the evaluation would stop and a window would say "Connection to kernel was lost." I finally determined that the mserver.exe process had quit, causing this message. I have configured my firewall to permit all communications that maple and mserver want to do. The worksheet is a translation from an older version (Maple V R4 ...), the worksheet and the loop ran fine in Maple VR4, but I get the above mentioned problem when running the worksheet in Maple 10. I've translated the code into the updated language, but I still get the error. The loop in question is:
Does anyone know why an "inline" Maple 10 plot exported as an eps figure (by right-clicking on the figure) is not compatible with the psfrag.sty package for LaTex? Oddly, writing the plot "directly" to an eps with the following commands does produce an eps figure that is compatible with psfrag.sty, i.e., the axes labels can be replaced with LaTex math symbols: > plotsetup(ps, plotoutput = `fig1.eps`, plotoptions=`portrait,noborder,height=5in,width=5in`); > plot(sin(x),x=0..1,labels=[x,y]); Looking in the eps files themselves, the "inline" version (%!PS-Adobe-3.0 EPSF-3.0, Creator: FreeHEP Graphics2D Driver) writes the x axis label with
Hello. I badly know English and I ask to excuse. I use Maple10. I can not execute integration of complex{difficult} function. Ic:=int(A/(1+(r-r0)^2/A^2)*(1/sqrt(1-w0^2/r^2)),r=w0..infinity); Thanks for attention.
This is a copy of a post I made at the comp.soft-sys.math.maple newsgroup: I just installed the x86_64 version of maple 10 on my ubuntu linux desktop, but I can't figure out why xmaple won't run. Installing in the first place was a bit of a pain: I had to use the '-i console' parameter, and once it was installed, I had to chmod +x the executables and replace the maple10/jre.X86_64_LINUX/bin and maple10/jre.X86_64_LINUX/lib directories with links to my current java version's (1.5.0_06) directories. I had no problem activating, and plain old console 'maple' runs fine, but nothing happens when I try to run 'xmaple' or 'maple -x'. It just pauses for a second or two when I press return, and then ends. Now I know this distribution of linux isn't supported, but I don't see why it can't be made to work. Any suggestions?
I have a Primitive Polynomial over GF(2) of degree 8. p(x) = x^8 + x^6 + x^3 + x^2 + 1 I need to evaluate a root 'w' such that p(w) = 0 How do I do it?
Following are coupled PDEs governing the system. c1 ∂x1S11 + c2 ∂x1S22 + c3 ∂x2S12 = 0 --- (1) c2 ∂x2S11 + c1 ∂x2S22 + c3 ∂x1S12 = 0 --- (2) ∂x2 x2S11 + ∂x1 x1S22 - 2 ∂x1 x2S12 = 0 --- (3) where c1, c2, and c3 are constants. S11, S22, and S33 are 2-dimensional field. And boundary conditions are appropriately defined. In fact, Eq.(1) and (2) are the equilibrium equations and Eq.(3) is the compatibility equation of 2D static strain-stress problem. I don't have any experiences on constructing finite difference equations of coupled
The exponential function behaves a little strange sometimes. This happens in Maple 9. It thinks that 0^0 is 1. I'm actually in agreement with that, although I've seen many a mathemtician argue that it should really be undefined. De gustibus non est disputandum. But it's strange that it think that 0^(1+I) is 0 but 0^I gives a divide-by-zero error, without mentioning that the division by zero occurs somewhere in a call to ln(x). It's something stupid, but a potential source of mystifying bugs in user code. Some CASes, such as Maxima, are smart enough to have a specific error for 0^z for complex z. Still others return NaN.
One of the items missing in the "combinat" package is that there exists no procedure to produce one combination at a time from C(n,k). The only possibility is to generate a list of all possible subsets of C(n,k) in a single go.

I am looking for a function/library to generate sequences of combination C(n,k), which would generate the next (successor) sequence, given a sequence. ie next:=some_proc(n,k,prev) should return the next sequence after the sequence "prev". Is this available anywhere ?
I have problems with assume integer. Here is a worksheet yielding a wrong solution. Is there something other than assume(integer)? > restart: > assume(k,integer); > is(k,integer); > is(l,integer); > t1:=int(sin(x)*sin(k*x),x=0..Pi); > t2:=int(sin(x)*sin(l*x),x=0..Pi); > limit(t2,l=1);
I want to create a list and apply sin(x) to it. Is there something that can help me do the following.... Apply sin(x) to a list as in... sin[2, Pi, Pi/3] Please let me know.
In a new PC with a nVidia graphics card under Win XP Pro I have found that
plots, using the Classic interface (Maple 8 included), show a cyan background
by default, instead of white. Default means PlotBGColor=default or 255 255 255
in maple10.ini.

Clicking with the mouse on the plot turns the background white, both for
inline and window output, but e.g. using the window output, and pressing the right
arrow turns the background cyan again.

On the other hand, plot background in Standard interface shows white.

I have not realized of any other application showing this problem.
Any idea on its origin?
New here and not sure if this is where the bugs go. Assuming it is... Using Maple10, build 190196 and Linux; entering the following >map(Im,Matrix(1,1,shape=identity)): gives back 1x1 identity matrix (that is, [1]). Fixed by >map(Im,1.*Matrix(1,1,shape=identity)): which returns [0.], as it should. Cheers
I am trying to solve the following system in (L,N) with Maple eq1 := 449.7102399/(L-115.6885356*N^.98*L^1.019)^.1* (1-117.8866178*N^.98*L^.19e-1)+15-5894.330889*N^.98* L^.19e-1-411.72/(48-L)^.6e-1-985.8471121* exp(-3.638-.174*N)/L^.326 = 0 eq2 := -50985.79270/(L-115.6885356*N^.98*L^1.019)^.1/N^.2e-1* L^1.019-5668.738244/N^.2e-1*L^1.019+254.5065245*exp(-3.638-.174*N)* l2^.674 = 0 I have tryed with solve(),PolynomialSystem() but without any result. I have also tryed with implicitplot() to have an approximate solution. I would be v grateful for any help. Cheers, g

when using the graphical version of Maple 10 on Mac OS X, I frequently get problems when entering content or changing it. I start by entering content, and all works fine. Then I execute the worksheet, save the worksheet, and all is still fine.

Then I restart Maple and open the worksheet again. Now I want to change some content. But when I press shift-enter to insert a line, it does nothing the first time, and only works from the second time on... when browsing with the arrow keys, it seems like there is some sort of hidden character inserted, as I need to press the left key twice to go over it.
First 72 73 74 75 76 77 78 Page 74 of 78