MaplePrimes Commons General Technical Discussions

The primary forum for technical discussions.
Do you think that it's possible for Maple to ever be free software? I
suppose I should emphasise that this is "free as in freedom",
regardless of whether Maplesoft decides to keep charging money for its
use or not. Me, I don't see it happening in the near future, but I
harbour hope that it could happen for the following reasons:

1) Other success stories of free software, such as the Firefox
browser.

2) Maple, unlike the other leading brand, was built in a purely
academic environment by a community of mathematicians and
scientists who understand the need for free and open collaboration
server: efnet channel: #maple this channel is unaffiliated with maplesoft. It is new at the time of this posting so be patient if there is not much activity at first. I know a bit about maple and may be available to help people with it. If you have never used IRC before it is not difficult. You may want to read about it a little by googleing IRC. if you just want to connect I have posted instructions about connecting to this and other math related channels on IRC at this link: http://web.mac.com/luther_driggers/iWeb/SFUMSU/NEWS/50430B9A-5AAD-48DC-B53B-A5565C352F70.html
Hi. Hope someone can help me. I have attached a file, created in Maple 10.02 (the Java version). The file seems to be corrupted, since every time i try to open it, I get the following error message: "File open!" "There were problems during the load process. Your worksheet may be incomplete." No input or output is displayed in maple, eventhough the fileize is 552KB. I tried then to open the file with classic worksheet maple 10 and the console, and with both the Java and classic worksheet version of Maple 9.5, still to no avail. If i open the worksheet in notepad or similar, I can tell that the code is still existing.
I did some complecated calculation for cloth simulation. When I get the value from C++ Maple API, it is 1.#QNAN. But when I get the result from Maple, the value is following: (-0.6205772259e-2-0.2125843006e-1*I)*(Pi-1.928059303+5.979053727*I)+0.2356552645e-2*(Pi-1.928059303+5.979053727*I)^2 What is the meaning of 'I' in the result? I am dying to solve the calculation without 1.#QNAN.
Hi all, I have a thirdgrade equation and I wish to find the values when f(x)=0 So I have typed in the equation as well as f(x)=0 and wish for maple to give me the intersect points for L:=2*x^3+6*x^2-2*x-6:M:=0:plot([L,M], x=-4..2, y=-7..7); With the help of the help section I then add P:=Intersect(L,M); But I just get the equation read back to me. The answer I am looking to be displayed is -3,-1,1 How do I get maple to do this? Thanks in advance :-)
Ignore this posting. The question was answered already in comp.soft-sys.math.maple. The problem was the use of point as the first argument of rotation. Change the two lines

> rotation(point,P,evalf(theta),el);
> coordinates(%);

to

> rotation(PP,P,evalf(theta),el);
> coordinates(PP);

and the procedure will work.

--Edwin
-------------------------------------------------------------------

When I execute the procedure Rot below it works fine the first time but a second execution gives an error message? Is there a way to fix this problem? I have to do a restart to make it work again.
MaplePrimes own Jim Herod has a wonderful set of lecture notes—accompanied by a collection of Maple worksheets—which introduce linear operators on infinite-dimensional Hilbert spaces to beginning graduate students in science and engineering. Entitled Linear Algebra, Infinite Dimensions, and Maple, these notes were developed from a one quarter course which Prof. Herod taught many times at the Georgia Institute of Technology. The notes are very concise and have been refined and improved many times over the years in response to student feedback.
I do not understand why these parts give different results. Part 1. > restart; > u:=(t,x)->sum(a[n](t)*sin(n*Pi*x),n=1..2); > diff(u(t,x),t); > D[1](u)(t,x); THE OUTPUT OF THE LAST LINE IS WHAT A HUMAN WOULD GET. Part 2. > restart; > N:=2; > u:=(t,x)->sum(a[n](t)*sin(n*Pi*x),n=1..N); > diff(u(t,x),t); > D[1](u)(t,x); THE OUTPUT OF THE LAST LINE IS 0, curiously. Part 3. > restart; > N:=2; > u:=(t,x)->add(a[n](t)*sin(n*Pi*x),n=1..N); > diff(u(t,x),t); > D[1](u)(t,x); THE OUTPUT OF THE LAST LINE ECHOES THE REQUEST. > I prefer the output of Part 1, of course. I can tolerate the output of Part 3. But, the output of Part 2 seems wrong. What am I not understanding?
Now that you have a shiny new degree in mathematics or computer science, how do you get a job in your field? There are many online resources which can help you succeed in your quest!
Dave Rusin, a Professor of Mathematics at Northern Illinois University, maintains The Mathematical Atlas: A Gateway to Modern Mathematics. This comprehensive atlas is organized in a large hierarchy based on the Mathematics Subject Classification (MSC) of the American Mathematical Society (AMS).
hi everybody, I tried to install Maple 10 on my AMD64 Athlon 3200+ (running with Fedora Core 4 64bit Kernel 2.6.15-1.1831_FC4). Well, the installer worked just fine, except the activation - unable to determine Host ID. So I activated Maple offline. After the installing, the first problem I had to handle with was the "read only" mode off all installed executables - I think I changed the mod off all executables in the maple 10 folder... Now I was able to run the command line mode of maple. But I am still not able to run Maple in X11 mode - when entering ./maple -x or ./xmaple nothing happens, no error - nothing. Since Maple is working in the commandline mode, I assume that it has to do with java somehow. Well, I am not really an experienced Linux user, but I installed jdk-1.5.0-06, hoping it will solve the problem, without success :-( . I now that Fedora Core 4 is not supported, but I don't see why Maple should not work properly here if it does with redhat. Well, it would be really great if somebody has a solution to this problem.
Hi everyone! I want to thank Tom Lee for inviting me to join the MaplePrimes community. I feel very enthusiastic about the creative potential of this wonderful collaborative resource and want to take a moment to introduce myself. My first blog post includes a brief biography and states some of my Maple plans and research goals.
Hi i am doin a project on autotuning pid temperature controller,i need 8051 assembly language code for it...so plz any info abt the code send it to my mail.
Hello,

I read some other entries here and there of users having problems with the Maple 10 editor. Just wanted to know if we are isolated cases under Linux and Mac or if this is bigger issue.
I am working under Linux FC4, and for me it requires a lot of patience with this editor. He jumps here and there, the cursor disappears in the wide space of my worksheet, copy and paste into a string is not possible at all...
I knew previous versions (Maple 7), their editor had their own life too, but this is the top. And in fact, I hoped that they finally come up with a less peculiar editor. Instead I see a lot of cosmetics. Or am I wrong ?
First 70 71 72 73 74 75 76 Page 72 of 78