MaplePrimes Suggestions

Have a problem with MaplePrimes? Want to suggest a possible improvement to the site? Please post it here.

As some of you have previously mentioned, we have seen an increase in the amount of spam on MaplePrimes over the past few months. We recently took steps to improve it in a recent update that has so far proven helpful, and have also increased our behind-the-scenes efforts to proactively remove and block spam accounts.

Today we made a couple of additional minor changes to member profiles that should help further. Specifically, members can no longer enter HTML tags in the biography, 'technical interests/fields', and 'other interests' sections within their profiles. Spammers were co-opting these areas to create links back to their sites, and it is our hope that MaplePrimes will become much less attractive to them now that the capability has been removed.

In addition, we de-activated a large number of accounts (with 0 reputation) that were using these fields for spam. Prior to taking this action, we reviewed the records we were deactivating, and did not see any evidence of legitimate members. However, there is a small chance that we blocked a legitimate account in the process of doing this. If this has occurred to you, please accept my apologies and send an e-mail to custservice@maplesoft.com and we will reactivate it quickly.

 

I hope that in the future if mapleprimes ever does another overhaul that it does NOT do what has recently been done at the mathematica forum I just came across. http://community.wolfram.com/groups/-/m/t/744097?p_p_auth=AfGyGp7X

Mapleprimes has endured a forum change from primes1 to primes2(current forum) and all posts/questions have for the most part remained intact, and have been repaired or fixed by the developers if pointed out .. thumbs up for Maplesoft and Mapleprimes developers for retaining all forum data.  Most posts that didn't have a home were simply relocated, but are still accessible.

In the case for mathematica, a whole student forum was removed and is being scrutinized, and decided by mathematica developers whether or not the post should be put back into the forum (currently none of the posts have been restored).  I would think that would be most dissappointing from any user standpoint. 

Off to the right of mapleprimes we have Recent Questions/Maplesoft Blog Posts/Recent Posts and Active Conversations.

I propose to have the category Workarounds added. 

 

There are two instances I can think of that would be beneficial for Maple users that would belong here.  The most recent one http://www.mapleprimes.com/posts/201844-Possible-Bug-In-Maple- and one regarding issues adding the dissipative term to the heat equations http://www.mapleprimes.com/questions/97391-Whats-Wrong-With-Maple-Solution

Users of older versions of Maple or even current Maple versions not yet updated would find this quite useful. 

 

There are some great comments and replies by users that are worth upvoting.   Also choosing as best answer to some posts that were converted from questions would also be helpful here at mapleprimes.

Mapleprimes should have an option to sort Mapleprimes by the date of the original poster.

Why hasn't mapleprimes yet been able to solve the spam problem.  There was never this long a problem with Mapleprimes 1, every morning I find spam for the last few weeks. 

Also the timing still has yet to be fixed.  After 1 hour the times for when a post was made goes back to 0 minutes ago.

 

 

Earlier this morning, we published an update to MaplePrimes that includes two new features as well as some significant efficiency improvements. Highlights of this update include:

Best Answer

Of all the feature requests that we receive, this has been the most popular, and we're excited to see how it is used! Simply, this new capability allows a member to select the 'best answer' from a list of many. This best answer, selected by clicking on a new trophy icon, will always always appear at the top of the list of answers.

Having your answer selected as 'best' will reward you with 7 reputation points, as well as make you eligible to receive one of two new badges to show off your question-answering prowess!

Tag Management

Improving how tags are managed within MaplePrimes has been another long time request from members, and we have made some significant improvements. The first thing that many will notice is that the interface for adding tags to a post or question is now easier to use and (hopefully) faster.

More importantly, however, are the new management features. For starters, only members with a reputation of at least 100 can add brand new tags. If your reputation is less than 100, you can only select from the extensive list of pre-existing keywords. In addition, members with a reputation of at least 50 can now manage tags for existing content by clicking on the new 'Manage Tags' button. It is our hope that this feature will help increase the value of tagging within MaplePrimes by optimizing the commonly-used keywords, and we encourage everyone to take advantage of this new capability!

Efficiency and Stability Improvements

You should notice significant speed increases across all pages within MaplePrimes. On average, page load times have sped up by a factor of 2x, and many times higher in some cases. In addition, interface changes and optimizations have dramatically reduced the file size of many pages, which will make them more responsive in general.

 

As always, thank you for making MaplePrimes the amazing community that it is! We are hopeful that you will enjoy these improvements, and we look forward to your comments and suggestions.

Looks like mapleprimes was just updated.  I'm finding links broken and pictures missing.

The search operation on both questions and posts doesn't work. I get the same set of results for both, and the same results regardless of the search term.

When I login and then create a question or post and click submit (or preview), I get a new request to login, and, after I do that login, the originally entered message body has been erased.

Dear Bryon and Will:

Please fix MaplePrimes so that the Replies to Answers to Questions appear in chronological order under their respective Answers. Currently they appear in a somewhat random and changing order when their are several Replies. This has been a problem since the last "upgrade" to MaplePrimes.

Another persistent problem since that upgrade is that about half of the time that someone tries to attach a file, the file does not actually attach, even though the editor gives every indication that it has attached, and a hyperlink even appears in the post.

People are starting to leave MaplePrimes because of these problems.

Thank you for your attention to these matters,
Carl Love

Dear friends. 

This is to alert you to a minor problem with your website. I use a variety of operating systems and browsers to access your site. With Firefox 22 and Firefox 26 and OpenSuse 12.2 when I click on a question with a lot of commentary like "Perl vs. Maple (MPF)" from a couple of days ago or "collect x/2-y/2 1/2" the question appears to load for a while but then an empty page appears, containing only the string "2014" and nothing else. Maybe you want to look into this.

Best regards,

Marko Riedel

 

There are still several bugs resulting from the MaplePrimes update last week which you may not be aware of.

  1. The list "All Recent Posts & Questions" is not in the correct order. It is ordered by the time of creation of the Post or Question. It should be ordered by the time of the most recent update to the thread. In other words, the top seven entries in "All Recent Post & Questions" should be the seven entries of "Active Conversations".
  2. Email notifications do not always contain a hyperlink to the relevant post. (I could send you some examples if you need.)
  3. In the list of Answers in a user's profile, the votes for the Answers are not shown for those Answers created after the update.
  4. There are no longer automatically generated titles for Replies for which the author fails to enter a title. This taken alone may be a good idea, but it contributes to bug (2) above. Also, it makes it impossible to send a "Contact Author" email relating to the Reply---when you click send on the email, it will be rejected, even if you tried to add a title.

Earlier this week, we updated MaplePrimes with some fairly extensive changes that improved site performance. While MaplePrimes behaved as expected for most, a few people experienced some problems logging in, and a few other issues were also reported. If you are a MaplePrimes member inconvenienced by these issues, I apologize and thank you for your patience, and also for reporting the problems. I've had some conversations with a few different members, and your help in describing and diagnosing the problems is very much appreciated.

We have been working hard to resolve these problems, and I'm happy to report that most have now been taken care of.

  • The log-in function now works as expected across all browsers. If you are still having problems, you can visit http://www.mapleprimes.com/logout.aspx to force a log-out and reset your browser cookies for MaplePrimes, which will also correct the problem going forward.

  • We have corrected the problem where links to uploaded files were resulting in 404 errors.

  • We have also corrected an issue where the ordering of posts in a user's profile page was done incorrectly.


There are a handful of smaller problems that we continue to work through, and if you notice any other issues, please continue to let us know, either by posting here on MaplePrimes, or by contacting me directly.

Bryon

The board is going to work now with FF for me after latest updates.

NB: I got some mails advicing to delete (old) cookies for Mapleprimes, but
as my browser is alsways completely cleared on close (or on demand) that can
not have been the reason.

It works at least, if I give up all security settings. Which I do not want,
so I sketch a way to use them.

Be aware that not all in a page comes from Mapleprimes. Some is from another
server maplesoft.com and thus considered as 3rd party. Same for some scripts
and CSS etc, which stem from Google, jquery (or else)

If using NoScript or some blockers or similar essentially one has to allow
ajax.googleapis.com, which was needed in the previous version as well (see
below). Dito code.jquery.com is needed (both are 3rd party to Mapleprimes).

It still may hang up at loading ajax-loader.gif, which is located on the
server mapleprimes.com - I do not know why. After allowing a request policy
from mapleprimes.com to ajax.googleapis.com it loads.

That allows to still block all the social media stuff (especially FB connect
is disabled)

And currently I do not see calls to 2o7, just Omniture is trying to work.

---

For the call to Google: it seems to be needed only for their jquery library,
ajax.googleapis.com/ajax/libs/jquery/ and .../jquery/.

But the site calls the open source code.jquery.com/ui anyway. So why using
Google as well? Why not change and stay on code.jquery.com?

Calling to Google transmits my IP and browser header, it is like a fingerprint
and allows GG to identify me later on as Maple user. I dislike that very much.

Edited: edit works as well

After disabling all security addons the Ajax gif loads, then it shows an error and after that it jumps to a page displaying "2013", but that page actually does not have any content (use ctrl + u to see it).

And the I see, that the browser tries to load from maplesoft.112.2o7.net and hangs up in that transfer (have not checked the ports).

In reality I would forbid to load from 2o7, as I receject almost all trackers.

But looking at Adobe http://www.adobe.com/de/privacy/analytics.html or others http://www.makeuseof.com/tag/that-mysterious-2o7-net-tracking-cookie-all-you-need-to-know/ those are 3rd party cookies (Omniture ---> Adobe)

Every reasonable person aware of security and xss forbids dubious sources from other websites (and I am not happy that this sites call Ajax at Google)

And if that is the reason for the bad behaviour of the new sites it would be a good joke, really.

For me it only works with IE and all its security issues (and I have to use "preview" before posting is possible)

1 2 3 4 5 6 7 Last Page 3 of 27