MaplePrimes Questions

I have been using fsolve to derive constants for a polynomial. These are presented clearly in blue, but I am unable to reference these numbers for further calculations other than by typing them in manually. e.g. output is:

{d = 520.9032305, c = .41478630e-1, b = -.84548378e-5, a = .125070852e-8}

 


fsolve({y[1]=a*x[1]^3+b*x[1]^2+c*x[1]+d,y[2]=a*x[2]^3+b*x[2]^2+c*x[2]+d,
> y[3]=a*x[3]^3+b*x[3]^2+c*x[3]+d,y[4]=a*x[4]^3+b*x[4]^2+c*x[4]+d},{a,b,c,d});

Hi

I use dsolve( sys ode, ics)  and  dsolve( sys, ics, numeric) but both does not gives any solution of the system proposed. 
May be I must fix some parameter or something else.

problemdisplaysolution.mw

 

many thinks

Help create file Excel in ExcelTools, but error row 564?

thu_file.mw

Please help me? 

hi

i have a vector [V] and want to calculate f:=V^2;  and plot(V,f);how to do that?

i tried this but you can see in fig uploaded that an error occured.

I want to solve the transient heat diffusion equation in a semi-infinite solid, both analyticall and numerically:

BVP1 := { diff( theta(eta), eta, eta) +2 * eta * diff(theta(eta), eta), theta(infinity) = 0, theta(0) = 1 };
Analytically:  
sol1 := dsolve(BVP1);
                   theta(eta) = 1 - erf(eta)
which is the correct exact self-similar solution.
Numerically:
dsolve(BVP1, numeric) ;
and I got this error message:
Error, (in dsolve/numeric/bvp/convertsys) too few boundary conditions: expected 3, got 2
Why does Maple need three conditions and what is this extra condition? 
Thanks for your help.

restart:with(geometry):with(plots): 
> S:=segment:L:=line:Per:=PerpendicularLine: 
> R:=5:xA:=0:yA:=0:point(A,xA,yA):xI:=R/3:yI:=0:point(I1,xI,yI): 
> circle(C,[A,R]): 

> quadri:=proc(t) 
> local xM,yM,xN,yN,xE,yE,dr1: 
> xM:=evalf(R*cos(t)):yM:=evalf(R*sin(t)):point(M,xM,yM):L(lMI,[M,I1]): 
> intersection('h',C,lMI,[M,N]):L(lAM,[A,M]):L(lAN,[A,N]): 
> Per(lME,M,lAM):Per(lNE,N,lAN):intersection(E,lME,lNE): 
> S(sAM,[A,M]):S(sAN,[A,N]):S(sME,[M,E]):S(sNE,[N,E]): 
> dr1:=draw({lMI(color=blue),sAM(color=black),sAN(color=black), 
> sME,sNE}): 
> display({dr1}): 
> end: 
  
> dr:=draw({C},view=[-6..17,-10..6]): 
> display([dr,quadri(0.7),quadri(1),quadri(1.2)],view=[-6..17,-10..6]); Thanks you.

Hii,

I am using a command -NLPSolve(Ecost1, Q = 10 .. 20, initialpoint = {Q = 10}, assume = nonnegative, maximize = false). I am looking for solution that find the Q value at the minimum value of Ecost1. But Ecost1 should not go below 0. 

and also I am getting an error -Warning, initialpoint option ignored by solver.

Kindly tell how to deal with these issues.

 

Thanks

Hi, How can I  to assign a sequence number once. For example,

I want to ‘a0,a1,......an is assigned to variables x0 , x1,......, xn,’

I used command line as following :

seq(x[i], i = 1 .. 5) := [1, 2, 3, 4, 5],error as follows,‘Error, invalid left hand side in assignment’
Any  suggestion?

 

I need help on solving the following PDE by Maple:

https://math.stackexchange.com/questions/3177491/how-to-solve-the-given-partial-differential-equation

I couldn't write the partial differential equation in Mapleprimes so provided the link from somewhere else. Please help. Thank you.

f :=2*sin(x^2/2)-sin(1*x/2)^2 In the interval [1,2] Find to the 10 significant figures the value of the second derivative at turning point

Hi, 
I'm very stunned by the results displayed in the worksheet below.
It seems that adding extra assumptions on a variable already constrained with "assume" has disturbing side effects ?

Here is a simplified worksheet that exhibits the phenomenon.
Basically I want to solve the equation a*x-b =b with respect to x.
In a first step I set assumptions on a and b and Maple returns x=0, as expected.
Next I add a new condition on b and ask Maple to solve the equation again. I intain this strange result: x=(b~ - b~)/a~.

Am I doing something wrong?

Thanks in advance


 

restart:

anames(user);

assume(a > 0):
assume(b > 0):

f := a*x+b

a*x+b

(1)

g := f=b:
simplify(g);
solve(g, a);

a*x+b = b

 

Warning, solve may be ignoring assumptions on the input variables.

 

0

(2)

anames(user);

b, g, f, a

(3)

additionally(b > a)

h := f=b:
simplify(h);
solve(h, a);

a*x+b = b

 

Warning, solve may be ignoring assumptions on the input variables.

 

anames(user)  # additionally(b > a) doesn(t introduce a new variable

b, h, g, f, a

(4)

indets(g);
indets(h);  # why do I have b~ twice ?
            # This is probably the reason why solve(h, a) doesn't work

{a, b, x}

 

{a, b, b, x}

(5)

lprint(indets(h))

{a, b, b, x}

 

# strange...

solve(h, indets(h)[1]);

simplify(%);

Warning, solve may be ignoring assumptions on the input variables.

 

-(b-b)/x

 

-(b-b)/x

(6)

# remark, dismantle explains nothing about the distinction between b~ and b~


EQUATION(3)
   POLY(6)
      EXPSEQ(4)
         NAME(4): a
         NAME(4): b
         NAME(4): x
      DEGREES(HW): ^2 ^1 ^0 ^1
      INTPOS(2): 1
      DEGREES(HW): ^1 ^0 ^1 ^0
      INTPOS(2): 1
   NAME(4): b
 

 

dismantle(h)


EQUATION(3)
   POLY(6)
      EXPSEQ(4)
         NAME(4): a
         NAME(4): b
         NAME(4): x
      DEGREES(HW): ^2 ^1 ^0 ^1
      INTPOS(2): 1
      DEGREES(HW): ^1 ^0 ^1 ^0
      INTPOS(2): 1
   NAME(4): b
 

 
 

 


 

Download MultipleAssumptions.mw

 

binomial(x, -1) should be 0 for any x which is not a negative integer.

When assuming x to be a positive integer, the command binomial indeed yields 0:

assume(x, posint); binomial(x, -1);

0

but when assuming x to be non-integer, the binomial command seems to ignore the assumption:

assume(x, Non(integer)); binomial(x, -1);
binomial(x, -1)

How to force the binomial command to take into account all assumptions?

Hello, 

I hope you are doing well. I have the followig equation which I want to solve w.r.t.o (x). Maple took more than 12 hours for evaulation and still no solution. What could be the reason? Could you please help. 

 

 

(.5*(-sqrt(1/(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2)+1)+1/(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2)+1))/(2/(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2)+2)+(.5*(-sqrt(1/(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2)+1)+1/(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2)+1))/(2/(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2)+2) = (1/2)*sqrt(2)*(2*(-2^1.5*sqrt(.5*sqrt(2*(1-x))^2)/(2*sqrt(2*sqrt(2*(1-x))^2*.5+1))+sqrt(.5*sqrt(2*(1-x))^2)/(2*sqrt(.5*sqrt(2*(1-x))^2+1))+.5)-sqrt(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2)/(2*sqrt(2*(sqrt(2*x)+sqrt(2*(1-x)))^2*.5+1))-sqrt(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2)/(2*sqrt(.5*(sqrt(2*x)+sqrt(2*(1-x)))^2+1))-.5+sqrt(.5*(2*sqrt(2*x)+sqrt(2*(1-x)))^2)/(2*sqrt(2*(2*sqrt(2*x)+sqrt(2*(1-x)))^2*.5+1))+sqrt(.5*(2*sqrt(2*x)+sqrt(2*(1-x)))^2)/(2*sqrt(.5*(2*sqrt(2*x)+sqrt(2*(1-x)))^2+1))+.5+(sqrt(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2)/(2*sqrt(2*(sqrt(2*x)-sqrt(2*(1-x)))^2*.5+1))+sqrt(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2)/(2*sqrt(.5*(sqrt(2*x)-sqrt(2*(1-x)))^2+1))+.5)-sqrt(.5*(2*sqrt(2*x)-sqrt(2*(1-x)))^2)/(2*sqrt(2*(2*sqrt(2*x)-sqrt(2*(1-x)))^2*.5+1))-sqrt(.5*(2*sqrt(2*x)-sqrt(2*(1-x)))^2)/(2*sqrt(.5*(2*sqrt(2*x)-sqrt(2*(1-x)))^2+1))-.5)*c

As a challenge problem.  At what x,y coordinate does circle B (radius r) make contact with circle A (radius R)?  Let's suppose the center of circle A is at (0,0).  The height circle B sits at, is d above the 0 x-axis. 

 

I'm trying to create an ellipsoid using spherical coordinates.

 
                   "x^2 + y^2/4 + z^2/9 = 1" how can I enter this?

This is what I have , but shape show up really crazy

plot3d([cos(theta)*sin(phi),sin(theta)*sin(phi),cos(phi)],theta=0..2*Pi,phi=0..Pi,scaling=constrained,axes=boxed);

Thanks

[An edited and reposted version of this Question, which has subsequently been deleted, specifically asked that the plot be done by making a small adjustment to Maple's spherical coordinates. The deleted version also named the ellipsoid E, a detail which is important for understanding correctly the OP's subsequent integration Question. --Carl Love acting as a Moderator]

First 394 395 396 397 398 399 400 Last Page 396 of 2120