adnan06

77 Reputation

4 Badges

14 years, 322 days

MaplePrimes Activity


These are replies submitted by adnan06

As I have said in my previous post I included a jpg picture and it worked correctly also it was exported from maple because that is actually what we want, to include the maple ouput graphs in our documents. Please pay attention to the following: 1- according to my experience MOST of the error messages (whether in maple, latex or any other softwar) are not really related to what cause the problem, sometimes we need to ignore the message and check in different ways. 2- be sure that you include \usepackage{graphicx} 3- open your jpg image and be sure that its exported correctly by maple ( I mean you can open and see it). 4- Maple, latex and anyother software sometimes keep working on the old data even if you have changed it. I think it might have something if we might call a buffer or an internal temporarily memory which sometimes does not modify the data( I say maybe) so try to restart your applications or sometimes its also useful to restart your pc. I also do that in problematic cases and sometimes it really helps. 5- delete your jpg and export it all over again from maple and re-include it in latex. If the above mentioned points dont help please send me your tex file the jpg image by e-mail so that I can check for you, maybe I can help. check your private "my inbox" of your mapleprimes account to see my e-mail address. Thanks
As I have said in my previous post I included a jpg picture and it worked correctly also it was exported from maple because that is actually what we want, to include the maple ouput graphs in our documents. Please pay attention to the following: 1- according to my experience MOST of the error messages (whether in maple, latex or any other softwar) are not really related to what cause the problem, sometimes we need to ignore the message and check in different ways. 2- be sure that you include \usepackage{graphicx} 3- open your jpg image and be sure that its exported correctly by maple ( I mean you can open and see it). 4- Maple, latex and anyother software sometimes keep working on the old data even if you have changed it. I think it might have something if we might call a buffer or an internal temporarily memory which sometimes does not modify the data( I say maybe) so try to restart your applications or sometimes its also useful to restart your pc. I also do that in problematic cases and sometimes it really helps. 5- delete your jpg and export it all over again from maple and re-include it in latex. If the above mentioned points dont help please send me your tex file the jpg image by e-mail so that I can check for you, maybe I can help. check your private "my inbox" of your mapleprimes account to see my e-mail address. Thanks
Hello alec and all, When I apply the proc for the newton's basins of attraction posted here by alec I get the following error message in both maple8 and maple 10. Error, (in plot/options2d) unknown or bad argument: s_tyle = patchnogrid and when I remove s_tyle = patchnogrid I got images with very bad colors which absolutely dont look the same as posted here. Anyone over there know the cause and the solution? Thanks.
Thanks a lot acer
Thanks a lot acer
Dear Acer; Thank you very much for your support. When I put your source code in mape it works perfectly because you put X[61]:=X[60]: before the loop but when I applied your idea to my program exactly as follows: ( I need this for plotting the fixed point iteration) > with(plots): > x:=Vector(100,(i)->i): > f:= x -> a*x - x^2: > a:= 2.8: > p:= plot({f(x),x},x=0..2.5): > x[0]:=1.5: > for i from 0 to 100 do > x[i+1] := f(x[i]): > if x[i]=x[i+1] then > k = i: > g:= x[k]: > break; > > end if > > end do: > for j from 0 to k do > stair:= x -> plot([[x,x],[x,f(x)],[f(x),f(x)]]): > end do: > display({p, seq(stair(x[i]), i=0..k)}); k; x[k]; I got the following error messages which I dont understand what they exactly mean: Error, (in rtable/Power) exponentiation operation not defined for Vectors Error, Vector index out of range Error, Vector index out of range Error, Vector index out of range can you please solve this. Thanks again
Dear Acer; Thank you very much for your support. When I put your source code in mape it works perfectly because you put X[61]:=X[60]: before the loop but when I applied your idea to my program exactly as follows: ( I need this for plotting the fixed point iteration) > with(plots): > x:=Vector(100,(i)->i): > f:= x -> a*x - x^2: > a:= 2.8: > p:= plot({f(x),x},x=0..2.5): > x[0]:=1.5: > for i from 0 to 100 do > x[i+1] := f(x[i]): > if x[i]=x[i+1] then > k = i: > g:= x[k]: > break; > > end if > > end do: > for j from 0 to k do > stair:= x -> plot([[x,x],[x,f(x)],[f(x),f(x)]]): > end do: > display({p, seq(stair(x[i]), i=0..k)}); k; x[k]; I got the following error messages which I dont understand what they exactly mean: Error, (in rtable/Power) exponentiation operation not defined for Vectors Error, Vector index out of range Error, Vector index out of range Error, Vector index out of range can you please solve this. Thanks again
First of all I would like to thank you Mr. Robert Israel for you example and explanation. On the other hand I want to make some correction to my question concerning the second polynomial; well in my question I mentioned x^3 -1 but I ment to say X^3 + 1 this is a real polynomial of one variable (x) but it has a mix combination of real and complex roots namely: {−1, 1/2 +(3)^0.5/2 i, 1/2 −(3)^0.5/2 i}., thats why when substituting this poly. into your code would not work proporly as expected because the graph of the basin (as I think) should be performed with densityplot and (as I think there should be a code that works for all real polynomials whether they have real or complex roots the paper http://www.polymatica.com/Pmindexpdfs/Pmnrarticle.pdf shows such examples with the figures but does not say anything about how the maple program has been done. well I hope that my problem is now made clear and I hope to find an answer because it really exists but I dont know it.
First of all I would like to thank you Mr. Robert Israel for you example and explanation. On the other hand I want to make some correction to my question concerning the second polynomial; well in my question I mentioned x^3 -1 but I ment to say X^3 + 1 this is a real polynomial of one variable (x) but it has a mix combination of real and complex roots namely: {−1, 1/2 +(3)^0.5/2 i, 1/2 −(3)^0.5/2 i}., thats why when substituting this poly. into your code would not work proporly as expected because the graph of the basin (as I think) should be performed with densityplot and (as I think there should be a code that works for all real polynomials whether they have real or complex roots the paper http://www.polymatica.com/Pmindexpdfs/Pmnrarticle.pdf shows such examples with the figures but does not say anything about how the maple program has been done. well I hope that my problem is now made clear and I hope to find an answer because it really exists but I dont know it.
Page 1 of 1