longrob

Mr. Robert Long

1409 Reputation

18 Badges

14 years, 262 days
Leeds, United Kingdom

Social Networks and Content at Maplesoft.com

Business Consultant Data Scientist Statistician

MaplePrimes Activity


These are questions asked by longrob

Greetings Is there a nice way to obtain the jacobian of a system of ODEs ? For example with restart: ross_x:=diff(x(t),t)=-y(t)-z(t): ross_y:=diff(y(t),t)=x(t)+a*y(t): ross_z:=diff(z(t),t)=b+x(t)*z(t)-c*z(t): rossler_sys:=ross_x,ross_y,ross_z; I can't seem to find an easy way to do it, other than re-write the system altogether s_x:=-y-z: s_y:=x + a*y: s_z:=b+z*(x-c): J:=Matrix([[diff(s_x,x),diff(s_x,y),diff(s_x,z)],[diff(s_y,x),diff(s_y,y),diff(s_y,z)],[diff(s_z,x),diff(s_z,y),diff(s_z,z)]]); .....which seems horrible. Thanks LR
Greetings
Hi all I see it is very easy to define a simple function in Maple using -> But what if more than a single expression is needed and if local variables are needed ? Is there a way to put several statements and use local variables in a function definition ? For example to define a function that takes a list as it's argument and returns the arithmetic mean or the simple sum. Must such things be done with a procedure ? Thanks !
Hi all I have > tst:=-(1-cos(p))/p^2+1/2*cos(1/4*p)^2*cos(1/8*p)^2*cos(1/16*p)^2: >plot(tst); which seems to work OK. However, this generates an error plot(tst,Pi..2*Pi); Warning, unable to evaluate the function to numeric values in the region; see the plotting command's help page to ensure the calling sequence is correct Plotting error, empty plot ...as does any other range I have tried. I guess it's something very simple, but if someone can point me in the right direction I would appreciate it !
I'm very new to maple and I've been experiencing a few difficulties. One in particular is quite frustrating: when opening a worksheet in classic worksheet mode I get a message that it was created in an earlier version, and after clicking OK maple crashes. For example, with the document here: http://www.maplesoft.com/applications/view.aspx?SID=1404 I am using Maple 12. This problem does not occur in standard gui mode, only classic worksheet mode but for a variety of reasons I wish to use classic as much as possible. Thanks
1 2 3 4 Page 3 of 4