MaplePrimes Questions

Hi I am trying to combine a previous, numerically obtained result in a subsequent calculation: outline: suppose i have a given function, f(x), and i wish to construct the following boundary value problem: y''(x)=f(x), y(0)=1, y(1)=2 the known function f(x) is a result of another calculation, which i have obtained numerically. (f(x)=proc(x)...end proc, or something to that affect). code: -------------------------------------------- > restart; > sys := {diff(y(x), x) = x, y(0) = 1}; / d \ { --- y(x) = x, y(0) = 1 }
How can I create the inert form of the following function: dm:=z->diff(z,t)+v[c]*d_[c](z); Note d_ is the new indicial differential operator available in physics package of Maple 11. Its inert form is %d_. What I need is that when I write, dm(rho), maple does not expand it into two terms using the above function, but displays the compact form dm(rho). I want to see the expanded form, only when needed, not at every step where dm is used. So at other steps, I just want to see dm(rho), without evaluation. Thanks, Pawan Takhar
In the example below, the plot option axesfont affects both axes in Maple 10.06, but in Maple 11.01 it affects only the vertical axis. Is this a feature, or a bug? If it’s a feature, how can I change the font of the horizontal axis tickmarks?

dates := [0 = "21/8/00", 140 = "8/1/01", 536 = "8/2/02", 885 = "23/1/03", 1267 = "9/2/04", 1628 = "4/2/05", 2004 = "15/2/06", 2200 = "30/8/06", 2479 = "5/6/07", 2531 = "27/7/07"];
xy := [[0, 2.5], [140, 2.2], [536, 2.6], [885, 2.5], [1267, 3.3], [1628, 3.1], [2004, 5.0], [2200, 3.0], [2479, 5.9], [2531, 4.3]];
This question was already raised before. Does Maple 11 "fortran" command generates code which is compatible with Fortran 90 (or 95)? I have a problem in several respects, especially in the syntax of "continuation" lines. How can I generate Fortran 90 syntax. To be more specific: When long line is of code is generated 'number' sign is used to continue on the new line. In fortran 90 '&' sign is expected. i.e. fortran 77: #2*rho1(i+32 #)*rho1(i+11)-0.2037715763 instead we need in fortran 90: & 2*rho1(i+32 & &)*rho1(i+11)-0.2037715763 &
I just uploaded the file: I'm running Maple 10.05. The problem is more curiosity and annoyance than practical, at this point, but: If I remove the with(RealDomain) at the top of the file, everything runs fine and a nice plot is produced. Keeping the with(RealDomain) statement, results in ERROR, invalid object in MESH. Can anyone tell me what's going on? Don Ritchie
I need to put all these things together to make a scene, I would like to keep the house,and the clouds as a background plot, and have the tornado and tire move. Sort of like the tornado picks up the tire and then drops it. here is my code its to big for me to save it on here. Using like the animate code, and display codes. Packages: with(plots):with(plottools): Tornado: Actual Tornado: tubeplot([20*t*cos(t),20*t*sin(t),20*t], t=0..20*Pi, radius=-100*exp(.00001*t), tubepoints=10, numpoints=100, color=grey, frames=30): Animated Tornado: rotating around: animate(tubeplot,[[20*t*cos(t+s),20*t*sin(t+s),20*t+s],
I need to calculate derivative of a scalar function psi, which depends upon the scalar theta and tensor G[i] using the diff command and indicial notation capability of the recently included Physics package. My actual equation is longer, but here I am only including the terms needed to present my question. Please see below:



> with(Physics):


The code below is just to illustrate the issue. Is there any way to keep the chosen scaling and view when the plots are placed within an array? As the code below will show the scaling and view for a plot in an array has a mind of its own! I tried plotting a and b with both plots in them but with one in white - so it looked as if there was only one plot - but that did not work. restart; > with (plots): a:=plot(x^2/10,x=1..50,scaling=constrained,view=[0..120,0..800]): > b:=plot(-x^2+50*x,x=1..60,color=green,scaling=constrained,view=[0..120,0..800]): > display(a,b); > > g:=array(1..2):
Hello Maple community, although I'm using Maple (now version 11) for quite a while now, I still have problems in designing and writing efficient procedures. Within the context of quantum information theory, I want to write a procedure that parametrizes unitary matrices of arbitrary dimension NxN (in order to perform an optimization over this space). For the beginning, I just want to create random unitary matrices of a given dimension. For this, I implemented the formulas for the "Generalized Euler angle parametrization" (math-ph/0205016). This involves first the creation of N^2-1 matrices that serve as generators for SU(N) and, in a second step, several matrix exponentials and matrix products. These two steps I put in two procedures ("hermitian_basis" and "parametrize_unitary_Euler") (see the linked worksheet).
I am writing a large number of variables to file to load into excel - it all works fine - with the code below. But there just has to be a neater way to do it. Can anyone help?
> for t from 1 to nops(files) by 1 do
> fprintf(fd
> ,"%a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t %a\t \n"
I have succeeded in generating a nice plot of a surface in which I am interested, and have calculated geodesics on the surface. Is it possible to display one (or more) geodesic curves on a 3D plot of the surface? If so, would someone point me in the right direction to do so. I've looked at "multiple", but don't see how it's applicable to my problem. Don Ritchie
I'm using Maple 9.5 (xmaple linux version). I can run application with no errors, but when I try to calculate anything, maple doesn't generate any output or results. Even the simplest examples doesn't work (like 2+2;) What may causes problems? Please help me!!
We have a maple 10 site license and I recently started to use maple for some challenging symbolic manipulation. Specifically I wanted to find the 3-dimensional eigenvectors A(u,w) and eigenvalues \lambda for a system of 8 partial differential equations. I was disappointed when maple completed most of the problem finding all 8 eigenvalues but only 6 of the 8 eigenvectors. In fact explicitly issuing Eigenvectors(A) command didn't seem to work as it ran for a long time with out returning so I ended up just issuing a series of LinearSolve(A-\lambda I|0) commands. This worked for the first 6 eigenvalues but for the last pair of eigenvalues maple just didn't do anything simply printing the command I issued. Maple didn't print any diagnostic information to let me know what went wrong. My question is when Maple doesn't evaluate a command how does one obtain information about what went wrong?
Hello to evereybody!! I'm newbie with Maple and I've to do a program that calculates the rank of a Matrix, I can't use the comand rank or similar. I think it's something like: repeat If det(A) =/= 0 then rang := nº rows else reduce(a) until rows=1 or det(a) =/= 0 But i don't know how to codificate it in maple!! Help!!! Thanks for reading my problem... Sorry...If my english is bad i'm not from England or Usa
I was wondering if one could animate a tubeplot. if so i am trying to animate this tubeplot that i created so it can look like a tornado in action. tubeplot([20*t*cos(t+7),20*t*sin(t+7),20*t],t=0..20*Pi, radius=-100*exp(.00001*t), tubepoints=20, numpoints=100, color=grey); and if you can't does anybody know how I can animate a space curve similar to this to make it look like a tornado.
First 2213 2214 2215 2216 2217 2218 2219 Last Page 2215 of 2329