MaplePrimes Questions

Hi all;

I hope all is well with you.

I am regular user of Maple for 7 years. I just reinstalled it to a new version, Maple 2019.

After installation, which was very smooth and without any unexpected problem, I opened a new document and entered a simple task; “sqrt(4);” the answer was

1.81847767202745*10^(-58) + (7.53238114626421*10^(-59))*I

I am pretty sure that I am missing something. The answer is obviously incorrect and there is a problem, but where.

I would be thankful if someone could help me with this issue.




A tank contains 1200 gal of water in which 150 lb of salt is dissolved initially. 50 gal of brine, each (gallon) containing (1+sint) lb of dissolved salt, runs into the tank per minute. The mixture, which is kept uniform by stirring, runs out of the tank at the rate of 30 gal per minute. Denoting the amount of salt in the tank at any time i as m, (a) formulate an ordinary differential equation for studying the dynamics of the amount of salt in the tank, (b) solve the differential equation manually, and (c) write a MATLAB mfile program to solve the differential equation using dsolve command and plot the dynamic response of the system for OSIS 7.5 hr with At = 0.5 min.

I'm trying to compute:


and got:


But I think it should be something close to:




Is this a bug?


Hi all,

I'm using dsolve (numeric) for a system of ODE with initial conditions.

Is it possible to show (at the same time with solving) the values of time and an unknown when solving a system of ODE before the end of calculation. Of course, the calculation time is high and I want to know before the calculation is finished if the solution is converging.

Also, I use the option range in my calculations from 0 to 200s (seconds) and more. I do'nt know how I can speed up the solution with less memory.

Please find in the attached file an example.

Thank you in advance for your help.

Dear Maple users

I have had problems with Maple 2020. I am using Windows 10, by the way, and have several versions of Maple installed: 2019, 2018 and even 2017. Now however I am unable to open a Maple file from Windows Explorer either by double-clicking or by right-clicking and choosing "Open with" Maple 2020. Nothing happens when I try so! It works properly when I choose older versions of Maple. I have about the same problems on another computer, an Ultrabook. It is really a pain having to open Maple 2020 and then having to browse all the way down a file path ... 

NB! I have tried reinstalling, but it didn't help!

I hope someone have an idea how to solve this issue. Can it be solved in the Windows Registry?




I need to plot a contour plots of x versus f that satisfy two following equations

2.884460657-2.884460657*sqrt(1-.6933705250*x)-5.000000000*f*(1-(1-.8*x)^.2500000000)-(12.50000000*(1-f))*(1-(1-.32*x)^.2500000000) = 0;

1/sqrt(1-.6933705250*x)+1.250000000*f/(1-.8*x)^.7500000000+(3.125000000*(1-f))/(1-.32*x)^.7500000000 = 0

How can I do that by Maple?

If the coefficient of x can be changed from 0.1 to 0.6, what is your suggestion(s) to  repeat the above process for each of these coefficients?  


I have been using Alex Potapchik & & Alec Mihailovs' procedure for generating a multivariate sample

How can I plot the eigenvectors in the 3D scatterplot?



kernelopts(version); interface(version)

`Maple 2019.2, X86 64 WINDOWS, Nov 26 2019, Build ID 1435526`


`Standard Worksheet Interface, Maple 2019.2, Windows 10, November 26 2019 Build ID 1435526`


with(LinearAlgebra); with(Statistics); with(plots)

MultivariateNormalSample := proc (Sigma, V, N) local d; d := LinearAlgebra:-Dimension(V); LinearAlgebra:-LUDecomposition(Matrix(Sigma, datatype = float[8]), 'method' = 'Cholesky').ArrayTools:-Alias(Statistics:-Sample(Normal(0, 1), d*N), [d, N])+ArrayTools:-Replicate(Vector[column](V, datatype = float[8]), 1, N) end proc

Cov := Matrix([[4, 2.5, .4], [2.5, 2, .2], [.4, .2, .5]])

Cor := simplify(MatrixPower(DiagonalMatrix(Diagonal(Cov)), -1/2).Cov.MatrixPower(DiagonalMatrix(Diagonal(Cov)), -1/2))

S := MultivariateNormalSample(Cov, `<,>`(0, 0, 0), 1000); Statistics:-CovarianceMatrix(S^%T); map(Statistics:-Mean, [S[1], S[2]])




Z := Scale(S^%T)

E, V := Eigenvectors(Cor)

E := Re(E); V := Re(V)

Vector(3, {(1) = 2.0005950859349144, (2) = .11194337607751015, (3) = .8874615374875758})


Matrix(%id = 18446746188592589870)


plots:-pointplot3d(Z, axes = normal, thickness = 1, symbol = circle, axis[1] = [color = black], axis[2] = [color = blue], axis[3] = [color = green], color = "DarkRed", orientation = [30, 75], viewpoint = "circleright", symbolsize = 1)





Coming across this post upon investigating relational symbols available in Maple that I am yet to use, (the first listing in the search results):

I again wish to reinforce the motive behind a post I previously made, and that is that a stack exchange maple community would be beneficial to education in general.

I also want to point out that I have no stake in this, I am an average user of both the Stack exchange mathematics domain, and an average user of Maple, neither of which I am employed by or would be in any realistic forseeable future.

How can I put a line to run from a single point on the x-axis to the top. Like a like that run at x = 5 axis to the top. 

Du plot two lines but overlapped 

how to set color of each line and choose each line plot on top of layer to confirm overlapped?


Not that I care about the virtual rating numbers here, but I am wondering why would one suddenly lose 15 point after posting a problem they found in Maple? Is this typical?

3 hrs ago, I was 3001  and when I came to check on the status if any, now it says 2986.

Just wondering why, that is all. Again, this really does not bother me at all as I do not care about these virtual cloud credit points, and I only post here on occasions and when I found some problem. I just like to know why this happened just now, that is all. 






When I tried these ODE's in Maple 2019, and Maple 2018, they are worked (i.e. gave solutions). Now these ODE's either hang in 2020 or return unsolved. What could have caused this? On Maple 2020, under windows 10:

dsolve(ode); #hangs

dsolve(ode); # return unsolved

dsolve(ode); # return unsolved

ode:=(diff(y(x),x) = (-y(x)^2+4*a*x)^3/(-y(x)^2+4*a*x-1)/y(x)):
dsolve(ode); #hangs

I noticed that in Maple 2019.2 this problem is also there. But not in Maple 2019.  So something changed from after Maple 2019.

Here is worksheet on Maple 2018 that shows these worked there. But no longer work on Maple 2020. There might be more like these but these the ones I found so far.

Is it possible to define variables with "unit" % or ‰ in Maple?


does not work, it apparently gives you 20 multiplied with the result of the last calculation.

Hi folks!

Is there any way to make this kind of derivative?

If necessary, I can provide the original file here.

Thanks in advance for any help!

If I understand how to use vectors in Maple, I need to give the number of elements.  Is this correct?  I am working with vectors that I do not know the number of elements.  I can use a large number that will be greater than the required number of elements, but this does not seem to be a good solution.  The number of elements is 2000 for about 10 different vectors.  What is the best method to set up the victors for this application?

First 411 412 413 414 415 416 417 Last Page 413 of 2279