MaplePrimes Questions

How do i format numbers in maple output including comma separation and number of decimal points, etc (i.e. 33,444.00)
I'm having some problems with my uni Maple test questions. How do I after creating a partial fraction expansion extract the numerator of the 5th summand in the par frac expansion using a maple command? Also using the geom3d package, how do I set a line using the 'parallel' command which goes through a point and is parallel to another point? (x,y,z) Thanks in advance.
I want to produce a table of values with a heading. I’d like something like a heading with the name “x
In order to generate a 2x2-matrix in the question text I use
$display_matrix =maple("printf(MathML:-ExportPresentation(<<($a),($c)>|<($c),($b)>>))");
where $a, $b, $c are random numbers (see below for full question source).

In MapleTA 2.0.1 the question operates correctly. I quote here an exemplatory call to Maple taken from the console:

jvm 1 | To Maple --> printf(MathML:-ExportPresentation(<<(-4),(6^(1/2))>|<(

However, instead of depicting the corresponding matrix, MapleTA 2.5 depicts the Maple code. That this will happen can also clearly be seen in the call to Maple:

jvm 1 | To Maple --> printf("%m", 'Matrix(2,2,{(1, 1) = -2, (1, 2) = 2*2^(1
/2), (2, 1) = 2*2^(1/2), (2, 2) = -4},datatype = anything,storage = rectangular,
order = Fortran_order,shape = [])');

How does it come that MapleTA 2.5 decides to add "%m" to printf? Is there a possibility to fix this by making appropriate changes in a setup file?

I would be grateful for any hint.

Full question source (the question asks for the eigenvalues of the shown matrix):

mode=Multi Formula@
name=eigenvalues (more ergonomic)@
algorithm=$case = range(1,3);
$c = maple("[sqrt(6),sqrt(8),2][$case]");
$sign = range(-1,1,2);
$b = range(-5,5);
$a = $b+($sign)*($case);
$display_matrix = maple("printf(MathML:-ExportPresentation(<<($a),($c)>|<($c),($b)>>))");
question=Bestimmen Sie die Eigenwerte von $display_matrix.
I've just gotten started with maple (2 days ago). I needed to construct a set whose elements are vectors. During the generation of these vectors, there turn out to be duplicates and I was hoping that the set union operation will get rid of these. Instead, I end up with a set consisting of duplicated vectors. Here is a very simplified case that my problem boils down to: with(LinearAlgebra); a:=UnitVector(1,2); b:=UnitVector(1,2); #a and b are clearly equal. s:={a,b}; #s should be just the singleton set. But it gives s as being a 2 element set with this vector repeated.
While using Maple 10 at school I ran into an error when trying to plot a spacecurve within a 3D plot. When I enter: > A:=spacecurve([2*x,0,0],t=0..1); I get: A := PLOT3D(CURVES([[undefined,undefined,undefined],[undefined,undefined,undefined].. That take up half the screen. If I try to plot this, there is no curve on the plot, but I can see the axes. WinXP SP2 1024Mb RAM (I think) Nvidia Ti-4200

I want to ask about a small problem. I will present a paper at a conference in February. Because it involves time consuming calculations of numerical solutions for several onerous systems, I will do the calculations at home before the talk, save the results, and show the output to the conference. The folks attending the conference are not necessarily Maple Folks, so I do not want to have to explain the tilde after characters for which I have made assumptions. Of course, I know about


After making the calculations here at home, traveling to the meeting, opening the file to make the presentation then, alas, the tildes are back again. Try this.

> assume(a, real):
> interface(showassumed=0):
> equa:=a^2+a-1;

Run this file. No tilde. Close the file saving the output. Open the file. There is the tilde after each “a".

My question:is there some way to make the tilde stay gone when I save such a file and reopen it without recalculation the worksheet?

Does anyone know how to use the Maple workheet "Mma" which is supposed to translate Mathematica notebooks into Maple? I got Mma from the Maple site ( Is appears easy. Initialize the process with the commands interface(warnlevel=0): interface(displayprecision=4): with( MmaTranslator ): The give the tranlator the location of the Mathematica notebook with FromMmaNotebook( "C:/Notebooks/mmaSampler.nb" ); Even though I've checked the Matematica notebook for accuracy, All I ever get are error messages.
Hi all, I'm a new user'll forgive me if I've chosen the wrong forum. That's my problem: I've used Maple 10 3 or 4 times since the installation, but the last time I've tried to start it, the window was completely GRAY; after about a minute an error message appeared saying something about a 'peripheral error' and 'restart the computer to restore the system' (...sorry for bad translation from italian), the interesting thing is that the system has changed its graphical settings about the monitor resolution (800*600) and colors (I think 4 or 16). An other information... I noticed that a txt file was created just in that time and placed into maple directory: 'hs_err_pid1136.txt'; opening it you can read 'An unexpected exception has been detected in native code outside the VM.
Hi guys ;) I have a question. Is it possible to apply a PID controller with the following parameters(P=6,I=4,D=0.02)to a Non Linear System described with the differentiate equation like this mk*diff(x(t),t,t)+kfv*diff(x(t),t)-(ki^2*u(t)^2*kc)/(mk*(x(t)-x10)^2)-mk*g=0 or in the second form, as two differentiate equations like dx1 := (x1,x2) ->x2; dx2 := (x1,x2) ->((u*ki)^2*kc)/(mk*(x1-x10)^2)-g*mk/mk-kfv*x2/mk; without linearisation in operating point, where u - is input variable, x - position, dx/dt - velocity, d^2x/dt - acceleration ? Thanks for your help.
Delete a file or folder that I no longer want to retain.
Hi. I have a transfer function like this one: y:=(2.5)/((8*s^2+6*s+1)*s); and I can make inverse Laplace transformation in time and plot it by: y1:=invlaplace(y,s,t); plot(y1,t=0..25); I try it also with time delay in transfer function but it doesn`t work. y:=(2.5*exp(-1.5*s))/((8*s^2+6*s+1)*s); > y1:=invlaplace(y,s,t); > plot(y1,t=0..25); So i find a solution in differential equation and make an algorithm to convert transfer function to differential equation. ode := 8*(diff(x(t), t, t))+6*(diff(x(t), t))+x(t) = 2.5*Heaviside(t-1.5); ics := x(0) = 0, (D(x))(0) = 0;
Hi Maple's experts! I have two questions related to "iso-product" lines (in economics): 1. I draw the following graphs F:=plot3d( min(x,30*y), x=0..20, y=0..20): G:=plot3d( min(20*x,y), x=0..20, y=0..20): display({F,G}); a) How could I graph the contourlevels of the "combined" graphic of F and G? b) Obviously, the contourlevels are not convex.. it would be possible to "convexify" that?. 2. How could I do the same a) and b) if F:=plot3d( min(x,30*y), x=0..20, y=0..20): G:=plot3d( min(20*x,y), x=0..20, y=0..20): H:=plot3d( 3*(x*y)^(1/2), x=0..20, y=0..20); display({F,G,H});
I want to compile the appended code snippet from HelpExamples.c into a DLL using MSVC6 and added C:\Programme\Maple10\extern\include as well as C:\Programme\Maple10\ as pathes to the project. After compiling I get the following error message for linking: Linking... Creating library Release/MapleAPI.lib and object Release/MapleAPI.exp MapleAPI.obj : error LNK2001: unresolved external symbol __imp__ToMapleString@8 It seems that i miss an import library - what should I do (except having a break for some more coffee)? Sh... upload does not work for 2 kB - exceeds maximum file size
I am trying to solve an equation and I receive this: "Error, (in fproc) unable to evaluate expression to hardware floats" Please help
First 2277 2278 2279 2280 2281 2282 2283 Last Page 2279 of 2298