MaplePrimes Questions


I'm trying to rearrange a transfer function to get my s^2 term with other specific terms . Below is the denominator of the transfer function. I know that my goal is to get (Izz*u)/m for the s^2 term, so I divide by Df*Dr*(a+b)*u*m, as shown below.

However, if we look at the s^2 terms for now, the equation should be further simplified leaving me with simply (Izz*u)/m, but Maple doesn't want to do this for some reason, and if I use simplify on the above expression it tries to expand everything again, and forgetting about my collect(fun, s).


Is there any way to get around this?


Many thanks


Dear all

I have a function g that I compute its limit at x0 

but when I compute series(g(x),x=x0) then I compute the limit of the series I get different limit


Many thanks for your help


I have a piecewise equation,and two Sum (one of them is infinity and the other has upperband k). I need a numerical value for F2. 

H := r->; piecewise(r < 1, 1);

XF := x-> 2;

f1 := k-> sum(XF(j)*(1-H(j)), j = 0 .. k);

F2:=sum(f1(i), i = 0 .. infinity);


This is a question more or less related to this one Is it possible to define variables with unusual na... but I think it's better to open a new thread. If some think otherwise, please feel free to displace it to the link above.

I want to relabel the vertices of a graph by using special characters.
It happens that this works perfectly if I do not impose the style of the drawing but that it doesn't if I set, for instance, spring=style.
In the attached file you will see that the subsitution of the old vertex names by the new ones doesn't work if apply it directly on the many operators of the PLOT command contains.

Is this behaviour fixed in more recent versions of Maple or it's still present?

Why does Maple not have texture fill for plotting. Even the old Pascal had it.

Maple Help points out

All Programs>Maple 2017>Classic Worksheet Maple 2017

link that I do not have. Is there a reason for this and how do I fix this?


I don't understand whats wrong with my code
    local y
    if (x=1)
    end if; 
    return y
    end proc    

Error, reserved word `if` unexpected

I'm also having trouble getting this code to work:

    if (x= infinity)
    return 1 ;
        return 0;
        end if; 
    end proc 
theres no error but h(0) just returns h(0) not either value as I would like

Dear All,

How do I use the piecewise function z[k]:=piecewise(k<>0,0,k=0,1) in the loop 

for k from 0 to 10 do



i want the value of z[k] to be automatically used in the loop for the corresponding value of k

Graph the real roots of the equation x3 + (a − 3)3x2 − a2x + a3=0 for a ∈ [0, 1].



for i from 1 to 3 do


print(plot(R||i(a),a=0..1,numpoints=500)); end od:


Is there a simplier way to solve this. If not why did they choose this path?

@Carl Love 

Ages Group JOHOR
0-4 118
5-9 174
10-14 374
15-19 597
20-24 670
25-29 677
30-34 516
35-39 407
40-44 291
45-49 196
50-54 155
55-59 101
60-64 66
65-69 34
70-74 21
>75 9
Grand Total




Can you help me to make a 1D plotting by using this data? 

Dear all

Can we use maple to compute integral using the residual theorem


We can consider the contour a circle that contains one pole (Ipi/2)

Many thanks


Hi! I have been trying to calculate the value of theClenshaw derivative. I can get the regular clenshaw to work but not the derivative. I'm going off of the thread ( (P.s notice I have halfed the A[z+1] term. I have tried both ways but the overall result is wrong so I am guessing something more important is wrong).

This is my code so far

local i,k,A,B: global Clen1D_Dx: 

A := Vector(z..Nm+1+z);
B := Vector(z..Nm+1+z);

for k from Nm-1+z by -1 to 1+z do
A[k] := C[k] + 2*s*A[k+1] - A[k+2]:

for k from Nm-1+z by -1 to 1+z do
B[k] := 2*A[k+1] + 2*s*B[k+1] - B[k+2]:
Clen1D_Dx :=  A[z+1]/2 + s*B[1+z] - B[2+z]:


Where z could be 0 or 1 depending on what index your C array starts at. C is the array of chebyshev coefficients of a Chebyshev series appromating u(x) for example. The Chebycoeff1D procedure calculates the Chebyshev coefficients  and the code below calls the procedure for a specific function. Try it with some values of xM, for example 4-10.

local Cfac,fac1x,fac2x,k,K;

  for k from 1 to Nn do 
  od; unassign('k'):                    
  for K from 1 to Nn do
nn := 1.0:
Lc := 0.0: Rc := 1.0:

Once you have the C array call Clenshaw_Dx_1D. For example

Clenshaw_Dx_1D(0,C,xM+1,0.0);  # Evalutes f'(x) in the middle of the domain.

Check with

subs(x=0.5, diff(func,x));

The overall "pattern/shape" of the derivative values is correct, just not the amplitude/values. Any help here? Where is the Clenshaw derivative procedure going wrong.

I have a region that can be graphed by A := plots:-inequal([evalc(abs(z)) < 3, evalc(1 < abs(z - 1))], x = -5 .. 5, y = -5 .. 5)

From there, I need to use the transformation 

M := (3 + sqrt(5))/2*(z - x1)/(z - x2) where x1 := (9 - sqrt(45))/2 and x2 := (9 + sqrt(45))/2 


How do I do this? Do I need to extract data points from the first graph? Is there an easier way to do this? 

I would like to plot a hyperbola using the polarplot command, such as the following:

polarplot(3/(1-1.5*sin(theta)), coordinateview = [0 .. 10, 0 .. 2*Pi])

But the graph includes the asymptotes, which I would not like to be included. I have tried the discont=true command, but it completely changes the shape of the graph and no longer looks like a hyperbola:

polarplot(3/(1-1.5*sin(theta)), coordinateview = [0 .. 10, 0 .. 2*Pi], discont = true)

 How would I get the hyperbola above to display with no asymptotes?


The Library:-RedefineTensorComponent in the physics package has got some serious problems, I guess in the update. It is not assigning the components at the right location for a tensor of rank 4 and above. It is working for tensors of rank 1, 2 and 3. Can someone please look into the issue and help out?

I am attaching the code with an example to indiacate the problem.

First 444 445 446 447 448 449 450 Last Page 446 of 2261