MaplePrimes Questions

with(GroupTheory):

st := time();
RightCosets(SymmetricGroup(10), SymmetricGroup(11));
time() - st;

0.047

Note GroupOrder(SymmetricGroup(11)) is 39916800. It is a very large group. This seems unimaginable to me. Can I know how maple does it?

How do I access numerical formatting from command line?

The help page shows you how to use the point and click menus to change the numerical formatting. It works fine but I want a command to convert from say decimal to scientific notation. Am I missing something?

Here the gui menu on the right hand side of a typical worksheet.

This is the help page for "Numerical Formatting" but there is not much about commands, just the point and click menus. If anyone knows where to search for these commands, please respond. Thanks.

https://maplesoft.com/support/help/maple/view.aspx?path=worksheet/expressions/numericformatting

Hi.  I am using the linux version of Maple.  I seem to experience more bombs in Maple/Linux vs MathCad/Windows.  The program just froze as I was entering text.  Just text.  It is not a disaster since I make very frequent saves.  But it is very annoying.  I was a heavy user of MathCad from about 2005 to 2019.  In the early days, it bombed a lot.  But I do not recall that it ever bombed when I was entering text.  Any suggestions?  Would there be a limition on the number of text characters?  Is it Linux?  Other than this problem, it is a great program.

Hi,

I have been looking for a solution to my problem since last night, but I have been unsuccessful. My problem is that the Column command is not recognized in some Maple worsheets. This problem might occur with other commands too, but most commands seem to work fine. It also only seems to happen in some (not all) worksheets. I just tried creating a new Maple sheet where all I do is create a 2x2 matrix and apply the Column command, but the command is not recognized.

Any ideas? Thanks.

John

Hi, I'm begginer to Maple,

I imported matrix from csv file by this comand:

tab1:= ImportMatrix(source,skiplines=1);
and some of the parts of the source csv file are blank. can i replace these places in matrix with zero somehow please?

Thank you for your answers.

 

The Examples section on the help page of a command is important for learning, but cannot cover all uses. This is especially true for general purpose commands like "solve" or "simplify". Searching all help pages that contain the word "solve" results in too many irrelevant hits that do not contain examples.

Why does adding a bracket to a command not filter for help pages with examples using the command?

Inside a help page Find/Replace finds such strings.

Hi, guys. 

I have a question with D(D)^k, where D is a diagonal matrix,k>=0,for example

D:=<<6, 0> | <0, -1>>

I want Dk to be simplified to the form

<<6k, 0> | <0, (-1)k>>

How can I get it?

TKS in advance!

Hello,

Is it possible to have a common legend for different figures? I can plot them as Array of Plots (below) but then they each have a legend. 

Is it possible to have the two figures side by side and a common legend in the middle?

Thank you!

restart:
with(plots):
A := Array(1 .. 2):
A[1] := plot([2*sin(x), 3*sin(x)], x = -Pi .. Pi, labels = [x, b*sin(x)], color = [blue, red], legend = ["Case of b=2", "Case of b=3"]):
A[2] := plot([2*cos(x), 3*cos(x)], x = -Pi .. Pi, labels = [x, b*cos(x)], color = [blue, red], legend = ["Case of b=2", "Case of b=3"]):
display(A);

Recently, I tried to write a function to get the lexicographic product of two graphs.

In  graph theory the lexicographic product G ∙ H of graphs G and H is a graph such that
  • the vertex set of G ∙ H is the cartesian product V(G) × V(H); and
  • any two vertices (u,v) and (x,y) are adjacent in G ∙ H if and only if either u is adjacent with x in G or u = x and v is adjacent with y in H.

I'm trying to write this function as defined after making sure it doesn't exist in maple. I saw a similar post by mathematica stack.

There are many answers in the post, the most interesting to me is the following code, which follows the definition of lexicographic product. 

lexicographicProduct[g1_?UndirectedGraphQ, g2_?UndirectedGraphQ, opt : OptionsPattern[]] := 
 RelationGraph[
   (* two nodes are connected if their corresponding nodes in the first graph are connected *)
   EdgeQ[g1, First[#1] \[UndirectedEdge] First[#2]] || 
   (* or their corresponding nodes in the first graph are the same and their corresponding nodes in the second graph are connected *)
   (First[#1] === First[#2] && EdgeQ[g2, Last[#1] \[UndirectedEdge] Last[#2]]) &,

   (* the vertices are the cartesian product of the two vertex sets *)
   Tuples[{VertexList[g1], VertexList[g2]}],

   (* also allow setting graph options *)
   opt
 ]

lexicographicProduct[CycleGraph[5], CycleGraph[3]]

It utilizes the  function RelationGraph in Mathematica. I feel that this function is generic in nature. So here I would ask maple if they had a similar function.

Function RelationGraph is to generate a graph based on data and a binary relation.

For example, using RelationGraph  I  can get easily  the kth power Gk of an graph G which is another graph that has the same set of vertices, but in which two vertices are adjacent when their distance in G is at most k.

Dis[g1_?UndirectedGraphQ, k_] := 
 RelationGraph[
  GraphDistance[g1, #1, #2] <= k && GraphDistance[g1, #1, #2] != 0 &, 
  VertexList[g1]]
Dis[PathGraph[Range[10]], 2]

If I use maple and do not use the built-in function GraphPower, I might deal with the following.

with(GraphTheory):
with(SpecialGraphs):
graphpower:=proc(G,k):
local choo,edge,vex,g;
 vex:=convert(Vertices(G),list);
 choo:= choose(vex, 2):
 g:= Graph(Vertices(G)):
 for edge in choo do 
     if Distance(G, edge[1], edge[2])<=k  then 
        AddEdge(g, convert(edge,set))
     fi;
  end do:
 return g;
end proc:
s:=graphpower(PathGraph(10),2);DrawGraph(s)

 

 

I believe if the RelationGraph function can be  implemented in maple, the function lexicographicProduct would be easier to obtain.

Hey, guys! My Maple 2020 program does not build a plot. that is, it cuts it off. everything is correct in maple 2015.

plot(140^t*exp(-140)/t!, t = 0 .. 300)

Maple 2015

plot(140^t*exp(-140)/t!, t = 0 .. 300)

 

My maple 2020 creates

 

 

Why???????????

 

How do we plot the least integer function [x]?

I am referring to a function with the following graph

Declaring types of arguments of a procedure or checking type of something when working with lists or Arrays is easy. For example one can easily use A :: list( posint ) or type( B :: 'Array'( polynom ) ), but with MutableSet, the same approach ends with an error;

Error, module does not have a ModuleType member to accept structured type arguments.

I guess it is the same for other objects defined as a module with option object. Is there a recommended way to have type declaration for such objects or MutableSet in specific?

Dear Mapler

I have an expression that consist of power of main variable x. I aim to fetch the coefficient of square root of x for example. I get an error when I am using COEFF(esp, sqrt(x))

Is there any solution?

When I export a very simple Maple 2018 (MaxOS) document to Latex, this tex file results:

 

%% Created by Maple 2018.2, Mac OS X

%% Source Worksheet: untitled 3

%% Generated: Sun Jul 03 16:34:49 CEST 2022

\documentclass{article}

\usepackage{maplestd2e}

\def\emptyline{\vspace{12pt}}

\begin{document}

\pagestyle{empty}

\DefineParaStyle{Maple Bullet Item}

\DefineParaStyle{Maple Heading 1}

\DefineParaStyle{Maple Warning}

\DefineParaStyle{Maple Heading 4}

\DefineParaStyle{Maple Heading 2}

\DefineParaStyle{Maple Heading 3}

\DefineParaStyle{Maple Dash Item}

\DefineParaStyle{Maple Error}

\DefineParaStyle{Maple Title}

\DefineParaStyle{Maple Text Output}

\DefineParaStyle{Maple Normal}

\DefineCharStyle{Maple 2D Output}

\DefineCharStyle{Maple 2D Input}

\DefineCharStyle{Maple Maple Input}

\DefineCharStyle{Maple 2D Math}

\DefineCharStyle{Maple Hyperlink}

\begin{Maple Normal}{

\begin{Maple Normal}{

\mapleinline{inert}{2d}{restart; 1}{\[\displaystyle \]}

}\end{Maple Normal}

}\end{Maple Normal}

\begin{Maple Normal}{

\begin{Maple Normal}{

\mapleinline{inert}{2d}{a := b^2-sqrt(4); "_noterminate"}{\[\displaystyle \]}

}\end{Maple Normal}

}\end{Maple Normal}

\begin{maplegroup}

\begin{Maple Normal}{

\mapleinline{inert}{2d}{a := b^2-sqrt(4); "_noterminate"}{\[\displaystyle \]}

}\end{Maple Normal}

\mapleresult

\begin{maplelatex}

\mapleinline{inert}{2d}{a := b^2-2; "_noterminate"}{\[\displaystyle \]}

\end{maplelatex}

\end{maplegroup}

\begin{Maple Normal}{

\begin{Maple Normal}{

\mapleinline{inert}{2d}{a := b^2-sqrt(4); "_noterminate"}{\[\displaystyle \]}

}\end{Maple Normal}

}\end{Maple Normal}

\begin{maplegroup}

\begin{Maple Normal}{

\mapleinline{inert}{2d}{a := b^2-sqrt(4); "_noterminate"}{\[\displaystyle \]}

}\end{Maple Normal}

\mapleresult

\begin{maplelatex}

\mapleinline{inert}{2d}{a := b^2-2; "_noterminate"}{\[\displaystyle \]}

\end{maplelatex}

\end{maplegroup}

\begin{Maple Normal}{

\begin{Maple Normal}{

\mapleinline{inert}{2d}{}{\[\displaystyle \]}

}\end{Maple Normal}

}\end{Maple Normal}

\end{document}

 

However, when trying to process the tex file in both Overleaf and TexShop the pdf output is only an empty page. No error occurs, i.e. the maplestd2e.sty file is recognised by both Overleaf and TexShop.

 

What is going wrong here?

restart:
eq := a*x^3 + b*x^2 + c*x + d;
 s := x1 + x2 + x3 = -b/a;
 sp := x1*x2 + x1*x3 + x2*x3 = c/a;
 p := x1*x2*x3 = -d/a;
sol:=solve({eq, p, s, sp}, {x1, x2, x3},explicit);                       
 a := 1;
b := -5;
c := 6;
d := -1;
 sol;                           

why is not successfull ?   Thank you.                 

First 63 64 65 66 67 68 69 Last Page 65 of 2195