MaplePrimes Questions


Please help my with my program. First, I'll post the relevant code, then the questions:


with(Statistics); with(LinearAlgebra);

#k is a Vector everywhere in this program
ModeFreq := (k, m)->Norm(<Norm(k, 2), m>, 2);
OscillatorAmplitude :=(n, k, m, x) -> (ModeFreq(k, m)/Pi)^(1/4)*exp(-1/2*x^2*ModeFreq(k, m))*HermiteH(n, x*sqrt(ModeFreq(k, m)))/sqrt(2^n*factorial(n));
DeltaApproxAmplitude :=(x0, N, k, m, x) -> evalf(expand((sum(OscillatorAmplitude(n, k, m, x)*OscillatorAmplitude(n, k, m, x0), n = 1 .. N))/sqrt(sum(OscillatorAmplitude(n, k, m, x0)^2, n = 1 .. N))));
I am a newcomer to Maple, so I am going to assume that my problems are generally simple, and that I should be posting in this Newbie forum. My apologies in advance if I assumed wrong. My problem is that I take an equation that contains a radical as a common factor for several terms, rearrange it so the radical is on one side, square the equation to remove the radical, and then do a change of variables to convert the equation to a quadratic and solve it. All of that goes well, but when I convert back to the original variable and attempt to verify the solution it becomes very complicated, and I can't seem to simplify it enough to verify the solution.
I am trying to post an expression that contains inequality signs, e.g., xx<> problem is it does not display properly thanks
This is a portion of my first Maple program. I included the part that had the relevant code and output of what is going wrong. The problem I am having is in the PlotTable I create. It is a table with specifically defined indices, which gets added to each time through a loop. What each indices refers to is a table of lists, representing an x,y coord pair. The first time an index is added is corrects puts the data. The second time you can see that it added the second data correctly, but it also overwrote the data for the previous index. for k from 1 to nops([indices(thicknesstable)]) do #loop for each structure
Hi! I'm wondering how I'd go about attaching multiple coefficients from a list to a function, while storing the output as a list. An example of a simple case (the only one which I've been able to get to work) is as follows: for j from 1 by 1 to 3 to f_j := j*sin(x) end do And then, when I want to manipulate the output, I have to handle each output element separately. I also know how to attach a list of coefficients from a list, but handling an expression like f_2*tan(23) = 2*tan(23)*x^2 is cumbersome and a bit silly, and not at all adequate for expressions with multiple terms.
I have to solve the nonlinear equation, i give the all indication, but the system also give the error to me. who can help me to solve this problem? my equation is : a[1]:=2:b[1]:=0.01:a[2]:=1:b[2]:=0.01: a[0]:=1:b[0]:=0.01:a[3]:=1:b[3]:=0.01:v:=0.2: RF:=diff(x[1](t),t)=a[0]+a[1]*x[1]+a[2]/(v-x[1])+a[3]*x[2]/(x[1]*(v-x[1])),diff(x[2](t),t)=b[0]+b[1]*x[1]+b[2]/(v+x[1])+b[3]*x[2]/(x[1]*(v-x[1])); > ic:=x[1](0)=5,D(x[1])(0)=0,x[2](0)=1,D(x[2])(0)=0;x[1]*0.2=x[2]; > dsolve({RF,ic},x[1](t),x[2](t),type=numeric); Error, (in dsolve/numeric/process_input) received more than one indication of the dependent vars [x[1](t), x[2](t)]
I've been at it a year, but this is my first attempt to write and use a package. I wrote a module with an exported package and tested it within the worksheet in which I wrote it. I defined the file path with _liblist and both the binary and the source file appeared where I wanted them. I cut and pasted the same path information in attempting to load the program. So I am wondering why it didn't load. I'm using Maple 10.03 on OS X 10.3.9. ********************************************** file "MyMatrices" ********************************************** MyMatrices := module() description "routines for matrices";
> with('ScientificConstants'); > GetElement('Na'); ... atomicweight = ([value = 22.989770, uncertainty = 2.*10^(6(, units = u]), ... So if I do the following, I expect 22.989770 (grams/mol) > evalf(Element('Na',atomicweight)); -26 3.817543727 10 What is happening here? Why does "atomicweight" mean one thing in one context and another in another? Cheers Geoff Russell
I am trying to familiarize myself with the functionality of the Maplet Builder, and I'm having some frustrating problems. Whenever I set a button to change the value of a MathML viewer, for the command, I use the statement MathML[Export](insert Maple statement here), and I receive an argument error. In addition, I was wondering if (while using the builder) there was a way to add some code that evaluates one or more Maple statements (i.e., variable definitions to be used by multiple Maplet components,etc.) that does not affect the value of any of the component properties. I'm used to using the GUI components in worksheet mode which seem to be more flexible in terms of programming actions for components (perhaps only because of my ignorance pertaining to the Maplet builder).
hi; i have a system of 4 equations depending on each other, which cannot be solved explicitly. using the fsolve command reports a solution, however there must be whole bunch of possible quadruples. i tried to fit the fsolve command in a loop, ignoring the previous solutions, without any success. can anybody give me a hint on how to come up with the whole range of possible solution?
Dear all, I evaluate a multiple integral (need to do 6 times). Maple cannot find analytical solution, so i try numerical as follows. But it still dind't give me a solution. Why? Is it because the function is too complex and too many integral? Thanks a lot! R := 250; l := 1500; e := 2000; n := 5; a := 100; alpha := 2000; beta := 2000; h := (x,y,s,t,u,v)->(1/(pi*n*(a^2)))^3 * exp(-(1/(n*(a^2))*((x-alpha)^2+(y-beta)^2+(s-x)^2+(t-y)^2+(u-s)^2+(v-t)^2))); Int(Int(Int(Int(Int(Int(h(x,y,s,t,u,v),x=0..2*R),y=0..l),s=e..2*R+e),t=0..l),u=2*e..2*R+2*e),v=0..l); evalf(%);
When I try to get online help for the optimization package by executing the command: ?Optimization I do not any information on the package at all. The info seems to be missing entirely. For example there is no online info on the LSSolve function. Where is this info hidden? I'm using 10.04 (Mac). Thanks.
Hire There: I am trying to make a contourplot animation of the function u(x,y,t)=exp(-Pi*Pi*t)*sin(2*Pi*x)*sin(2*Pi*y),defined in [0,1]X[0,1] I tried this a := proc (t) densityplot(proc (x, y) options operator, arrow; exp((-1)*Pi*Pi*t)*sin(2*Pi*x)*sin(2*Pi*y) end proc, 0 .. 1, 0 .. 1, axes = frame, style = PATCHNOGRID, colorstyle = HUE, numpoints = 6400) end proc display(seq(a(t), t = 0 .. 1), insequence = true, axes = framed); but it seems that it is not working I really appreciate your help
Can anybody tell me, How to use Dirac Matrices (Direct products of Pauli Matrices) in Maple?
I would like to define J=(y1-y10)^2+(y2-Y20)^2+k*(u1)^2+k*(u2)^2 where y1 is a function of u1 and u2 y2 is a function of u1 and u2 then I need to diff(J,u1), diff(J,u1,u2) Thank you for your support Don
First 2238 2239 2240 2241 2242 2243 2244 Last Page 2240 of 2279