MaplePrimes Questions

I will have excel sheet with minium 500 coulmns and 1000 rows say

For sample to explain my question I attach a demo excel

All my columns have headers

I am looking to find all 2 way multiplication and add them as columns to my excel sheet and return it as a new excel sheet say

The column names for the new 2 way column should be like the

header name of column you are multiply * the name of the other columsn

Now in sample file if i multiple column with name A with column with name B I get a new column with header A*B the header name should be inserted and

Below that all the elements of that A column multiplied  with that of B should come

I am looking to form columns for all possible2  way multiplication for the excel I will give.

As you can see the demo file


Kind help please


I have changed the the global character size from 12 to 14 but it is not stable. Suddenly size 12 is coming up when a try to copy a row to a another row in the same worksheet.

It is very annoying!!

Any tips????



Here is an apparent instance: 



`Standard Worksheet Interface, Maple 2023.0, Windows 10, March 6 2023 Build ID 1689885`






Quite evidently, its supremum cannot be 0. (There are, of course, other approaches to compute it symbolically, yet I just wonder about the cause of this bug.)

Dear all

I have an equation obtained from partial derivable of some functions, I would like to compute the limit when my variable named Pe goes to infinity. 

I hope to get a more appreciate presentation of my code to obtain the limit (  Pe -> + infty)

All derivative are well compute, but How can I add the limit as Pe goes to infinity

Thank you 

Hey everyone,

I've been experiencing some issues with Mapleprimes on my laptop. Whenever I try to access the website, it takes an unusually long time to load, and sometimes it doesn't even load at all. This is quite frustrating as I need to use Mapleprimes for my research work. I've tried accessing the website on other devices, and it works fine, so I'm confident that the issue is with my laptop. Has anyone else experienced this problem? Any suggestions on how to fix it?

Thanks in advance for your help!

Why doesn't Maple simplify sin(x) / cos (y) as tan





Digits := 10


w := GInearest(0+I)





p1 := plot(f(t), t = 0 .. 20000, color = green); plots[display]({p1})



D1 := 15

epsilon := 200000

L := 6500

v := .7



t := 10000



i = sqrt(-1)

i = I


"k(n) := evalf((2 *Pi*n)/(L))"

proc (n) options operator, arrow, function_assign; evalf(2*Pi*n/L) end proc


f(n) = (int(f(t)*exp(-w*k(n)*x), x = 0 .. L))/L


"C(x, t) :=  (∑) exp(-v* t*k(n)- D1 *t*(k(n)^())^(2)- epsilon *t*(k(n))^(4)) *f(n)* exp(w*k(n)* x)"

proc (x, t) options operator, arrow, function_assign; sum(exp(-v*t*k(n)-D1*t*k(n)^2-varepsilon*t*k(n)^4)*f(n)*exp(w*k(n)*x), n = 1 .. 10) end proc


uu10000 := [seq(evalf(C(L-j, t)), j = 0 .. 6500, 100)]

[0.8582270020e-37+0.7071768085e-46*I, 0.8542115620e-37-0.8289193755e-38*I, 0.8422030662e-37-0.1650065052e-37*I, 0.8223146210e-37-0.2455737186e-37*I, 0.7947335229e-37-0.3238382907e-37*I, 0.7597194496e-37-0.3990668010e-37*I, 0.7176019535e-37-0.4705546418e-37*I, 0.6687772885e-37-0.5376326775e-37*I, 0.6137045955e-37-0.5996735584e-37*I, 0.5529014934e-37-0.6560976155e-37*I, 0.4869391210e-37-0.7063782859e-37*I, 0.4164366719e-37-0.7500470239e-37*I, 0.3420554942e-37-0.7866976371e-37*I, 0.2644927960e-37-0.8159900244e-37*I, 0.1844750367e-37-0.8376532722e-37*I, 0.1027510610e-37-0.8514880864e-37*I, 0.2008503850e-38-0.8573685436e-37*I, -0.6275071112e-38-0.8552431450e-37*I, -0.1449829443e-37-0.8451351706e-37*I, -0.2258447115e-37-0.8271423331e-37*I, -0.3045824843e-37-0.8014357420e-37*I, -0.3804631338e-37-0.7682581907e-37*I, -0.4527807059e-37-0.7279217843e-37*I, -0.5208629116e-37-0.6808049422e-37*I, -0.5840773014e-37-0.6273487939e-37*I, -0.6418370476e-37-0.5680530177e-37*I, -0.6936062957e-37-0.5034711554e-37*I, -0.7389050434e-37-0.4342054446e-37*I, -0.7773134955e-37-0.3609012248e-37*I, -0.8084758661e-37-0.2842409660e-37*I, -0.8321035975e-37-0.2049379645e-37*I, -0.8479779638e-37-0.1237297776e-37*I, -0.8559520434e-37-0.4137144557e-38*I, -0.8559520435e-37+0.4137144402e-38*I, -0.8479779639e-37+0.1237297769e-37*I, -0.8321035979e-37+0.2049379630e-37*I, -0.8084758664e-37+0.2842409653e-37*I, -0.7773134957e-37+0.3609012242e-37*I, -0.7389050442e-37+0.4342054433e-37*I, -0.6936062961e-37+0.5034711548e-37*I, -0.6418370481e-37+0.5680530171e-37*I, -0.5840773026e-37+0.6273487928e-37*I, -0.5208629121e-37+0.6808049418e-37*I, -0.4527807065e-37+0.7279217840e-37*I, -0.3804631352e-37+0.7682581900e-37*I, -0.3045824850e-37+0.8014357418e-37*I, -0.2258447130e-37+0.8271423327e-37*I, -0.1449829450e-37+0.8451351705e-37*I, -0.6275071183e-38+0.8552431450e-37*I, 0.2008503694e-38+0.8573685437e-37*I, 0.1027510603e-37+0.8514880865e-37*I, 0.1844750360e-37+0.8376532724e-37*I, 0.2644927944e-37+0.8159900249e-37*I, 0.3420554936e-37+0.7866976374e-37*I, 0.4164366713e-37+0.7500470242e-37*I, 0.4869391201e-37+0.7063782866e-37*I, 0.5529014927e-37+0.6560976160e-37*I, 0.6137045944e-37+0.5996735595e-37*I, 0.6687772877e-37+0.5376326784e-37*I, 0.7176019529e-37+0.4705546426e-37*I, 0.7597194490e-37+0.3990668022e-37*I, 0.7947335225e-37+0.3238382916e-37*I, 0.8223146207e-37+0.2455737195e-37*I, 0.8422030659e-37+0.1650065065e-37*I, 0.8542115619e-37+0.8289193856e-38*I, 0.8582270020e-37]




Could someone explain to me why the Maple online help pages (see here) are still apparently matching the Maple 2021 release for the past few years? Does this mean that all the information on the Maple online help pages is out of date, or just this one specific page is terribly out of date?


I am trying to discretize high order derivatives (typicaly of order 3-4) and I would like to use maple to avoid errors. Using this thread of discussion I got the following minimum example that illustrates the problem I am facing:


# central discretisation u_xx, i=1,..,n-1
dxc:=add([1,-2,1] *~ [u[i+k,j] $k=-1..1])/(h^2);

(u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2



# we need to compute gradient(laplacian) on faces i+1/2,j and i-1/2,j.

#First diff(u_xx,x)|i+1/2,j
d1:=add([1,-1] *~ [dxc[i+p,j] $p=0..1])/(h);
#which should give
d1:=add([1,3,-3,1] *~ [u[i+k,j] $k=-1..2])/(h^3);

(((u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2)[i, j]-((u[i-1, j]-2*u[i, j]+u[i+1, j])/h^2)[i+1, j])/h


(u[i-1, j]+3*u[i, j]-3*u[i+1, j]+u[i+2, j])/h^3



I would like maple to evaluate the first expression for d1 and give the second expression that I wrote manually.

Is there a way to do this ? (using simplify() does't produce anything)



I have posted a question in the last couple of days:

which was taken down by this member:

where (s)he posted in a previous question of mine, that the new question is a duplicate.

You cannot find his/her reply where (s(he states that the question is a duplicate.

I have replied to his/her reply and explained that my new question is not a duplicate.

(S)he deleted his initial reply together with my reply, and substituted it with what you can see on the page now:

Please stop posting completely separate new Question threads on this issue.

This person wrongly declared that my question is a duplicate, and did not even bother to take into account my reply. (S)he can delete whatever (s)he wants, and just barks orders.

Now, is this really normal support behaviour? Why is this person shutting my questions down? Is this the kind of support a person gets for paying for an expensive software?

Where do I escalate this issue?

Kind help to implement the attached flowchart



Just experienced a strange response from Maple when I changed the Font anti-aliasing to enabled.

With Font anti-aliasing disabled I ran evalf(Pi,100) and Maple returned 100 digits - no problem.  I then did some other errands in other programs leaving Maple idle, when I came back I thought I would change anti-aliasing to enabled and see if maybe that's the reason why some users are experiencing icons disappearing etc..

Well I re entered and evalueated evalf(Pi,100) and Maple only output 10 digits.  Huh??? What!? Why?  changed font anti-aliasing back but no joy.  So I closed Maple and I got a pop up

Maybe it was hiding behind Maple I don't know but I don't think it was there until I closed Maple.  It seems this OpenJDK platform I believe is causing a lot of Maple issues.

Whoa!  That's really odd.  My restart was with Maple Font anti-aliasing enabled I performed a evalf(Pi,100) and no problem.  I changed to Font anti-aliasing disabled and evalf(Pi,100) presented me with 10 digits!

What the heck is going on.  This font anti-aliasing enabled caused my Maple to slow down as the screen filled up (as I recorded in a earlier post months ago) and now toggling anti-aliasing causes the outputs to not work as expected.  It's gotta be an open JDK issue. (FYI closing Maple did not produce the same pop-up as earlier - I expect idling maple for a while might)

In the following example, the information in which range fsolve should search for a solution and the range in which a function is defined is somehow redundant. (This example has been adopted from here where fsolve without assumptions does not throw an error but evaluates forever.)

Why can’t fsolve not always assume that the range equals the domain of interest? This would make life easier and provide more solutions to inexperienced users who have not yet learned the need for assumptions.

If there are good reasons (and there probably are) that such an implicit assumption (i.e. range equals domain) would be too restrictive: can’t fsolve give a hint or provide an new option to use ranges as assumptions?

Example with incomplete elliptic integral of the first kind

f := proc (x__0) options operator, arrow; int(1/(sqrt(x__0-x)*sqrt(-x^2+1)), x = 0 .. x__0) end proc

proc (x__0) options operator, arrow; int(1/(sqrt(x__0-x)*sqrt(-x^2+1)), x = 0 .. x__0) end proc


Range := 0 .. 1; plot(f(x__0), x__0 = Range, labels = [x__0, 'f(x__0)'])


f(.5) = 1.524886838NULL

Defining the inverse of f

g := proc (y) options operator, arrow; fsolve(`assuming`([f(x__0) = y, x__0 = Range], [lhs(Range) <= x__0 and x__0 <= rhs(Range)])) end proc

proc (y) options operator, arrow; fsolve(`assuming`([f(x__0) = y, x__0 = Range], [lhs(Range) <= x__0 and x__0 <= rhs(Range)])) end proc


x__0 = g(f(.5)) → x__0 = .5000000000NULL

Now without assumptions

h := proc (y) options operator, arrow; fsolve(f(x__0) = y, x__0 = Range) end proc

proc (y) options operator, arrow; fsolve(f(x__0) = y, x__0 = Range) end proc



Error, (in fsolve) cannot determine if this expression is true or false: abs(Re(x))+abs(Im(x)) <= 0.




I am trying to obtain the solution of the differential equation f'''+ff''-f'^2-Mf'=0, with f(0)=0, f'(0)=1, and f'(5)=0 with M=0.5 using finite element method

But got this error. I attached the file also.




M := .5;



a := 0;



b := 5;



N := 50;



h := (b-a)/N;



nodes := [seq(h*i+a, i = 0 .. N)];

[0, 1/10, 1/5, 3/10, 2/5, 1/2, 3/5, 7/10, 4/5, 9/10, 1, 11/10, 6/5, 13/10, 7/5, 3/2, 8/5, 17/10, 9/5, 19/10, 2, 21/10, 11/5, 23/10, 12/5, 5/2, 13/5, 27/10, 14/5, 29/10, 3, 31/10, 16/5, 33/10, 17/5, 7/2, 18/5, 37/10, 19/5, 39/10, 4, 41/10, 21/5, 43/10, 22/5, 9/2, 23/5, 47/10, 24/5, 49/10, 5]


elements := [seq([i, i+1], i = 0 .. N-1)];

[[0, 1], [1, 2], [2, 3], [3, 4], [4, 5], [5, 6], [6, 7], [7, 8], [8, 9], [9, 10], [10, 11], [11, 12], [12, 13], [13, 14], [14, 15], [15, 16], [16, 17], [17, 18], [18, 19], [19, 20], [20, 21], [21, 22], [22, 23], [23, 24], [24, 25], [25, 26], [26, 27], [27, 28], [28, 29], [29, 30], [30, 31], [31, 32], [32, 33], [33, 34], [34, 35], [35, 36], [36, 37], [37, 38], [38, 39], [39, 40], [40, 41], [41, 42], [42, 43], [43, 44], [44, 45], [45, 46], [46, 47], [47, 48], [48, 49], [49, 50]]


bilinear := proc (u, v, w) options operator, arrow; int(diff(u(x), `$`(x, 3))+u(x)*(diff(u(x), `$`(x, 2)))-(diff(u(x), x))^2-M*u(x)*(diff(u(x), x)), x = w[1] .. w[2])+int((diff(u(x), x))*(diff(v(x), x)), x = w[1] .. w[2]) end proc;

proc (u, v, w) options operator, arrow; int(diff(u(x), `$`(x, 3))+u(x)*(diff(u(x), `$`(x, 2)))-(diff(u(x), x))^2-M*u(x)*(diff(u(x), x)), x = w[1] .. w[2])+int((diff(u(x), x))*(diff(v(x), x)), x = w[1] .. w[2]) end proc


Llinear := proc (v, w) options operator, arrow; v(a)*(diff(w(x), x)) end proc, x = a;

proc (v, w) options operator, arrow; v(a)*(diff(w(x), x)) end proc, x = 0


K := CreateMatrix(N+1, N+1, 0);

CreateMatrix(51, 51, 0)


F := CreateVector(N+1, 0);

CreateVector(51, 0)


for e in elements do x1 := nodes[e[1]]; x2 := nodes[e[2]]; h := x2-x1; Ke := bilinear(proc (x) options operator, arrow; piecewise(x < x1+(1/2)*h, 1-(x-x1)/h, (x2-x)/h) end proc, proc (x) options operator, arrow; piecewise(x < x1+(1/2)*h, (x-x1)/h, (x2-x)/h) end proc, [x1, x2]); Fe := Llinear(proc (v) options operator, arrow; v(x)*piecewise(x = x1, 1, x <> x1) end proc, [x1, x2]); for i in [e[1], e[2]] do for j in [e[1], e[2]] do K[i, j] := K[i, j]+Ke[i-e[1]+1, j-e[1]+1] end do; F[i] := F[i]+Fe[i-e[1]+1] end do end do

Error, invalid subscript selector


K[1, 1] := 1;







K[N+1, N+1] := 1;





u := LinearSolve(K, F)

Error, (in LinearAlgebra:-LinearSolve) invalid input: LinearAlgebra:-LinearSolve expects its 1st argument, A, to be of type {Matrix, list({Matrix, Vector})} but received K


f := unapply(u(x), x);

proc (x) options operator, arrow; u(x) end proc


Warning, unable to evaluate the function to numeric values in the region; see the plotting command's help page to ensure the calling sequence is correct






Given a graph G and a vertex v find the shortest self returning walk from that visits all vertices starts at v and comes back to v.

In the below graph the shortest self returning walk which visits all vertices and comes back to first to started vertex

A function which takes a graph G  and  vertex v as input and returns the length of the  shortest self returning walk of that vertex in the below example 10


I am sorry for the error i just saw the change after reading more in deep


For the vertex 7 the shortest self returning walk from that visits all vertices starts at 7 and comes back to 7 It is a walk so edges can repeat


The closed walk which passes through all vertices minimum from vertex 7 is so length 10. is what it means

so it returns 10.

2 3 4 5 6 7 8 Last Page 4 of 2213