MaplePrimes Questions

Hello,

in Maple 2017 (could not try 2018) the following is a bug;
 

with(LinearAlgebra);
U:= Matrix(4,4, shape=triangular[upper, unit], symbol =u);
-U;

 

It returns the wrong matrix, with +1 on the diagonal and -u_{ij} on the upper part. That is, it changes the sign only of the entries in the upper part. The bug is for any size, and also for lower triangular.

 

I have been trying to use fsolve to iteratively solve a free convection heat transfer problem for a heated vertical plate using units and the ThermoPhysicalData library.  I have received some help and have managed to get rid of the eror messages but I still can't seem to get it to solve.

Here is the code

 

restart;
with(Units:-Standard); with(ThermophysicalData);

conv_VerticalPlate_proc := proc (T__side, T__amb, Area, L, varepsilon, q__i)
 
  local sigma, g, T__s, `T__∞`, T__f, k, rho, Cp, Pr, mu, nu, alpha, beta, Ra__L, Nus__L, h, q__h, q__r, q__total;
  g := 9.81*Unit('m'/'s'^2); sigma := 5.6703*Unit('W'/('m'^2*'K'^4))/10^8;
 
  if type(T__side, with_unit) then
    T__s := convert(T__side, temperature, kelvin)
  elif T__side = 0 then
    T__s := 273.15*Unit('K')
  else
    T__s := T__side*Unit('K')
  end if;
 
  if type(T__amb, with_unit) then
    'T__∞` := convert(T__amb, temperature, kelvin)
  elif T__amb = 0 then
    'T__∞` := 273.15*Unit('K')
  else
    `T__∞` := T__amb*Unit('K')
  end if;
 
  T__f := (1/2)*T__s+(1/2)*`T__∞`;
 
  k := Property(thermal_conductivity, temperature = T__f, pressure = Unit('atm'), air);
  rho := Property(density, temperature = T__f, pressure = Unit('atm'), air);
  Cp := Property(Cpmass, temperature = T__f, pressure = Unit('atm'), air);
  Pr := Property(prandtl, temperature = T__f, pressure = Unit('atm'), air);
  mu := Property(viscosity, temperature = T__f, pressure = Unit('atm'), air);
 
  if type(k, with_unit) and type(rho, with_unit) and type(Cp, with_unit) and type(mu, has_unit) then
    nu := mu/rho;
    alpha := k/(rho*Cp);
    beta := 1.0/T__f;
    Ra__L := g*beta*abs(T__s-`T__∞`)*L^3/(alpha*nu);
    Nus__L := (.825+.387*(Ra__L^(1/6))/(((1+(.492/Pr)^(9/16))^(8/27))))^2;
    h := Nus__L*k/L; q__h := h*(T__s-`T__∞`)*Area;
    q__r := varepsilon*sigma*(T__s^4-`T__∞`^4)*Area;
    q__total := q__h+q__r
  else
    0.1e-6*Unit('W')
  end if
 
end proc;
 
conv_VerticalPlate_proc(31.5*Unit('degC'), 20*Unit('degC'), Unit('m'^2), Unit('m'), .9);

                      100.8567010 Unit(W)
 
conv_VerticalPlate_proc(x*Unit('degC'), 20*Unit('degC'), Unit('m'^2), Unit('m'), .9);
 
                         0.001 Unit(W)
 
fsolve(100*Unit('W')-conv_VerticalPlate_proc(x, 20*Unit('degC'), Unit('m'^2), Unit('m'), .9), x = Unit('degC') .. 100*Unit('degC'));
 

 

I would appreciate help wih this.

 

Thanks

For example if a:=[3,3,1,5,7,8,5,4,4,4,4,3,9]

What is the simplest way, or alternate ways, to remove only one 4 for example from the dataset.

model.mw

after loop how to pick equations automatically solve system of equations??? 

Hi

 

I've just upgraded from v2017.3 to 2018. It worked OK until I installed latest service pack 2018.2.1 (server license provided by my University). Ever since I cannot use Maple. Anything I type I get Typesetting:-mparsed(...) error and the text/command I typed.

 

I’ve contacted our software tech support and they told me to change the typesetting level from advanced to standard and it did fix the problem.

 

But why does it happen in the first place? I’m running Windows 8.1 64bit. Out tech support told me to has something to do with 3D display issue on my machine and told me to bring my laptop on Monday to see if they can resolve the issue.

 

Anyone else have this problem? Why didn’t it happen with older Maple versions? What am I missing by using standard typesetting instead of the default advanced?

Thanks

 

 

 

 

 

 

how can I get a positive output in the following example

solve((hv*hw+lv*lw)/(lv+hv)*(lv+hv) = dw*(lv+hv), hv)

instead of -lv*(dw-lw)/(dw-hw) I would like lv*(dw-lw)/(hw-dw)

Hi. how can maple determine whether a vector is linear compostion of two or more vectors? 
for example w=a*v+b*u so that w is linear compostion of vectors u and v ( a and b are scalar numbers). tnx for the help.

 Given  any graph , I want to  determine the number of cycles of  graph .  What should I do?

I have this equation but maple solve root is 2

Root_eq.mw

Root is 4 x1 =1, x2= 8.95006470,

x3 =0 .6939575785

x4 = -0.6440222825

 


 

Local*Gamma:

v[1](x, t) = v[1]*(-x*v[1]-x*`θv`[2]-v[1]-v[2]+1)

 

v[2](x, t) = gamma*v[2]*(lambda-v[1]-v[2]-eta*(x*v[1]+x*`θv`[2]))

(1)

NULL


 

Download DTM_TO_SOlve.mw

Is there any way to transfer to transfer a table into Maple? I made a table in Google Sheets / Excel and I want to put it in my maple worksheet

 

Thanks in advance

What's going wrong here?

The Matrix is created by using the Matrix Palette. 

It seems that in a matix it is not possible to use division by a noninteger. Is that right?

(I use Maple 2018.2 and this is tested on both Windows and MacOS.)

Kind regards,

Mikkel


 

with*PDE(tools):

`∂`(v[1])/`∂`(t) = v[1]*[-x*v[1]-x*`θv`[2]-v[1]-v[2]+1]

 

`∂`(v[2])/`∂`(t) = gamma*v[2]*[lambda-v[1]-v[2]-eta*(x*v[1]+x*`θv`[2])]

(1)

``


 

Download DTM_TO_SOlve.mw

Hello, for an assignment I was given the task of iteratively calculating the water depth of a flow using Newton's method. For this I tried to create a procedure wich uses a number of input values. The code is listed below;

 

restart;
Newton := proc (n, y0, Q, b, m, k, S0) local A, P, Sf, y, F, dAdy, dPdy, Fdiff, i; global ylist; y[0] := y0; for i from 0 to n do A[i] := (b+m*y[i])*y[i]; P[i] := b+2*y[i]*sqrt(1+m^2); Sf[i] := Q*abs(Q)*P[i]^(4/3)/(k^2*A[i]^(10/3)); F[i] := S0/Sf[i]-1; dAdy[i] := b+2*m*y[1]; dPdy[i] := 2*sqrt(1+m^2); Fdiff := (2/3)*(F[i]-1)(5*dAdy[i]/A[i]-2*dPdy[i]/P[i]); y[i] := procname(evalf(y[i]-F[i](y[i])/Fdiff[i](y[i]))) end do; ylist := [seq(y[i], i = 0 .. n)]; return ylist end proc;

Newton(10, 1, 5, 12, 1, 30, 0.1e-4);
Error, (in Newton) invalid input: Newton uses a 2nd argument, y0, which is missing

 

As you can see, I get an error referring to the second argument y0, which is the starting value of the calculation. The error says the argument is missing, however it is right there in the brackets of the Newton procedure (along with the values of all other parameters). I have tried explicitly stating that y0:=1, and changing the name of the parameter, however that didn't help.

Am I missing something really simple, or is there something wrong with my code?

Thanks in advance.

Hi everybody

I try to save an array of equations in a "mpl file", and then read file and array by command read mpl file. But system error "bad id" occurs. Previously I saved this mpl file by "save" and read array by "read" command. I ran this code several times without any problem, suddenly error "bad id" occurred. When I save mpl file by the code edit region and then read it by "read" in the same or  a new worksheet, the error doesn't happen!
 What is wrong?
"Id" refers to the array index?

Thanks.
Maple 18 and Windows 10

First 431 432 433 434 435 436 437 Last Page 433 of 2141