Unanswered Questions

This page lists MaplePrimes questions that have not yet received an answer

If you could assist; I am trying to set something like an asymptote or upper limit such that my plot below approaches asymptotically (below y =1 ) from negative infinity:

Download Plotting.mw

command completion (when hitting the ESC key) in Maple could be made more useful. It does not seem to support type names for example.

What shows up on the command completion window are  possible commands that start with that partial text.

It does not list other known names by Maple, such as type names and other options.

This makes it hard to use in many places, where one have to remember type names exactly instead of the system helping them by listing all possible type names that start with that string.

Is there a way around this? Will Maple next version support smarter and more complete command completion menu?

 

 

AoA....

sir how we solve partial differential equation by Adomian Decomposition method in maple? plz send me maple code..

Dear all

I tried to compute an integral using trapezoidal rule using two differents methods but I get two different results
trap.mw

Thank you for your help 

Matlab has some great functions package which accomplishes:

  • This function saves a figure or single axes to one or more vector and/or bitmap file formats, and/or outputs a rasterized version to the workspace, with the following properties:
    - Figure/axes reproduced as it appears on screen
    - Cropped/padded borders (optional)
    - Embedded fonts (pdf only)
    - Improved line and grid line styles
    - Anti-aliased graphics (bitmap formats)
    - Render images at native resolution (optional for bitmap formats)
    - Transparent background supported (pdf, eps, png, tiff)
    - Semi-transparent patch objects supported (png, tiff)
    - RGB, CMYK or grayscale output (CMYK only with pdf, eps, tiff)
    - Variable image compression, including lossless (pdf, eps, jpg)
    - Optional rounded line-caps (pdf, eps)
    - Optionally append to file (pdf, tiff)
    - Vector formats: pdf, eps
    - Bitmap formats: png, tiff, jpg, bmp, export to workspace

 

  • Why don't we all together in this forum create a package like that? :) At least I  hope we can create for most important of the functions like cropping border etc. Many Maple users need a code like that.

 

  • I don't know whether we can quickly convert these codes to maple codes or not.  But maybe we use all code in this forum about this and create a new package.

Best regards.

Hi,

I was hoping to run two procs: tgf3 and tgf4 in parallel using Grid, Run and get a faster execution time. As I understood the description of Grid Run, the first call to Grid Run will run in the background and before it is finished the second call Grid Run will start. I do not believe I have that situation in my script. I am not understanding Grid Run. How can this problem be fixed? Here is just a portion of the script using Grid Run:

Use Grid Run 0 for tgf3 and 1 for tgf4. Determine the real time and compare times. The Grid Runs do not appear to run in parallel.

rgt := time[real]();
Grid:-Run(0, `~`[tgf3@op](convert(L, listlist)), 'assignto' = ans3roots);
Grid:-Run(1, `~`[tgf4@op](convert(L, listlist)), 'assignto' = ans4roots);
ans3roots;
ans4roots;

GridRunTime := time[real]() - rgt;
                     GridRunTime := 44.074

Here is my script:

Grid_Run_2.mw

 

Thank you for your help.

When I am using

Polynomialdeal package:

`J := PolynomialIdeal(sys, characteristic = p)`

and calculate the corresponding Groebner basis.

It report this "Error, (in Groebner:-Basis) Segmentation Violation occurred in external routine".

Does anyone know how to fix this error?

Here is the output details.

 GB:=Groebner[Basis](sys,IdealInfo[DefaultMonomialOrder](J),method=fgb);

memory used=712.9MB, alloc=103.8MB, time=4.48
memory used=779.3MB, alloc=111.8MB, time=4.89
-> MGb
 domain: rat_int_cof
F4 algorithm
1: prime=2132425153
 deg  pairs  taken         matrix                                        found
   6     20      1         8 x 1018       238.5 per row,     0.0 MB      1 new,      0 zero     0.007 sec
   8     22      3       310 x 20321      288.7 per row,     0.7 MB      3 new,      0 zero     0.035 sec
   9     28      5       818 x 38796      397.2 per row,     2.5 MB      5 new,      0 zero     0.069 sec
  10     37     18      5118 x 220200     532.9 per row,    20.8 MB     16 new,      2 zero     0.386 sec
  11     83     52     21117 x 653954     835.4 per row,   134.7 MB     35 new,     17 zero     1.844 sec
  12    218    153     84758 x 2148937   1314.0 per row,   850.0 MB    100 new,     53 zero    14.546 sec
  13    690    551    336032 x 6779582   2133.6 per row,  5471.1 MB    310 new,    241 zero   222.741 sec
  14   2256   1875   1144460 x 18963907  3811.9 per row, 33288.2 MB    732 new,   1143 zero  2407.556 sec
  15   5978   5202  error in FGb
Error, (in Groebner:-Basis) Segmentation Violation occurred in external routine

 

 

I have this two expresions

 

e1 := (1/2)*P[psi]^2/(cos(`ϑ`)^2*Ix)

e2 := (1/2)*P[psi]^2/(cos(`ϑ`)^2*Ix)

 

simplify(e1-e2)=-(1/2)*(-P[psi]^2+P[psi]^2)/(cos(`ϑ`)^2*Ix)

 

but 

simplify(-P[psi]^2+P[psi]^2)

is zero 

 

why i dont obtain zero if i use simplify(e1-e2) ??

Download MHD1.mw

 

 

System of equations with boundary conditions are moving?

Also, find the values of unknown variables?

Dear Users!
Hope everyone fine here. I tried (as given bellow) to find the solution of nonlinear system of PDEs via FDM. To solve system of nonlinear equations I used newton raphson method and for higher value of like Mx > 8 the matrix G and G1 (mentioned as red) take alot of time. Can anyone help me to reduce the computational time? Becuase I have to evealuate the solution for Mx = 50.


restart; Digits := 30; with(LinearAlgebra);
T := 1; L := 3; N := 30; Mx := 5; `Δx` := L/(1.*Mx); `Δt` := T/(1.*N);
for i from 0 while i <= Mx do
u[i, 0] := 0.; u[i, -1] := u[i, 1]; tau[i, 0] := 0.; theta[i, 0] := 0.; theta[i, -1] := theta[i, 1]
end do;
for n from 0 while n <= N do u[0, n] := 0.; u[Mx, n] := 0.; theta[0, n] := 1.; theta[Mx, n] := 0.
end do;
for n from 0 while n <= N-1 do
print("Simulation in proccess at time-level n", n+1);
for i while i <= Mx-1 do
Ru[i, n] := simplify((u[i+1, n+1]-u[i+1, n])/`&Delta;t`+(u[i+1, n+1]-2*u[i+1, n]+u[i+1, n-1])/`&Delta;t`^2-(u[i+1, n+1]-2*u[i, n+1]+u[i-1, n+1])/`&Delta;x`^2+25.*(u[i+1, n+1]+(u[i+1, n+1]-u[i+1, n])/`&Delta;t`)-1.5*(theta[i, n]+(theta[i, n+1]-theta[i, n])/`&Delta;t`));
`R&theta;`[i, n] := simplify((theta[i+1, n+1]-theta[i+1, n])/`&Delta;t`+(theta[i+1, n+1]-2*theta[i+1, n]+theta[i+1, n-1])/`&Delta;t`^2-(theta[i+1, n+1]-2*theta[i, n+1]+theta[i-1, n+1])/((15.)*`&Delta;x`^2)-((u[i, n+1]-u[i-1, n+1])/`&Delta;x`)^2/(3.)) end do;
for i while i <= Mx-1 do
`R&tau;`[i, n] := simplify(tau[i+1, n+1]+(tau[i+1, n+1]-tau[i+1, n])/`&Delta;t`-1.5^(-1/4)*(u[i+1, n+1]-u[i, n+1])/`&Delta;x`)
end do;
Sys := `<,>`(seq(Ru[i, n], i = 1 .. Mx-1), seq(`R&tau;`[i, n], i = 1 .. Mx-1), seq(`R&theta;`[i, n], i = 1 .. Mx-1));
V := `<,>`(seq(u[i, n+1], i = 1 .. Mx-1), seq(theta[i, n+1], i = 1 .. Mx-1), seq(tau[i, n+1], i = 2 .. Mx));
G := Matrix(3*(Mx-1), proc (i, j) options operator, arrow; diff(Sys[i], V[j]) end proc); G1 := MatrixInverse(G);
X[n, 0] := Vector(1 .. 3*(Mx-1), 1);
for k1 from 0 to r do
X[n, k1+1] := eval(V-G1 . Sys, Equate(V, X[n, k1]))
end do;
Sol[n] := Equate(V, X[n, r+1]); assign(op(Sol[n]));
if n > 0 then
U := eval(`<,>`(seq(u[i1, n+1], i1 = 1 .. Mx)-seq(u[i1, n], i1 = 1 .. Mx))); Noru[n+1] := Norm(%, 2); print("L[&infin;] norm of &tau;(x,y,t) at time level = ", %);
Theta := eval(`<,>`(seq(theta[i1, n+1], i1 = 0 .. Mx)-seq(theta[i1, n], i1 = 0 .. Mx))); `Nor&theta;`[n+1] := Norm(%, 2); print("L[&infin;] norm of &theta;(x,y,t) at time level = ", %) else print("n < 0")
end if end do

Special request to:
@acer @Carl Love @Kitonum @Preben Alsholm

Hey, im new to maple and have a few questions.

1. Sometimes, when i type e.g. a:=10 the blue evaluate line shows "a = 10" and sometimes it just shows "10"

is there a way to get that straight?

I have created a set of help files using the example templates. After I create the .help file and install it with my package, I can view the help pages in the help viewer. However, when I click on any link within a help page, the target page opens as a worksheet in Maple. I understand this is because I created the hyperlink with a worksheet as the target. However, I don't know where to obtain the help topic name for a help page before it has been created.  I have searched help, but can't find any applicable guidance.  Can anyone tell me how to determine the help topic name when first creating the help pages.

I have attached one of my help file worksheets.     Hlpdiracmatrices.mw

Dear Maple community,

I would really appreciate it if you could tell me how I can solve numerically in Maple the following system of equations (the Maple file containing these equations can be found here: Mapleprime_Q.mw):

 

Thank you very much in advance for you help!

Hello,

When I create a vector in spherical coordinates and map it to cartesian coordinates with Physics[Vectors] package as follows,

restart:with(Physics[Vectors]):
q_:=a _r + b _theta + c _phi
ChangeBasis(q_,cartesian)

I get the answer:

(a*cos(phi)*sin(theta)+b*cos(phi)*cos(theta)-c*sin(phi)) i + (a*sin(theta)*sin(phi)+b*cos(theta)*sin(phi)+c*cos(phi)) j + (-b*sin(theta)+a*cos(theta)) k

which is what I would expect.

But if I try to do that with VectorCalculus package as follows,

q := SetCoordinates(<a, b, c>, spherical)
MapToBasis(q, cartesian)

This gives 

(a*sin(b)*cos(c)) ex + (a*sin(b)*sin(c)) ey + (a*cos(b)) ez

I am confused about this!

The SetCoordinates(<a, b, c>, spherical) command outputs

q:=(a) er  + (b) ephi + (c) etheta

here, a,b, and c are  depicted as the components of the vector q in spherical coordinates, but when I map to cartesian coordinates, a,b, and c are treated as if they were the coordinates in spherical coordinates rather than components-- unlike ChangeBasis in Physics[Vectors] package.

Why are these two different?

1 2 3 4 5 6 7 Last Page 2 of 279